summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-12-29 21:36:14 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-12-29 21:36:14 +0000
commit0330ed46b45d9f2972070e6c2a7a14dc2a192bc7 (patch)
tree4b4310187812da3238a09b37cc75a3b4d921fa59 /sys-libs
parentarm stable, bug #344827 (diff)
downloadgentoo-2-0330ed46b45d9f2972070e6c2a7a14dc2a192bc7.tar.gz
gentoo-2-0330ed46b45d9f2972070e6c2a7a14dc2a192bc7.tar.bz2
gentoo-2-0330ed46b45d9f2972070e6c2a7a14dc2a192bc7.zip
Improving python related code, patch thanks to Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> bug #316959
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/ChangeLog6
-rw-r--r--sys-libs/tdb/tdb-1.2.1-r1.ebuild26
2 files changed, 26 insertions, 6 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index af748333200a..c02f9c83a5ce 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.23 2010/09/27 16:26:05 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.24 2010/12/29 21:36:14 vostorga Exp $
+
+ 29 Dec 2010; Víctor Ostorga <vostorga@gentoo.org> tdb-1.2.1-r1.ebuild:
+ Improving python related code, patch thanks to Arfrever Frehtes Taifersar
+ Arahesis <arfrever@gentoo.org> bug #316959
27 Sep 2010; Mart Raudsepp <leio@gentoo.org> tdb-1.2.1-r1.ebuild:
Marked ~mips for bug #285952
diff --git a/sys-libs/tdb/tdb-1.2.1-r1.ebuild b/sys-libs/tdb/tdb-1.2.1-r1.ebuild
index fcc0876b9100..d1421bad2881 100644
--- a/sys-libs/tdb/tdb-1.2.1-r1.ebuild
+++ b/sys-libs/tdb/tdb-1.2.1-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1-r1.ebuild,v 1.3 2010/09/27 16:26:05 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1-r1.ebuild,v 1.4 2010/12/29 21:36:14 vostorga Exp $
EAPI="2"
+PYTHON_DEPEND="python? 2"
inherit autotools python
@@ -15,12 +16,17 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
IUSE="python static-libs tools tdbtest"
RDEPEND=""
-DEPEND="python? ( dev-lang/python )
- !<net-fs/samba-libs-3.4
- !<net-fs/samba-3.3
+DEPEND="!<net-fs/samba-3.3
app-text/docbook-xsl-stylesheets
dev-libs/libxslt"
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
eautoconf -Ilibreplace
sed -i \
@@ -34,10 +40,20 @@ src_prepare() {
}
src_configure() {
+ local myconf=()
+
+ if use python; then
+ myconf+=(
+ PYTHON_CONFIG="${EPREFIX}/usr/bin/python-config-$(python_get_version)"
+ PYTHON="$(PYTHON -a)"
+ )
+ fi
+
econf \
--sysconfdir=/etc/samba \
--localstatedir=/var \
- $(use_enable python)
+ $(use_enable python) \
+ "${myconf[@]}"
}
src_compile() {