summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-29 03:07:07 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-29 03:07:07 +0000
commit02c8feb369eb698ef3eb52231952ba1f4c3a222c (patch)
tree38e892f12311342c0f8cd4afd38bc88c7ad9a6fc /sys-libs
parentRemoved old ebuild. (Manifest recommit) (diff)
downloadgentoo-2-02c8feb369eb698ef3eb52231952ba1f4c3a222c.tar.gz
gentoo-2-02c8feb369eb698ef3eb52231952ba1f4c3a222c.tar.bz2
gentoo-2-02c8feb369eb698ef3eb52231952ba1f4c3a222c.zip
added a patch to always use -fPIC for the shared library test, otherwise it may fail on -fPIC dependant archs. fixes bug #61868
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib/ChangeLog7
-rw-r--r--sys-libs/zlib/files/zlib-1.2.1-fPIC.patch15
-rw-r--r--sys-libs/zlib/zlib-1.2.1-r3.ebuild4
3 files changed, 24 insertions, 2 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index d44a1d802703..f7ffb51de68e 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/zlib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.36 2004/08/27 04:57:37 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.37 2004/08/29 03:07:07 lv Exp $
+
+ 28 Aug 2004; Travis Tilley <lv@gentoo.org> +files/zlib-1.2.1-fPIC.patch,
+ zlib-1.2.1-r3.ebuild:
+ added a patch to always use -fPIC for the shared library test, otherwise it
+ may fail on -fPIC dependant archs. fixes bug #61868
27 Aug 2004; Travis Tilley <lv@gentoo.org> zlib-1.2.1-r3.ebuild:
moved CONF_LIBDIR logic to use $(get_libdir) instead so that the ebuild will
diff --git a/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch b/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch
new file mode 100644
index 000000000000..a9be0c1b042d
--- /dev/null
+++ b/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch
@@ -0,0 +1,15 @@
+--- zlib-1.2.1.old/configure 2004-08-28 08:19:49.000000000 -0400
++++ zlib-1.2.1/configure 2004-08-28 08:33:57.745864064 -0400
+@@ -73,7 +73,11 @@
+
+ if test "$gcc" -eq 1 && ($cc -c $cflags $test.c) 2>/dev/null; then
+ CC="$cc"
+- SFLAGS=${CFLAGS-"-fPIC -O3"}
++ #SFLAGS=${CFLAGS-"-fPIC -O3"}
++ # the above is horribly wrong on a few archs where -fPIC should ALWAYS be
++ # used in the creation of shared libraries. without the following, the
++ # shared lib test will sometimes fail even when shared libs -can- be created.
++ SFLAGS="${CFLAGS-"-O3"} -fPIC"
+ CFLAGS="$cflags"
+ case `(uname -s || echo unknown) 2>/dev/null` in
+ Linux | linux | GNU | GNU/*)
diff --git a/sys-libs/zlib/zlib-1.2.1-r3.ebuild b/sys-libs/zlib/zlib-1.2.1-r3.ebuild
index db418d8d0dfc..a43f5348b834 100644
--- a/sys-libs/zlib/zlib-1.2.1-r3.ebuild
+++ b/sys-libs/zlib/zlib-1.2.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.1-r3.ebuild,v 1.9 2004/08/27 04:57:37 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.1-r3.ebuild,v 1.10 2004/08/29 03:07:07 lv Exp $
inherit eutils flag-o-matic
@@ -29,6 +29,8 @@ src_unpack() {
epatch ${FILESDIR}/${P}-configure.patch
#security fix. bug #61749
epatch ${FILESDIR}/${P}-CAN-2004-0797.patch
+ # fix shared library test on -fPIC dependant archs
+ epatch ${FILESDIR}/zlib-1.2.1-fPIC.patch
}
src_compile() {