summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-05 01:53:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-05 01:53:39 +0000
commit0175818097275b9128c23f69224b4c2f8bceafbd (patch)
tree6d01cf43714e73278d31f4a1d0219bd1a96aa009 /sys-libs
parentchanged the confusing linux-2.6 + devfs warning message (Manifest recommit) (diff)
downloadgentoo-2-0175818097275b9128c23f69224b4c2f8bceafbd.tar.gz
gentoo-2-0175818097275b9128c23f69224b4c2f8bceafbd.tar.bz2
gentoo-2-0175818097275b9128c23f69224b4c2f8bceafbd.zip
Add patch from upstream to clean up assert.h.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/2.3.2/glibc-2.3.2-assert.patch44
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r9.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild4
8 files changed, 63 insertions, 12 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 4fd916191b46..8cca8be928b6 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.299 2005/01/03 22:42:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.300 2005/01/05 01:53:39 vapier Exp $
+
+ 04 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/2.3.2/glibc-2.3.2-assert.patch, glibc-2.3.2-r12.ebuild:
+ Add patch from upstream to clean up assert.h.
03 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+files/2.3.2/glibc-2.3.2-alpha-sysdeps.patch, glibc-2.3.2-r12.ebuild:
diff --git a/sys-libs/glibc/files/2.3.2/glibc-2.3.2-assert.patch b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-assert.patch
new file mode 100644
index 000000000000..e779e99b1753
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-assert.patch
@@ -0,0 +1,44 @@
+Index: assert/assert.h
+===================================================================
+RCS file: /cvs/glibc/libc/assert/assert.h,v
+retrieving revision 1.25
+retrieving revision 1.26
+diff -u -r1.25 -r1.26
+--- assert/assert.h 15 Aug 2003 17:54:31 -0000 1.25
++++ assert/assert.h 4 Oct 2004 07:45:23 -0000 1.26
+@@ -84,33 +84,16 @@
+
+ __END_DECLS
+
+-/* For the macro definition we use gcc's __builtin_expect if possible
+- to generate good code for the non-error case. gcc 3.0 is a good
+- enough estimate for when the feature became available. */
+-# if __GNUC_PREREQ (3, 0)
+-# define assert(expr) \
+- (__ASSERT_VOID_CAST (__builtin_expect (!!(expr), 1) ? 0 : \
+- (__assert_fail (__STRING(expr), __FILE__, __LINE__, \
+- __ASSERT_FUNCTION), 0)))
+-# else
+-# define assert(expr) \
++# define assert(expr) \
+ (__ASSERT_VOID_CAST ((expr) ? 0 : \
+ (__assert_fail (__STRING(expr), __FILE__, __LINE__, \
+ __ASSERT_FUNCTION), 0)))
+-# endif
+
+ # ifdef __USE_GNU
+-# if __GNUC_PREREQ (3, 0)
+-# define assert_perror(errnum) \
+- (__ASSERT_VOID_CAST (__builtin_expect (!(errnum), 1) ? 0 : \
+- (__assert_perror_fail ((errnum), __FILE__, __LINE__, \
+- __ASSERT_FUNCTION), 0)))
+-# else
+-# define assert_perror(errnum) \
++# define assert_perror(errnum) \
+ (__ASSERT_VOID_CAST (!(errnum) ? 0 : \
+ (__assert_perror_fail ((errnum), __FILE__, __LINE__, \
+ __ASSERT_FUNCTION), 0)))
+-# endif
+ # endif
+
+ /* Version 2.4 and later of GCC define a magical variable `__PRETTY_FUNCTION__'
diff --git a/sys-libs/glibc/glibc-2.2.5-r9.ebuild b/sys-libs/glibc/glibc-2.2.5-r9.ebuild
index 56450db51f58..b0151af6fdbc 100644
--- a/sys-libs/glibc/glibc-2.2.5-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r9.ebuild,v 1.13 2004/09/29 05:24:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r9.ebuild,v 1.14 2005/01/05 01:53:39 vapier Exp $
inherit flag-o-matic gcc eutils
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index 934aa13a2eac..7f06574ccf50 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.4 2005/01/03 22:42:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.5 2005/01/05 01:53:39 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -328,6 +328,9 @@ src_unpack() {
# PT_GNU_STACK section. Bug #32960. <azarah@gentoo.org> (12 Nov 2003).
epatch ${FILESDIR}/2.3.2/${PN}-2.3.2-dl_execstack-PaX-support.patch
+ # Upstream patch to fix assert.h
+ epatch ${FILESDIR}/2.3.2/${P}-assert.patch
+
# This next patch fixes a test that will timeout due to ReiserFS' slow handling of sparse files
# cd ${S}/io; epatch ${FILESDIR}/glibc-2.2.2-test-lfs-timeout.patch
diff --git a/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild b/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild
index b005fd95c7ff..0a21f5daa5a0 100644
--- a/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild,v 1.3 2004/11/11 02:29:50 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild,v 1.4 2005/01/05 01:53:39 vapier Exp $
inherit eutils flag-o-matic gcc
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
index 16b5dcd9958a..0eb66c52ebe1 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.4 2004/11/12 23:43:37 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.5 2005/01/05 01:53:39 vapier Exp $
inherit eutils flag-o-matic gcc
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 124994a34dd6..25f7b7e92f8e 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.23 2004/12/23 20:16:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.24 2005/01/05 01:53:39 vapier Exp $
inherit eutils flag-o-matic gcc versionator
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index 14cbc9b73908..f2f649dc8642 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.17 2004/12/28 11:32:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.18 2005/01/05 01:53:39 vapier Exp $
inherit eutils flag-o-matic gcc versionator