summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-20 12:49:53 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-20 12:49:53 +0000
commite13bc1129f1ed83ab5ddf99b97e47c603b754401 (patch)
tree090ca46e42d59f9132f8485e7f5714f513988c39 /sys-libs/zlib
parentVersion bump, bug 316113. Remove old. (diff)
downloadgentoo-2-e13bc1129f1ed83ab5ddf99b97e47c603b754401.tar.gz
gentoo-2-e13bc1129f1ed83ab5ddf99b97e47c603b754401.tar.bz2
gentoo-2-e13bc1129f1ed83ab5ddf99b97e47c603b754401.zip
Version bump #316343 by Samuli Suominen.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/ChangeLog7
-rw-r--r--sys-libs/zlib/zlib-1.2.5.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index c5e341c2cd7f..3d2c8df5e380 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.76 2010/04/14 02:23:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.77 2010/04/20 12:49:53 vapier Exp $
+
+*zlib-1.2.5 (20 Apr 2010)
+
+ 20 Apr 2010; Mike Frysinger <vapier@gentoo.org> +zlib-1.2.5.ebuild:
+ Version bump #316343 by Samuli Suominen.
14 Apr 2010; Mike Frysinger <vapier@gentoo.org> zlib-1.2.4.ebuild:
Tweak the sed on configure tests to cover more cases #310573 by Jan-Erik
diff --git a/sys-libs/zlib/zlib-1.2.5.ebuild b/sys-libs/zlib/zlib-1.2.5.ebuild
new file mode 100644
index 000000000000..32198adbccf2
--- /dev/null
+++ b/sys-libs/zlib/zlib-1.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5.ebuild,v 1.1 2010/04/20 12:49:53 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Standard (de)compression library"
+HOMEPAGE="http://www.zlib.net/"
+SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
+ http://www.zlib.net/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!<dev-libs/libxml2-2.7.7" #309623
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.4-visibility-support.patch #149929
+ epatch "${FILESDIR}"/${PN}-1.2.3-mingw-implib.patch #288212
+ # trust exit status of the compiler rather than stderr #55434
+ # -if test "`(...) 2>&1`" = ""; then
+ # +if (...) 2>/dev/null; then
+ sed -i 's|\<test "`\([^"]*\) 2>&1`" = ""|\1 2>/dev/null|' configure || die
+}
+
+src_compile() {
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ emake -f win32/Makefile.gcc prefix=/usr STRIP= PREFIX=${CHOST}- || die
+ ;;
+ *) # not an autoconf script, so cant use econf
+ ./configure --shared --prefix=/usr --libdir=/usr/$(get_libdir) || die
+ emake || die
+ ;;
+ esac
+}
+
+src_install() {
+ emake install DESTDIR="${D}" LDCONFIG=: || die
+ dodoc FAQ README ChangeLog doc/*.txt
+
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ dobin zlib1.dll || die
+ dolib libz.dll.a || die
+ ;;
+ *) gen_usr_ldscript -a z ;;
+ esac
+}