summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-16 00:35:11 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-16 00:35:11 +0000
commit9eba0033ee43a38f48cba7de156c9d3c831d6297 (patch)
tree6288a7c61cbbf64441fe4cc76a6a0fb095efd07a /sys-libs/zlib
parentAdd fix from upstream for username handling with rsh. (diff)
downloadgentoo-2-9eba0033ee43a38f48cba7de156c9d3c831d6297.tar.gz
gentoo-2-9eba0033ee43a38f48cba7de156c9d3c831d6297.tar.bz2
gentoo-2-9eba0033ee43a38f48cba7de156c9d3c831d6297.zip
Version bump #309623 by Samuli Suominen.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/ChangeLog11
-rw-r--r--sys-libs/zlib/files/zlib-1.2.4-LDFLAGS.patch49
-rw-r--r--sys-libs/zlib/files/zlib-1.2.4-build.patch34
-rw-r--r--sys-libs/zlib/files/zlib-1.2.4-visibility-support.patch45
-rw-r--r--sys-libs/zlib/zlib-1.2.4.ebuild56
5 files changed, 193 insertions, 2 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index 67baecdc0b06..96228f421b44 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/zlib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.71 2009/10/10 17:01:04 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.72 2010/03/16 00:35:09 vapier Exp $
+
+*zlib-1.2.4 (16 Mar 2010)
+
+ 16 Mar 2010; Mike Frysinger <vapier@gentoo.org> +zlib-1.2.4.ebuild,
+ +files/zlib-1.2.4-LDFLAGS.patch, +files/zlib-1.2.4-build.patch,
+ +files/zlib-1.2.4-visibility-support.patch:
+ Version bump #309623 by Samuli Suominen.
10 Oct 2009; Mike Frysinger <vapier@gentoo.org> zlib-1.2.3-r1.ebuild,
+files/zlib-1.2.3-mingw-implib.patch:
diff --git a/sys-libs/zlib/files/zlib-1.2.4-LDFLAGS.patch b/sys-libs/zlib/files/zlib-1.2.4-LDFLAGS.patch
new file mode 100644
index 000000000000..8b128bee1fed
--- /dev/null
+++ b/sys-libs/zlib/files/zlib-1.2.4-LDFLAGS.patch
@@ -0,0 +1,49 @@
+respect LDFLAGS !
+
+--- zlib-1.2.4/Makefile.in
++++ zlib-1.2.4/Makefile.in
+@@ -26,7 +26,6 @@
+
+ SFLAGS=-O
+
+-LDFLAGS=-L. libz.a
+ LDSHARED=$(CC)
+ CPP=$(CC) -E
+
+@@ -134,29 +133,29 @@
+ -@mv objs/$*.o $@
+
+ $(SHAREDLIBV): $(PIC_OBJS)
+- $(LDSHARED) $(SFLAGS) -o $@ $(PIC_OBJS) -lc
++ $(LDSHARED) $(SFLAGS) -o $@ $(PIC_OBJS) -lc $(LDFLAGS)
+ rm -f $(SHAREDLIB) $(SHAREDLIBM)
+ ln -s $@ $(SHAREDLIB)
+ ln -s $@ $(SHAREDLIBM)
+ -@rmdir objs
+
+ example$(EXE): example.o $(STATICLIB)
+- $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ -L. $^ $(LDFLAGS)
+
+ minigzip$(EXE): minigzip.o $(STATICLIB)
+- $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ -L. $^ $(LDFLAGS)
+
+ examplesh$(EXE): example.o $(SHAREDLIBV)
+- $(CC) $(CFLAGS) -o $@ example.o -L. $(SHAREDLIBV)
++ $(CC) $(CFLAGS) -o $@ -L. $^ $(LDFLAGS)
+
+ minigzipsh$(EXE): minigzip.o $(SHAREDLIBV)
+- $(CC) $(CFLAGS) -o $@ minigzip.o -L. $(SHAREDLIBV)
++ $(CC) $(CFLAGS) -o $@ -L. $^ $(LDFLAGS)
+
+ example64$(EXE): example64.o $(STATICLIB)
+- $(CC) $(CFLAGS) -o $@ example64.o $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ -L. $^ $(LDFLAGS)
+
+ minigzip64$(EXE): minigzip64.o $(STATICLIB)
+- $(CC) $(CFLAGS) -o $@ minigzip64.o $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ -L. $^ $(LDFLAGS)
+
+ install-libs: $(LIBS)
+ -@if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir -p $(DESTDIR)$(exec_prefix); fi
diff --git a/sys-libs/zlib/files/zlib-1.2.4-build.patch b/sys-libs/zlib/files/zlib-1.2.4-build.patch
new file mode 100644
index 000000000000..52b398cef055
--- /dev/null
+++ b/sys-libs/zlib/files/zlib-1.2.4-build.patch
@@ -0,0 +1,34 @@
+--- zlib-1.2.4/win32/Makefile.gcc
++++ zlib-1.2.4/win32/Makefile.gcc
+@@ -30,21 +30,23 @@
+ #LOC = -DASMV
+ #LOC = -DDEBUG -g
+
+-CC = gcc
+-CFLAGS = $(LOC) -O3 -Wall
++CC ?= gcc
++CFLAGS ?= $(LOC) -O3 -Wall
+
+-AS = $(CC)
+-ASFLAGS = $(LOC) -Wall
++AS ?= $(CC)
++ASFLAGS ?= $(LOC) -Wall
+
+ LD = $(CC)
+-LDFLAGS = $(LOC) -s
++LDFLAGS ?= $(LOC)
+
+-AR = ar
++AR ?= ar
+ ARFLAGS = rcs
+
+-RC = windres
++RC ?= windres
+ RCFLAGS = --define GCC_WINDRES
+
++DLLWRAP ?= dllwrap
++
+-STRIP = strip
++STRIP = #
+
+ CP = cp -fp
diff --git a/sys-libs/zlib/files/zlib-1.2.4-visibility-support.patch b/sys-libs/zlib/files/zlib-1.2.4-visibility-support.patch
new file mode 100644
index 000000000000..78c902abde6d
--- /dev/null
+++ b/sys-libs/zlib/files/zlib-1.2.4-visibility-support.patch
@@ -0,0 +1,45 @@
+Only export symbols that should be exported.
+
+Patch by Mike Frysinger
+
+http://bugs.gentoo.org/32764
+http://bugs.gentoo.org/149929
+
+--- zlib-1.2.4/configure
++++ zlib-1.2.4/configure
+@@ -209,6 +209,20 @@
+ fi
+
+ cat > $test.c <<EOF
++int foo __attribute__ ((visibility ("hidden")));
++int main()
++{
++ return 0;
++}
++EOF
++if ($CC -c -fvisibility=hidden $CFLAGS $test.c) 2>/dev/null; then
++ CFLAGS="$CFLAGS -DHAS_attribute_visibility -fvisibility=hidden"
++ echo "Checking for attribute(visibility) support... Yes."
++else
++ echo "Checking for attribute(visibility) support... No."
++fi
++
++cat > $test.c <<EOF
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include "zconf.h"
+--- zlib-1.2.4/zconf.h.in
++++ zlib-1.2.4/zconf.h.in
+@@ -244,7 +244,11 @@
+ #endif
+
+ #ifndef ZEXTERN
+-# define ZEXTERN extern
++# if defined(ZLIB_INTERNAL) && defined(HAS_attribute_visibility)
++# define ZEXTERN extern __attribute__ ((visibility("default")))
++# else
++# define ZEXTERN extern
++# endif
+ #endif
+ #ifndef ZEXPORT
+ # define ZEXPORT
diff --git a/sys-libs/zlib/zlib-1.2.4.ebuild b/sys-libs/zlib/zlib-1.2.4.ebuild
new file mode 100644
index 000000000000..840cbaaa8237
--- /dev/null
+++ b/sys-libs/zlib/zlib-1.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.4.ebuild,v 1.1 2010/03/16 00:35:09 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Standard (de)compression library"
+HOMEPAGE="http://www.zlib.net/"
+SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
+ http://www.zlib.net/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+# makes xmllint segfault ? #309623
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.4-build.patch
+ epatch "${FILESDIR}"/${PN}-1.2.4-visibility-support.patch #149929
+ epatch "${FILESDIR}"/${PN}-1.2.4-LDFLAGS.patch #126718
+ epatch "${FILESDIR}"/${PN}-1.2.3-mingw-implib.patch #288212
+ # trust exit status of the compiler rather than stderr #55434
+ # -if test "`(...) 2>&1`" = ""; then
+ # +if (...) 2>/dev/null; then
+ sed -i 's|if test "`\(.*\) 2>&1`" = ""; then|if \1 2>/dev/null; then|' configure || die
+ sed -i -e '/ldconfig/d' Makefile* || die
+}
+
+src_compile() {
+ tc-export AR CC RANLIB RC DLLWRAP
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ emake -f win32/Makefile.gcc prefix=/usr || die
+ ;;
+ *) # not an autoconf script, so cant use econf
+ ./configure --shared --prefix=/usr --libdir=/usr/$(get_libdir) || die
+ emake || die
+ ;;
+ esac
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc FAQ README ChangeLog doc/*.txt
+
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ dobin zlib1.dll || die
+ dolib libz.dll.a || die
+ ;;
+ *) gen_usr_ldscript -a z ;;
+ esac
+}