summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
commitee9370024399e437cc5bf9059862f90092726ddb (patch)
treecfedc7627885a81bc93880532501da76c862d323 /sys-libs/nss-db
parentMaintainence and FHS 2.1 fixes for RC4 (diff)
downloadgentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.tar.gz
gentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.tar.bz2
gentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-libs/nss-db')
-rw-r--r--sys-libs/nss-db/nss-db-2.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-libs/nss-db/nss-db-2.2-r1.ebuild b/sys-libs/nss-db/nss-db-2.2-r1.ebuild
new file mode 100644
index 000000000000..8f3ee5774567
--- /dev/null
+++ b/sys-libs/nss-db/nss-db-2.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/nss-db/nss-db-2.2-r1.ebuild,v 1.1 2001/02/07 16:10:52 achim Exp $
+
+A=nss_db-${PV}.tar.gz
+S=${WORKDIR}/nss_db-${PV}
+DESCRIPTION="Allows important system files to be stored in a fast database file rather than plain text"
+SRC_URI="ftp://ftp.gnu.org/gnu/glibc/${A}"
+HOMEPAGE="http://www.gnu.org"
+#now db needs to move to the base install, that's ok.
+
+DEPEND=">=sys-libs/db-3.2.3-r1
+ sys-devel/gettext"
+
+RDEPEND=">=sys-libs/db-3.2.3-r1"
+
+
+src_compile() {
+
+ try ./configure --with-db=/usr/include/db3 --prefix=/usr --libdir=/usr/lib
+ try make ${MAKEOPTS}
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install
+
+ rm -rf ${D}/usr/lib
+ cd ${D}/lib
+ ln -s libnss_db-${PV}.so libnss_db.so
+
+ cd ${S}
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS
+}
+