summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-05-31 09:05:05 +0000
committerJeroen Roovers <jer@gentoo.org>2015-05-31 09:05:05 +0000
commit21666b3dad95b50fa7e11477849676276035b197 (patch)
treef03655107fa1fb8d158c489b082a0b19bebf8447 /sys-libs/libvpd
parentarm stable wrt bug #534882 (diff)
downloadgentoo-2-21666b3dad95b50fa7e11477849676276035b197.tar.gz
gentoo-2-21666b3dad95b50fa7e11477849676276035b197.tar.bz2
gentoo-2-21666b3dad95b50fa7e11477849676276035b197.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-libs/libvpd')
-rw-r--r--sys-libs/libvpd/ChangeLog10
-rw-r--r--sys-libs/libvpd/libvpd-2.2.0.ebuild33
-rw-r--r--sys-libs/libvpd/libvpd-2.2.4.ebuild36
3 files changed, 44 insertions, 35 deletions
diff --git a/sys-libs/libvpd/ChangeLog b/sys-libs/libvpd/ChangeLog
index d98dda0edbee..e04dd9e11334 100644
--- a/sys-libs/libvpd/ChangeLog
+++ b/sys-libs/libvpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libvpd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvpd/ChangeLog,v 1.3 2013/07/21 08:28:28 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvpd/ChangeLog,v 1.4 2015/05/31 09:05:05 jer Exp $
+
+*libvpd-2.2.4 (31 May 2015)
+
+ 31 May 2015; Jeroen Roovers <jer@gentoo.org> -libvpd-2.2.0.ebuild,
+ +libvpd-2.2.4.ebuild:
+ Version bump.
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #88306
diff --git a/sys-libs/libvpd/libvpd-2.2.0.ebuild b/sys-libs/libvpd/libvpd-2.2.0.ebuild
deleted file mode 100644
index c8ce6cac0ec1..000000000000
--- a/sys-libs/libvpd/libvpd-2.2.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvpd/libvpd-2.2.0.ebuild,v 1.1 2013/02/28 20:31:30 ranger Exp $
-
-EAPI=4
-
-DESCRIPTION="Library implementation for listing vpds"
-HOMEPAGE="http://sourceforge.net/projects/linux-diag/"
-SRC_URI="http://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
-
-LICENSE="IBM"
-SLOT="0"
-KEYWORDS="~ppc ~ppc64"
-IUSE=""
-
-DEPEND=">=dev-db/sqlite-3.7.8
- sys-libs/zlib"
-
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
-}
-
-src_configure() {
- ./bootstrap.sh
- econf || die "Unable to configure"
-}
-
-src_install(){
- emake DESTDIR="${D}" install || die "Something went wrong"
-
-}
diff --git a/sys-libs/libvpd/libvpd-2.2.4.ebuild b/sys-libs/libvpd/libvpd-2.2.4.ebuild
new file mode 100644
index 000000000000..1d380376e8be
--- /dev/null
+++ b/sys-libs/libvpd/libvpd-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvpd/libvpd-2.2.4.ebuild,v 1.1 2015/05/31 09:05:05 jer Exp $
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library implementation for listing vpds"
+HOMEPAGE="http://sourceforge.net/projects/linux-diag/"
+SRC_URI="http://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
+
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DEPEND="
+ >=dev-db/sqlite-3.7.8
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # sysconfdir is used only to establish where the udev rules file should go
+ # unfortunately it also adds the subdirs on its own so we strip it down to
+ # dirname
+ econf \
+ $(use_enable static-libs static) \
+ --sysconfdir="$( dirname $(get_udevdir) )"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+
+}