summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-01 10:03:04 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-01 10:03:04 +0000
commit64f1a21342588a92871eef96ef418181aff0583e (patch)
tree3d97c4cc81dc479042fcd8e1e5c68a5237b5acd7 /sys-libs/libstdc++-v3
parentAdded icon USE flag, see bug #62163. (Manifest recommit) (diff)
downloadgentoo-2-64f1a21342588a92871eef96ef418181aff0583e.tar.gz
gentoo-2-64f1a21342588a92871eef96ef418181aff0583e.tar.bz2
gentoo-2-64f1a21342588a92871eef96ef418181aff0583e.zip
made libstdc++-v3 use $(get_libdir) for optionally installing to lib32/lib64 based on the CONF_LIBDIR setting. CONF_LIBDIR wont be fully supported until portage 2.0.51
Diffstat (limited to 'sys-libs/libstdc++-v3')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog8
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild8
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index e24f8492080e..7f3c932103fd 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.21 2004/08/29 05:15:37 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.22 2004/09/01 10:03:04 lv Exp $
+
+ 01 Sep 2004; Travis Tilley <lv@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild,
+ libstdc++-v3-3.3.4.ebuild:
+ made libstdc++-v3 use $(get_libdir) for optionally installing to lib32/lib64
+ based on the CONF_LIBDIR setting. CONF_LIBDIR wont be fully supported until
+ portage 2.0.51
*libstdc++-v3-3.3.4 (29 Aug 2004)
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index 282bcab8d6e4..a6d0c20b8f65 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.24 2004/08/28 15:51:25 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.25 2004/09/01 10:03:04 lv Exp $
inherit eutils flag-o-matic libtool gnuconfig
@@ -227,6 +227,12 @@ src_install() {
# apps and also causes others to link against the old libstdc++...
rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+ # and it's much easier to just move around the result than it is to
+ # configure libstdc++-v3 to use CONF_LIDIR
+ if [ "$(get_libdir)" != "lib" ] ; then
+ mv ${D}/${LOC}/lib ${D}/${LOC}/$(get_libdir)
+ fi
+
mkdir -p ${D}/etc/env.d/
echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
}
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
index 9a5731b93d2d..b1ae9fd02dee 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.1 2004/08/29 05:15:37 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.2 2004/09/01 10:03:04 lv Exp $
inherit eutils flag-o-matic libtool gnuconfig
@@ -229,6 +229,12 @@ src_install() {
# apps and also causes others to link against the old libstdc++...
rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+ # and it's much easier to just move around the result than it is to
+ # configure libstdc++-v3 to use CONF_LIDIR
+ if [ "$(get_libdir)" != "lib" ] ; then
+ mv ${D}/${LOC}/lib ${D}/${LOC}/$(get_libdir)
+ fi
+
mkdir -p ${D}/etc/env.d/
echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
}