summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-17 03:28:06 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-17 03:28:06 +0000
commitc2a10d46d43c2d813cc3274ab0e4654436165729 (patch)
tree97094f5659b2d979be174de130f05e6d5ea13bbd /sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
parentversion bump with fix for bug #253712 as well (diff)
downloadgentoo-2-c2a10d46d43c2d813cc3274ab0e4654436165729.tar.gz
gentoo-2-c2a10d46d43c2d813cc3274ab0e4654436165729.tar.bz2
gentoo-2-c2a10d46d43c2d813cc3274ab0e4654436165729.zip
Restore USE=multilib crap #259215.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild')
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
index a1c8de807cbe..027b3765df25 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild,v 1.23 2009/02/16 23:38:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild,v 1.24 2009/02/17 03:28:06 vapier Exp $
inherit eutils flag-o-matic libtool multilib
@@ -121,6 +121,15 @@ src_unpack() {
elibtoolize --portage --shallow
./contrib/gcc_update --touch
mkdir -p "${WORKDIR}"/build
+
+ if use multilib ; then
+ # ugh, this shit has to match the way we've hacked gcc else
+ # the build falls apart #259215
+ sed -i \
+ -e 's:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:' \
+ "${S}"/gcc/config/i386/t-linux64 \
+ || die "sed failed!"
+ fi
}
src_compile() {