summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-11 16:46:12 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-11 16:46:12 +0000
commitb596e9d0089beb89b782e0f0d02876f77f0be377 (patch)
treebb362848af88d17ff4a9d79aaf32d5ea83ecb37e /sys-libs/libsmbios
parentAdd ~alpha/~ia64 wrt #260777 (diff)
downloadgentoo-2-b596e9d0089beb89b782e0f0d02876f77f0be377.tar.gz
gentoo-2-b596e9d0089beb89b782e0f0d02876f77f0be377.tar.bz2
gentoo-2-b596e9d0089beb89b782e0f0d02876f77f0be377.zip
Fix bug 256777, failure with gcc-4.4. Thanks to Kent Fredric <kentfredric@gmail.com> for the patch.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libsmbios')
-rw-r--r--sys-libs/libsmbios/ChangeLog9
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.0.3-gcc44.patch45
-rw-r--r--sys-libs/libsmbios/libsmbios-2.0.3.ebuild17
3 files changed, 61 insertions, 10 deletions
diff --git a/sys-libs/libsmbios/ChangeLog b/sys-libs/libsmbios/ChangeLog
index d4fa692350e2..908d64fbe7d2 100644
--- a/sys-libs/libsmbios/ChangeLog
+++ b/sys-libs/libsmbios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsmbios
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/ChangeLog,v 1.19 2008/11/01 16:24:32 cedk Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/ChangeLog,v 1.20 2009/04/11 16:46:12 loki_val Exp $
+
+ 11 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libsmbios-2.0.3-gcc44.patch, libsmbios-2.0.3.ebuild:
+ Fix bug 256777, failure with gcc-4.4. Thanks to Kent Fredric
+ <kentfredric@gmail.com> for the patch.
*libsmbios-2.0.3 (01 Nov 2008)
diff --git a/sys-libs/libsmbios/files/libsmbios-2.0.3-gcc44.patch b/sys-libs/libsmbios/files/libsmbios-2.0.3-gcc44.patch
new file mode 100644
index 000000000000..6f4a802ca789
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.0.3-gcc44.patch
@@ -0,0 +1,45 @@
+diff -Naur libraries/cmos/CmosRW.cpp libraries/cmos/CmosRW.cpp
+--- libraries/cmos/CmosRW.cpp 2008-02-13 19:12:43.000000000 +0000
++++ libraries/cmos/CmosRW.cpp 2009-01-29 11:29:02.992136416 +0000
+@@ -19,6 +19,7 @@
+ // compat header should always be first header if including system headers
+ #define LIBSMBIOS_SOURCE
+ #include "smbios/compat.h"
++#include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
+ #include "CmosRWImpl.h"
+diff -Naur libraries/memory/Memory_Linux.cpp libraries/memory/Memory_Linux.cpp
+--- libraries/memory/Memory_Linux.cpp 2007-10-19 22:15:12.000000000 +0000
++++ libraries/memory/Memory_Linux.cpp 2009-01-29 11:28:33.745839933 +0000
+@@ -22,6 +22,7 @@
+
+ #include <errno.h>
+ #include <sys/mman.h> /* mmap */
++#include <stdio.h>
+ #include <unistd.h> /* getpagesize */
+ #include <string.h> /* memcpy etc. */
+
+diff -Naur libraries/smbios/SmbiosStrategy_Linux.cpp libraries/smbios/SmbiosStrategy_Linux.cpp
+--- libraries/smbios/SmbiosStrategy_Linux.cpp 2007-10-19 22:15:12.000000000 +0000
++++ libraries/smbios/SmbiosStrategy_Linux.cpp 2009-01-29 11:28:04.639844346 +0000
+@@ -20,6 +20,7 @@
+ #define LIBSMBIOS_SOURCE
+ #include "smbios/compat.h"
+
++#include <cstdio>
+ #include <sstream>
+ #include <string.h>
+
+diff -Naur libraries/smi/SmiImpl.h libraries/smi/SmiImpl.h
+--- libraries/smi/SmiImpl.h 2007-11-27 17:50:54.000000000 +0000
++++ libraries/smi/SmiImpl.h 2009-01-29 11:44:52.811833602 +0000
+@@ -22,6 +22,8 @@
+ #include "SmiLowLevel.h"
+ #include "ExceptionImpl.h"
+
++#include <cstdio>
++
+ namespace smi
+ {
+ // define our exceptions
diff --git a/sys-libs/libsmbios/libsmbios-2.0.3.ebuild b/sys-libs/libsmbios/libsmbios-2.0.3.ebuild
index dd114e6ce53f..03920937897c 100644
--- a/sys-libs/libsmbios/libsmbios-2.0.3.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.0.3.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/libsmbios-2.0.3.ebuild,v 1.1 2008/11/01 16:24:32 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/libsmbios-2.0.3.ebuild,v 1.2 2009/04/11 16:46:12 loki_val Exp $
+
+EAPI=2
+
+inherit eutils
DESCRIPTION="Provide access to (SM)BIOS information"
HOMEPAGE="http://linux.dell.com/libsmbios/main/index.html"
@@ -16,13 +20,10 @@ DEPEND="dev-libs/libxml2
test? ( dev-util/cppunit )"
RDEPEND=${DEPEND}
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
+RESTRICT=test
-src_test() {
- einfo "testing currently broken - bypassing"
+src_prepare() {
+ epatch "${FILESDIR}/libsmbios-2.0.3-gcc44.patch"
}
src_install() {