summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-10-09 19:58:45 +0000
committerSven Vermeulen <swift@gentoo.org>2012-10-09 19:58:45 +0000
commit52a2c127b83f3d75282d163c2f5203ec1952c85c (patch)
tree37369d17737da1e2d7dfc51ba48cdbc0c557c8a5 /sys-libs/libsepol
parentClean up. (diff)
downloadgentoo-2-52a2c127b83f3d75282d163c2f5203ec1952c85c.tar.gz
gentoo-2-52a2c127b83f3d75282d163c2f5203ec1952c85c.tar.bz2
gentoo-2-52a2c127b83f3d75282d163c2f5203ec1952c85c.zip
New upstream SELinux utilities release
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.1.8.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 23ae07a21fd8..ca8a04ee3471 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.49 2012/10/03 20:34:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.50 2012/10/09 19:58:45 swift Exp $
+
+*libsepol-2.1.8 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +libsepol-2.1.8.ebuild:
+ Introducing upstream release
03 Oct 2012; Mike Frysinger <vapier@gentoo.org> libsepol-2.1.4-r1.ebuild:
Update to EAPI=4.
diff --git a/sys-libs/libsepol/libsepol-2.1.8.ebuild b/sys-libs/libsepol/libsepol-2.1.8.ebuild
new file mode 100644
index 000000000000..e0fd6a9c9985
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.8.ebuild,v 1.1 2012/10/09 19:58:45 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+ epatch "${FILESDIR}/libsepol-2.1.4-fix_role_fix_callback.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}