summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-06-01 12:21:16 +0000
committerSven Vermeulen <swift@gentoo.org>2014-06-01 12:21:16 +0000
commitb192badc01dd5305fe3327c457f9ee50ff7cb8a6 (patch)
tree6dc3af41198a243d3b14d00541a91d3be34f3cf3 /sys-libs/libsemanage
parentAdding libsemanage-2.3-r1 to p.mask (multilib and depends on audit) (diff)
downloadgentoo-2-b192badc01dd5305fe3327c457f9ee50ff7cb8a6.tar.gz
gentoo-2-b192badc01dd5305fe3327c457f9ee50ff7cb8a6.tar.bz2
gentoo-2-b192badc01dd5305fe3327c457f9ee50ff7cb8a6.zip
Fixing multilib support (bug #506460) with thanks to Sven Eden. Package has dep on audit-2.2.2 which is p.masked so added same package to p.mask combo
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-libs/libsemanage')
-rw-r--r--sys-libs/libsemanage/ChangeLog8
-rw-r--r--sys-libs/libsemanage/libsemanage-2.3-r1.ebuild114
2 files changed, 121 insertions, 1 deletions
diff --git a/sys-libs/libsemanage/ChangeLog b/sys-libs/libsemanage/ChangeLog
index b40fce6fb659..6ca13bf2bbc8 100644
--- a/sys-libs/libsemanage/ChangeLog
+++ b/sys-libs/libsemanage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsemanage
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.68 2014/05/10 14:01:27 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.69 2014/06/01 12:21:16 swift Exp $
+
+*libsemanage-2.3-r1 (01 Jun 2014)
+
+ 01 Jun 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3-r1.ebuild:
+ Fixing multilib support (bug #506460) with thanks to Sven Eden. Package has
+ dep on audit-2.2.2 which is p.masked so added same package to p.mask combo
10 May 2014; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.10.ebuild,
-libsemanage-2.2-r1.ebuild, -libsemanage-2.3_rc1.ebuild:
diff --git a/sys-libs/libsemanage/libsemanage-2.3-r1.ebuild b/sys-libs/libsemanage/libsemanage-2.3-r1.ebuild
new file mode 100644
index 000000000000..b4a099dee224
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-2.3-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.3-r1.ebuild,v 1.1 2014/06/01 12:21:16 swift Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+
+inherit multilib python-r1 toolchain-funcs eutils multilib-minimal
+
+MY_P="${P//_/-}"
+
+SEPOL_VER="2.3"
+SELNX_VER="2.3"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20140506/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libselinux-${SELNX_VER}
+ sys-process/audit
+ abi_x86_32? (
+ !<dev-libs/ustr-1.0.4-r4
+ !dev-libs/ustr[-abi_x86_32(-)]
+ !<sys-process/audit-2.2.2-r2
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ python? (
+ >=dev-lang/swig-2.0.4-r1
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ )"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
+ echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
+ echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
+ echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
+ echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
+ echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
+ echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
+ echo "bzip-small=true" >> "${S}/src/semanage.conf"
+
+ epatch_user
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ building() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ SHLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ "$@" || die
+ }
+
+ multilib_foreach_abi building all
+
+ if multilib_is_native_abi && use python; then
+ building_py() {
+ python_export PYTHON_INCLUDEDIR PYTHON_LIBPATH
+ emake CC="$(tc-getCC)" PYINC="-I${PYTHON_INCLUDEDIR}" PYTHONLBIDIR="${PYTHON_LIBPATH}" PYPREFIX="${EPYTHON##*/}" "$@"
+ }
+ python_foreach_impl building_py swigify
+ python_foreach_impl building_py pywrap
+ fi
+}
+
+multilib_src_install() {
+ installation() {
+ emake \
+ LIBDIR="${D}/${EPREFIX}/usr/$(get_libdir)" \
+ SHLIBDIR="${D}/${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" "$@"
+ }
+
+ multilib_foreach_abi installation install
+
+ if multilib_is_native_abi && use python; then
+ installation_py() {
+ emake DESTDIR="${D}" install-pywrap
+ }
+ python_foreach_impl installation_py
+ fi
+}