summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrent Baude <ranger@gentoo.org>2007-05-29 14:55:21 +0000
committerBrent Baude <ranger@gentoo.org>2007-05-29 14:55:21 +0000
commit763491b32d52d5e795ff9bd009570006d33bc439 (patch)
tree02fb30edc7d6492e2eb3364a70be4cbc28ae9fd2 /sys-libs/librtas
parentfix baselayout2 breakage and update the changelog (diff)
downloadgentoo-2-763491b32d52d5e795ff9bd009570006d33bc439.tar.gz
gentoo-2-763491b32d52d5e795ff9bd009570006d33bc439.tar.bz2
gentoo-2-763491b32d52d5e795ff9bd009570006d33bc439.zip
Adding an ebuild for librtas-1.3.1, marking ~ for ppc and ppc64
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-libs/librtas')
-rw-r--r--sys-libs/librtas/ChangeLog9
-rw-r--r--sys-libs/librtas/files/digest-librtas-1.3.13
-rw-r--r--sys-libs/librtas/files/librtas-1.3.1-remove-doc.patch14
-rw-r--r--sys-libs/librtas/librtas-1.3.1.ebuild26
4 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/librtas/ChangeLog b/sys-libs/librtas/ChangeLog
index 10fd12e924a1..e0896486a360 100644
--- a/sys-libs/librtas/ChangeLog
+++ b/sys-libs/librtas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/librtas
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/librtas/ChangeLog,v 1.3 2007/02/09 08:38:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/librtas/ChangeLog,v 1.4 2007/05/29 14:55:21 ranger Exp $
+
+*librtas-1.3.1 (29 May 2007)
+
+ 29 May 2007; Brent Baude <ranger@gentoo.org>
+ +files/librtas-1.3.1-remove-doc.patch, +librtas-1.3.1.ebuild:
+ Adding an ebuild for librtas-1.3.1, marking ~ for ppc and ppc64, will
+ eventually be the "new" librtas ebuild.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sys-libs/librtas/files/digest-librtas-1.3.1 b/sys-libs/librtas/files/digest-librtas-1.3.1
new file mode 100644
index 000000000000..f63e6b42759a
--- /dev/null
+++ b/sys-libs/librtas/files/digest-librtas-1.3.1
@@ -0,0 +1,3 @@
+MD5 d1d6a21e68e2cefccc7c4c7a5fdba1c5 librtas-1.3.1.tar.gz 99838
+RMD160 40f48393f399b6dc382e71f0579768c3f4122ce7 librtas-1.3.1.tar.gz 99838
+SHA256 3e5148b5313235c99fb6b391fec844f585c095cb37f36d3aeb05193cec5553cd librtas-1.3.1.tar.gz 99838
diff --git a/sys-libs/librtas/files/librtas-1.3.1-remove-doc.patch b/sys-libs/librtas/files/librtas-1.3.1-remove-doc.patch
new file mode 100644
index 000000000000..3c752425b428
--- /dev/null
+++ b/sys-libs/librtas/files/librtas-1.3.1-remove-doc.patch
@@ -0,0 +1,14 @@
+--- librtas-1.3.1.orig/Makefile 2007-04-12 15:01:01.000000000 -0500
++++ librtas-1.3.1/Makefile 2007-05-29 09:49:24.000000000 -0500
+@@ -16,11 +16,9 @@
+
+ install:
+ @$(call install_doc,$(FILES),$(DESTDIR))
+- @$(foreach d,$(SUBDIRS), $(MAKE) -C $d install;)
+
+ uninstall:
+ @$(call uninstall_doc,$(FILES),$(DESTDIR))
+- @$(foreach d,$(SUBDIRS), $(MAKE) -C $d uninstall;)
+
+ rpm: all
+ @echo "Creating rpm..."
diff --git a/sys-libs/librtas/librtas-1.3.1.ebuild b/sys-libs/librtas/librtas-1.3.1.ebuild
new file mode 100644
index 000000000000..00feb9de0eab
--- /dev/null
+++ b/sys-libs/librtas/librtas-1.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/librtas/librtas-1.3.1.ebuild,v 1.1 2007/05/29 14:55:21 ranger Exp $
+
+inherit eutils
+
+DESCRIPTION=" Librtas provides a set of libraries for user-space access to the Run-Time Abstraction Services (RTAS) on the ppc64 architecture."
+SRC_URI="http://librtas.ozlabs.org/releases/librtas-${PV}.tar.gz"
+HOMEPAGE="http://librtas.ozlabs.org/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/librtas-1.3.1-remove-doc.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Compilation failed"
+ dodoc README COPYRIGHT
+
+}
+