summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-18 13:31:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-18 13:31:28 +0000
commitda43c4ac8b09c00058bb6d878a307c60f69799b9 (patch)
treec9651b602e3297a441b4db6ea7aff22ae917d9a2 /sys-libs/libcxxrt
parent keyword ~amd64-fbsd (diff)
downloadgentoo-2-da43c4ac8b09c00058bb6d878a307c60f69799b9.tar.gz
gentoo-2-da43c4ac8b09c00058bb6d878a307c60f69799b9.tar.bz2
gentoo-2-da43c4ac8b09c00058bb6d878a307c60f69799b9.zip
bump a new snapshot
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxxrt')
-rw-r--r--sys-libs/libcxxrt/ChangeLog8
-rw-r--r--sys-libs/libcxxrt/libcxxrt-0.0_p20130218.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-libs/libcxxrt/ChangeLog b/sys-libs/libcxxrt/ChangeLog
index 99d184b76c98..f51f5b1d4a22 100644
--- a/sys-libs/libcxxrt/ChangeLog
+++ b/sys-libs/libcxxrt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libcxxrt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.6 2013/01/31 17:48:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.7 2013/02/18 13:31:28 aballier Exp $
+
+*libcxxrt-0.0_p20130218 (18 Feb 2013)
+
+ 18 Feb 2013; Alexis Ballier <aballier@gentoo.org>
+ +libcxxrt-0.0_p20130218.ebuild:
+ bump a new snapshot
31 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org>
libcxxrt-0.0_p20120911.ebuild, libcxxrt-9999.ebuild:
diff --git a/sys-libs/libcxxrt/libcxxrt-0.0_p20130218.ebuild b/sys-libs/libcxxrt/libcxxrt-0.0_p20130218.ebuild
new file mode 100644
index 000000000000..6d4505134d30
--- /dev/null
+++ b/sys-libs/libcxxrt/libcxxrt-0.0_p20130218.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20130218.ebuild,v 1.1 2013/02/18 13:31:28 aballier Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/pathscale/libcxxrt.git"
+
+[ "${PV%9999}" != "${PV}" ] && SCM="git-2" || SCM=""
+
+inherit base flag-o-matic toolchain-funcs portability ${SCM}
+
+DESCRIPTION="C++ Runtime from PathScale, FreeBSD and NetBSD."
+HOMEPAGE="https://github.com/pathscale/libcxxrt http://www.pathscale.com/node/265"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ DEPEND="app-arch/xz-utils"
+else
+ SRC_URI=""
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/libunwind-1.0.1-r1"
+DEPEND="${RDEPEND}
+ ${DEPEND}"
+
+src_prepare() {
+ base_src_prepare
+ cp "${FILESDIR}/Makefile" src/ || die
+ cp "${FILESDIR}/Makefile.test" test/Makefile || die
+ rm -f src/unwind* || die
+ cp -f "${FILESDIR}/unwind.h" src/ || die
+}
+
+src_compile() {
+ # Notes: we build -nodefaultlibs to avoid linking to gcc libs.
+ # libcxxrt needs: dladdr (dlopen_lib), libunwind (or libgcc_s but we build
+ # over libunwind) and the libc.
+ tc-export CC CXX AR
+ append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
+ cd "${S}/src"
+ LIBS="$(dlopen_lib) -lunwind -lc" emake shared
+ use static-libs && emake static
+}
+
+src_test() {
+ cd "${S}/test"
+ LD_LIBRARY_PATH="${S}/src:${LD_LIBRARY_PATH}" LIBS="-L${S}/src -lcxxrt -lc" emake check
+}
+
+src_install() {
+ # TODO: See README. Maybe hide it in a subdir and let only libcxx know about
+ # it. FreeBSD head installs it in /lib
+ dolib.so src/${PN}.so*
+ use static-libs && dolib.a src/${PN}.a
+
+ insinto /usr/include/libcxxrt/
+ doins src/cxxabi.h
+
+ dodoc AUTHORS COPYRIGHT README
+}