summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 22:09:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 22:09:14 +0000
commit6708104f264ec4968f6e5cbebde94189af0a8cf9 (patch)
treee78d718239c5165f953afdc57f3d22f9f8147fd2 /sys-libs/gpm
parentVersion bump. (diff)
downloadgentoo-2-6708104f264ec4968f6e5cbebde94189af0a8cf9.tar.gz
gentoo-2-6708104f264ec4968f6e5cbebde94189af0a8cf9.tar.bz2
gentoo-2-6708104f264ec4968f6e5cbebde94189af0a8cf9.zip
Add mousewheel support by Andrzej Zaborowski #101605.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog7
-rw-r--r--sys-libs/gpm/files/digest-gpm-1.20.1-r52
-rw-r--r--sys-libs/gpm/gpm-1.20.1-r5.ebuild70
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index fe2257c83983..9a9c7dac84ba 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.42 2005/05/07 23:30:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.43 2005/08/07 22:09:14 vapier Exp $
+
+*gpm-1.20.1-r5 (07 Aug 2005)
+
+ 07 Aug 2005; Mike Frysinger <vapier@gentoo.org> +gpm-1.20.1-r5.ebuild:
+ Add mousewheel support by Andrzej Zaborowski #101605.
05 May 2005; Mamoru KOMACHI <usata@gentoo.org> gpm-1.20.1-r4.ebuild:
Forgot to add emacs to DEPEND when emacs is in USE
diff --git a/sys-libs/gpm/files/digest-gpm-1.20.1-r5 b/sys-libs/gpm/files/digest-gpm-1.20.1-r5
new file mode 100644
index 000000000000..885731c61972
--- /dev/null
+++ b/sys-libs/gpm/files/digest-gpm-1.20.1-r5
@@ -0,0 +1,2 @@
+MD5 2c63e827d755527950d9d13fe3d87692 gpm-1.20.1.tar.bz2 565014
+MD5 ede95b6eb848f87440a2d7f86eaaf13a gpm-1.20.1-patches-1.4.tar.bz2 8049
diff --git a/sys-libs/gpm/gpm-1.20.1-r5.ebuild b/sys-libs/gpm/gpm-1.20.1-r5.ebuild
new file mode 100644
index 000000000000..8b29c72299e2
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.1-r5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.1-r5.ebuild,v 1.1 2005/08/07 22:09:14 vapier Exp $
+
+inherit eutils toolchain-funcs elisp-common
+
+PATCH_VER="1.4"
+DESCRIPTION="Console-based mouse driver"
+HOMEPAGE="http://linux.schottelius.org/gpm/"
+SRC_URI="ftp://arcana.linux.it/pub/gpm/${P}.tar.bz2
+ ftp://ftp.schottelius.org/pub/linux/gpm/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux emacs"
+
+DEPEND="sys-libs/ncurses
+ emacs? ( virtual/emacs )"
+RDEPEND="selinux? ( sec-policy/selinux-gpm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+}
+
+src_compile() {
+ econf \
+ --libdir=/$(get_libdir) \
+ --sysconfdir=/etc/gpm \
+ || die "econf failed"
+ emake \
+ CC=$(tc-getCC) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ EMACS=: \
+ || die "emake failed"
+
+ local lisp="emacs/t-mouse.el emacs/t-mouse.elc"
+ if use emacs ; then
+ cd "${S}"/contrib ; make clean
+ make EMACS=emacs ELISP="${lisp}" || die
+ fi
+}
+
+src_install() {
+ make install DESTDIR="${D}" EMACS=: ELISP="" || die "make install failed"
+ # fix lib symlinks since the default is missing/bogus
+ dosym libgpm.so.1.19.0 /$(get_libdir)/libgpm.so.1
+ dosym libgpm.so.1 /$(get_libdir)/libgpm.so
+ dodir /usr/$(get_libdir)
+ mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
+ gen_usr_ldscript libgpm.so
+
+ if use emacs ; then
+ cd ${S}/contrib/emacs
+ elisp-install . t-mouse*
+ fi
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ dodoc BUGS Changes README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+
+ newinitd "${FILESDIR}"/gpm.rc6 gpm
+ newconfd "${FILESDIR}"/gpm.conf.d gpm
+}