summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-03 11:54:00 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-03 11:54:00 +0000
commit067b14cef7a312f94c204815cc7c7bb6725b55f2 (patch)
tree39494ada75a4dbbc23e8124ad0e2628d6aca6f9e /sys-libs/gpm
parentFix SLOT (s/1.3/2/). (diff)
downloadgentoo-2-067b14cef7a312f94c204815cc7c7bb6725b55f2.tar.gz
gentoo-2-067b14cef7a312f94c204815cc7c7bb6725b55f2.tar.bz2
gentoo-2-067b14cef7a312f94c204815cc7c7bb6725b55f2.zip
Added emacs IUSE; bug #80217.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog5
-rw-r--r--sys-libs/gpm/gpm-1.20.1-r4.ebuild20
2 files changed, 20 insertions, 5 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 9221c8e4c925..41fc022c59e0 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.40 2005/04/01 22:20:49 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.41 2005/05/03 11:54:00 usata Exp $
+
+ 03 May 2005; Mamoru KOMACHI <usata@gentoo.org> gpm-1.20.1-r4.ebuild:
+ Added emacs IUSE; bug #80217.
01 Apr 2005; Lars Weiler <pylon@gentoo.org> gpm-1.20.1-r4.ebuild:
Stable on ppc.
diff --git a/sys-libs/gpm/gpm-1.20.1-r4.ebuild b/sys-libs/gpm/gpm-1.20.1-r4.ebuild
index 27199cecc97f..443787a49941 100644
--- a/sys-libs/gpm/gpm-1.20.1-r4.ebuild
+++ b/sys-libs/gpm/gpm-1.20.1-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.1-r4.ebuild,v 1.9 2005/05/03 04:50:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.1-r4.ebuild,v 1.10 2005/05/03 11:54:00 usata Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs elisp-common
PATCH_VER="1.3"
DESCRIPTION="Console-based mouse driver"
@@ -14,7 +14,7 @@ SRC_URI="ftp://arcana.linux.it/pub/gpm/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="selinux"
+IUSE="selinux emacs"
DEPEND="sys-libs/ncurses"
RDEPEND="selinux? ( sec-policy/selinux-gpm )"
@@ -34,11 +34,18 @@ src_compile() {
CC=$(tc-getCC) \
AR=$(tc-getAR) \
RANLIB=$(tc-getRANLIB) \
+ EMACS=: \
|| die "emake failed"
+
+ local lisp="emacs/t-mouse.el emacs/t-mouse.elc"
+ if use emacs ; then
+ cd ${S}/contrib ; make clean
+ make EMACS=emacs ELISP="${lisp}" || die
+ fi
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ make install DESTDIR="${D}" EMACS=: ELISP="" || die "make install failed"
# fix lib symlinks since the default is missing/bogus
dosym libgpm.so.1.19.0 /$(get_libdir)/libgpm.so.1
dosym libgpm.so.1 /$(get_libdir)/libgpm.so
@@ -46,6 +53,11 @@ src_install() {
mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
gen_usr_ldscript libgpm.so
+ if use emacs ; then
+ cd ${S}/contrib/emacs
+ elisp-install . t-mouse*
+ fi
+
insinto /etc/gpm
doins conf/gpm-*.conf