summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-10-08 04:19:36 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-10-08 04:19:36 +0000
commitc08066b520c7a4b55310176b92400eb9afbb3d40 (patch)
tree2df81305fda709e52caad6401e900eb1a6ffc8ba /sys-libs/glibc
parentmark stable (diff)
downloadgentoo-2-c08066b520c7a4b55310176b92400eb9afbb3d40.tar.gz
gentoo-2-c08066b520c7a4b55310176b92400eb9afbb3d40.tar.bz2
gentoo-2-c08066b520c7a4b55310176b92400eb9afbb3d40.zip
Enable SELinux support only on primary ABI on multilib systems.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild18
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild18
3 files changed, 35 insertions, 7 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index f08ee592b5a3..c7d3b29f7c26 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.396 2005/10/08 00:33:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.397 2005/10/08 04:19:36 pebenito Exp $
+
+ 08 Oct 2005; Chris PeBenito <pebenito@gentoo.org> glibc-2.3.5-r1.ebuild,
+ glibc-2.3.5-r2.ebuild:
+ Enable SELinux support only on primary ABI on multilib systems.
08 Oct 2005; Jeremy Huddleston <eradicator@gentoo.org>
glibc-2.3.5-r2.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 929976506738..f16446604bef 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.42 2005/10/05 03:18:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.43 2005/10/08 04:19:36 pebenito Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -879,8 +879,20 @@ glibc_do_configure() {
die "invalid pthread option"
fi
- if ! use build && use selinux; then
- myconf="${myconf} --with-selinux"
+ # Since SELinux support is only required for nscd, only enable it if:
+ # 1. USE selinux
+ # 2. ! USE build
+ # 3. only for the primary ABI on multilib systems
+ if use selinux && ! use build; then
+ if use multilib || has_multilib_profile; then
+ if is_final_abi; then
+ myconf="${myconf} --with-selinux"
+ else
+ myconf="${myconf} --without-selinux"
+ fi
+ else
+ myconf="${myconf} --with-selinux"
+ fi
else
myconf="${myconf} --without-selinux"
fi
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 48476a252a6c..a29ddbccdffb 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.8 2005/10/08 00:33:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.9 2005/10/08 04:19:36 pebenito Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -899,8 +899,20 @@ glibc_do_configure() {
die "invalid pthread option"
fi
- if ! use build && use selinux; then
- myconf="${myconf} --with-selinux"
+ # Since SELinux support is only required for nscd, only enable it if:
+ # 1. USE selinux
+ # 2. ! USE build
+ # 3. only for the primary ABI on multilib systems
+ if use selinux && ! use build; then
+ if use multilib || has_multilib_profile; then
+ if is_final_abi; then
+ myconf="${myconf} --with-selinux"
+ else
+ myconf="${myconf} --without-selinux"
+ fi
+ else
+ myconf="${myconf} --with-selinux"
+ fi
else
myconf="${myconf} --without-selinux"
fi