summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-29 18:42:41 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-29 18:42:41 +0000
commit126101eb342d6ca45f57504b7a9234b9d82b4af0 (patch)
treeb7bcc76173cac82024494d31150a11279344b220 /sys-libs/cracklib
parentMask multilib libart_lgpl & cracklib before committing. (diff)
downloadgentoo-2-126101eb342d6ca45f57504b7a9234b9d82b4af0.tar.gz
gentoo-2-126101eb342d6ca45f57504b7a9234b9d82b4af0.tar.bz2
gentoo-2-126101eb342d6ca45f57504b7a9234b9d82b4af0.zip
Enable multilib support, as a dependency of PAM.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/ChangeLog7
-rw-r--r--sys-libs/cracklib/cracklib-2.9.1-r1.ebuild108
2 files changed, 114 insertions, 1 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index ecb907fb8236..cfa3981e125a 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/cracklib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.190 2014/05/17 13:58:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.191 2014/05/29 18:42:41 mgorny Exp $
+
+*cracklib-2.9.1-r1 (29 May 2014)
+
+ 29 May 2014; Michał Górny <mgorny@gentoo.org> +cracklib-2.9.1-r1.ebuild:
+ Enable multilib support, as a dependency of PAM.
17 May 2014; Agostino Sarubbo <ago@gentoo.org> cracklib-2.9.1.ebuild:
Stable for alpha, wrt bug #503648
diff --git a/sys-libs/cracklib/cracklib-2.9.1-r1.ebuild b/sys-libs/cracklib/cracklib-2.9.1-r1.ebuild
new file mode 100644
index 000000000000..b735f822f256
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.9.1-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.9.1-r1.ebuild,v 1.1 2014/05/29 18:42:41 mgorny Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_OPTIONAL=1
+
+inherit eutils distutils-r1 libtool multilib-minimal toolchain-funcs
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://sourceforge.net/projects/cracklib"
+SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="nls python static-libs test zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ )"
+RDEPEND="${RDEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r6
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+do_python() {
+ multilib_is_native_abi || return 0
+ use python || return 0
+ pushd python > /dev/null || die
+ distutils-r1_src_${EBUILD_PHASE}
+ popd > /dev/null
+}
+
+pkg_setup() {
+ # workaround #195017
+ if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
+ eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
+ eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ fi
+}
+
+src_prepare() {
+ elibtoolize #269003
+ sed -i \
+ -e 's:_cracklib.c:@srcdir@/&:' \
+ -e '/include/s:builddir:srcdir:' \
+ python/setup.py.in || die
+ do_python
+}
+
+multilib_src_configure() {
+ export ac_cv_header_zlib_h=$(usex zlib)
+ export ac_cv_search_gzopen=$(usex zlib -lz no)
+ # use /usr/lib so that the dictionary is shared between ABIs
+ ECONF_SOURCE=${S} \
+ econf \
+ --with-default-dict='/usr/lib/cracklib_dict' \
+ --without-python \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+ do_python
+}
+
+multilib_src_test() {
+ do_python
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+multilib_src_install() {
+ default
+ # move shared libs to /
+ multilib_is_native_abi && gen_usr_ldscript -a crack
+
+ do_python
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ rm -r "${ED}"/usr/share/cracklib
+
+ insinto /usr/share/dict
+ doins dicts/cracklib-small || die
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+}