summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-05-27 02:26:44 +0000
committerBryon Roche <kain@gentoo.org>2002-05-27 02:26:44 +0000
commiteb450105d075350241a7067fac511a5638628f6c (patch)
tree76e88a23302588eaf290dd74dfedd510f55d9295 /sys-kernel
parentadded gdk-pixbuf to DEPEND (diff)
downloadgentoo-2-eb450105d075350241a7067fac511a5638628f6c.tar.gz
gentoo-2-eb450105d075350241a7067fac511a5638628f6c.tar.bz2
gentoo-2-eb450105d075350241a7067fac511a5638628f6c.zip
The last kernel I uploaded manifested a serious-looking memory corruption bug
after my first test run. :(
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ppc-sources/ChangeLog9
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r52
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19-r5.ebuild116
3 files changed, 126 insertions, 1 deletions
diff --git a/sys-kernel/ppc-sources/ChangeLog b/sys-kernel/ppc-sources/ChangeLog
index 50f0de4196eb..9538877d59de 100644
--- a/sys-kernel/ppc-sources/ChangeLog
+++ b/sys-kernel/ppc-sources/ChangeLog
@@ -1,6 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Id: ChangeLog,v 1.3 2002/05/27 00:12:35 kain Exp $
+# $Id: ChangeLog,v 1.4 2002/05/27 02:26:44 kain Exp $
+
+*ppc-sources-2.4.19-r5 (26 May 2002)
+
+ 26 May 2002; Kain <kain@kain.org> all :
+
+ Firewire still works, but otherwise this kernel is more like -r3.
+ The rmap vm doesn't seem to work too well on ppc after additional testing.
*ppc-sources-2.4.19-r4 (26 May 2002)
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r5 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r5
new file mode 100644
index 000000000000..0bfdcb6588e1
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r5
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 b0cb57363cf6427c566e69851d97f67a linux-gentoo-ppc-2.4.19-r5.patch.bz2 5867075
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19-r5.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r5.ebuild
new file mode 100644
index 000000000000..f3d2a8a7ba8b
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r5.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Kain X <kain@gentoo.org>
+# $Id: ppc-sources-2.4.19-r5.ebuild,v 1.1 2002/05/27 02:26:44 kain Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19-pre8-ben0
+# ati.2 Xfree86 4.2.0 DRM
+# Selected pre8aa patches:
+# 00_lowlatency-fixes-5
+# 70_xfs-1.1-0
+# 71_xfs-kiobuf-slab-1
+# 72_xfs-O_DIRECT-1
+# 73_xfs-blksize-PAGE_SIZE-1
+# Ani Joshi's rivafb bigendian fixes from YDL: I think these are in benh now
+
+
+DESCRIPTION="Full sources for the Gentoo Linux PPC kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.sunsite.dk/projects/gentooppc/distfiles/linux-gentoo-ppc-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+GENTOOPATCH=${DISTDIR}/linux-gentoo-ppc-${KV}.patch.bz2
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ pwd
+ bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}