summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-04-18 17:07:03 +0000
committerChristian Birchinger <joker@gentoo.org>2004-04-18 17:07:03 +0000
commite2169a08429903ec179095ef114e12e7b58b3b93 (patch)
treefbc79db78ffa4b90a03071ecb6930a7a6d4d0107 /sys-kernel
parentFix #42181 (Manifest recommit) (diff)
downloadgentoo-2-e2169a08429903ec179095ef114e12e7b58b3b93.tar.gz
gentoo-2-e2169a08429903ec179095ef114e12e7b58b3b93.tar.bz2
gentoo-2-e2169a08429903ec179095ef114e12e7b58b3b93.zip
Version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.262
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.26.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index ea47eb394a15..d06f9aed5b8a 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.53 2004/04/15 12:36:43 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.54 2004/04/18 17:07:03 joker Exp $
+
+*sparc-sources-2.4.26 (18 Apr 2004)
+
+ 18 Apr 2004; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.26.ebuild:
+ Version bump
*sparc-sources-2.4.25-r1 (15 Apr 2004)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26
new file mode 100644
index 000000000000..ce6ae7ed6f79
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26
@@ -0,0 +1,2 @@
+MD5 88d7aefa03c92739cb70298a0b486e2c linux-2.4.26.tar.bz2 30772389
+MD5 ec4db0cbb81c30dea24ee27287eb2ae2 patches-2.4.26-sparc.tar.bz2 145065
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.26.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.26.ebuild
new file mode 100644
index 000000000000..d8ef97841744
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.26.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.26.ebuild,v 1.1 2004/04/18 17:07:03 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${KV} || die "Unable to cd into ${KV}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}