summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-11 17:25:21 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-11 17:25:21 +0000
commitb691dc342a81980e834c86fe051c674d699867ee (patch)
tree6eeeae72ad5a8096a9bffba2ab225280722640cd /sys-kernel
parentFixes #8398. (diff)
downloadgentoo-2-b691dc342a81980e834c86fe051c674d699867ee.tar.gz
gentoo-2-b691dc342a81980e834c86fe051c674d699867ee.tar.bz2
gentoo-2-b691dc342a81980e834c86fe051c674d699867ee.zip
Version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r132
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r13.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r13 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r13
new file mode 100644
index 000000000000..958a8ddfe1ae
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r13
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 6685169d4fafc08b07fa722adc96662e uml-patch-2.4.19-13.bz2 146595
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r13.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r13.ebuild
new file mode 100644
index 000000000000..f2b8994deae7
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r13.ebuild,v 1.1 2002/10/11 17:25:21 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+