summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-11-22 16:31:08 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-11-22 16:31:08 +0000
commitacad1d596591aef909a16de1ef8210cc8d38ec5f (patch)
tree25e4d775777449330d5279739ae03c66912a2809 /sys-kernel
parentInstall configuration files in /etc/chrony. (diff)
downloadgentoo-2-acad1d596591aef909a16de1ef8210cc8d38ec5f.tar.gz
gentoo-2-acad1d596591aef909a16de1ef8210cc8d38ec5f.tar.bz2
gentoo-2-acad1d596591aef909a16de1ef8210cc8d38ec5f.zip
Version bump to 3.11.9 and 3.12.1, proxied commit for Eric F. GARIOUD; fixes bug #491874.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ck-sources/ChangeLog10
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.11.9.ebuild105
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.12.1.ebuild105
3 files changed, 219 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 4e00b40922fd..7c8b52f18133 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.225 2013/11/18 18:11:50 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.226 2013/11/22 16:31:08 tomwij Exp $
+
+*ck-sources-3.12.1 (22 Nov 2013)
+*ck-sources-3.11.9 (22 Nov 2013)
+
+ 22 Nov 2013; Tom Wijsman <TomWij@gentoo.org> +ck-sources-3.11.9.ebuild,
+ +ck-sources-3.12.1.ebuild:
+ Version bump to 3.11.9 and 3.12.1, proxied commit for Eric F. GARIOUD; fixes
+ bug #491874.
*ck-sources-3.10.17 (18 Nov 2013)
*ck-sources-3.9.11-r1 (18 Nov 2013)
diff --git a/sys-kernel/ck-sources/ck-sources-3.11.9.ebuild b/sys-kernel/ck-sources/ck-sources-3.11.9.ebuild
new file mode 100644
index 000000000000..d62b89000fea
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.11.9.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.11.9.ebuild,v 1.1 2013/11/22 16:31:08 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+IUSE="bfsonly"
+
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_EXP_GENPATCHES_PULL="1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_GENPATCHES_VER="13"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with Con Kolivas' high performance patchset and Gentoo's genpatches"
+
+#-- If Gentoo-Sources don't follow then extra incremental patches are needed -
+
+XTRA_INCP_MIN=""
+XTRA_INCP_MAX=""
+
+#--
+
+CK_VERSION="1"
+BFS_VERSION="441"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.bz2"
+BFS_FILE="${K_BRANCH_ID}-sched-bfs-${BFS_VERSION}.patch"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/3.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+BFS_URI="${CK_LVER_URL}/patches/${BFS_FILE}"
+
+#-- Build extra incremental patches list --------------------------------------
+
+LX_INCP_URI=""
+LX_INCP_LIST=""
+if [ -n "${XTRA_INCP_MIN}" ]; then
+ LX_INCP_URL="${KERNEL_BASE_URI}/incr"
+ for i in `seq ${XTRA_INCP_MIN} ${XTRA_INCP_MAX}`; do
+ LX_INCP[i]="patch-${K_BRANCH_ID}.${i}-$(($i+1)).bz2"
+ LX_INCP_URI="${LX_INCP_URI} ${LX_INCP_URL}/${LX_INCP[i]}"
+ LX_INCP_LIST="${LX_INCP_LIST} ${DISTDIR}/${LX_INCP[i]}"
+ done
+fi
+
+#-- CK needs sometimes to patch itself... (3.7)--------------------------------
+
+CK_INCP_URI=""
+CK_INCP_LIST=""
+
+#-- Local patches needed for the ck-patches to apply smoothly (3.4/3.5) -------
+
+PRE_CK_FIX=""
+POST_CK_FIX=""
+
+#--
+
+SRC_URI="${KERNEL_URI} ${LX_INCP_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_INCP_URI}
+ !bfsonly? ( ${CK_URI} )
+ bfsonly? ( ${BFS_URI} )"
+
+UNIPATCH_LIST="${LX_INCP_LIST} ${PRE_CK_FIX} ${DISTDIR}"
+
+if ! use bfsonly ; then
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${CK_FILE}"
+else
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${BFS_FILE}"
+fi
+
+UNIPATCH_LIST="${UNIPATCH_LIST} ${CK_INCP_LIST} ${POST_CK_FIX}"
+
+UNIPATCH_STRICTORDER="yes"
+
+#-- Since experimental genpatches && we want BFQ irrespective of experimental -
+
+K_EXP_GENPATCHES_LIST="50*_*.patch*"
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+
+ kernel-2_pkg_postinst
+
+ elog
+ elog "For more info on this patchset, see: http://forums.gentoo.org/viewtopic-t-941030-start-0.html"
+ elog
+}
diff --git a/sys-kernel/ck-sources/ck-sources-3.12.1.ebuild b/sys-kernel/ck-sources/ck-sources-3.12.1.ebuild
new file mode 100644
index 000000000000..9fd02c9e7d65
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.12.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.12.1.ebuild,v 1.1 2013/11/22 16:31:08 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+IUSE="bfsonly"
+
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_EXP_GENPATCHES_PULL="1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_GENPATCHES_VER="2"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with Con Kolivas' high performance patchset and Gentoo's genpatches"
+
+#-- If Gentoo-Sources don't follow then extra incremental patches are needed -
+
+XTRA_INCP_MIN=""
+XTRA_INCP_MAX=""
+
+#--
+
+CK_VERSION="1"
+BFS_VERSION="443"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.bz2"
+BFS_FILE="${K_BRANCH_ID}-sched-bfs-${BFS_VERSION}.patch"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/3.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+BFS_URI="${CK_LVER_URL}/patches/${BFS_FILE}"
+
+#-- Build extra incremental patches list --------------------------------------
+
+LX_INCP_URI=""
+LX_INCP_LIST=""
+if [ -n "${XTRA_INCP_MIN}" ]; then
+ LX_INCP_URL="${KERNEL_BASE_URI}/incr"
+ for i in `seq ${XTRA_INCP_MIN} ${XTRA_INCP_MAX}`; do
+ LX_INCP[i]="patch-${K_BRANCH_ID}.${i}-$(($i+1)).bz2"
+ LX_INCP_URI="${LX_INCP_URI} ${LX_INCP_URL}/${LX_INCP[i]}"
+ LX_INCP_LIST="${LX_INCP_LIST} ${DISTDIR}/${LX_INCP[i]}"
+ done
+fi
+
+#-- CK needs sometimes to patch itself... (3.7)--------------------------------
+
+CK_INCP_URI=""
+CK_INCP_LIST=""
+
+#-- Local patches needed for the ck-patches to apply smoothly (3.4/3.5) -------
+
+PRE_CK_FIX=""
+POST_CK_FIX=""
+
+#--
+
+SRC_URI="${KERNEL_URI} ${LX_INCP_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_INCP_URI}
+ !bfsonly? ( ${CK_URI} )
+ bfsonly? ( ${BFS_URI} )"
+
+UNIPATCH_LIST="${LX_INCP_LIST} ${PRE_CK_FIX} ${DISTDIR}"
+
+if ! use bfsonly ; then
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${CK_FILE}"
+else
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${BFS_FILE}"
+fi
+
+UNIPATCH_LIST="${UNIPATCH_LIST} ${CK_INCP_LIST} ${POST_CK_FIX}"
+
+UNIPATCH_STRICTORDER="yes"
+
+#-- Since experimental genpatches && we want BFQ irrespective of experimental -
+
+K_EXP_GENPATCHES_LIST="50*_*.patch*"
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+
+ kernel-2_pkg_postinst
+
+ elog
+ elog "For more info on this patchset, see: http://forums.gentoo.org/viewtopic-t-941030-start-0.html"
+ elog
+}