summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-04 17:47:29 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-04 17:47:29 +0000
commit8f6263a67f553aacae15068af5c0cc9793140be6 (patch)
treee493aba3c0d1dec340a039199e7eae7d02196c5a /sys-kernel
parentrepoman: whitespace cleanup (Manifest recommit) (diff)
downloadgentoo-2-8f6263a67f553aacae15068af5c0cc9793140be6.tar.gz
gentoo-2-8f6263a67f553aacae15068af5c0cc9793140be6.tar.bz2
gentoo-2-8f6263a67f553aacae15068af5c0cc9793140be6.zip
Added a patch to linux-headers-2.6.6 to solve sash issues on ARM and possibly other architectures. Closes bug #42527.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/ChangeLog7
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.6-appCompat.patch39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 5dd7cf175b30..f3ebdbc9a8e8 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.74 2004/06/03 16:07:31 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.75 2004/06/04 17:47:29 plasmaroo Exp $
+
+ 04 Jun 2004; <plasmaroo@gentoo.org>
+ files/linux-headers-2.6.6-appCompat.patch:
+ Added a patch to linux-headers-2.6.6 to solve sash issues on ARM and possibly
+ other architectures. Closes bug #42527.
03 Jun 2004; Travis Tilley <lv@gentoo.org> linux-headers-2.6.6.ebuild:
added ~amd64 to keywords
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.6-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.6-appCompat.patch
index 54366e079681..85b8947455eb 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.6-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.6-appCompat.patch
@@ -842,3 +842,42 @@ diff -ur linux-2.6.6/include/asm-x86_64/sigcontext.h linux-2.6.6-gentoo/include/
#endif
+#endif
+diff -ur linux-2.6.6/include/linux/gfp.h linux-2.6.6-gentoo/include/linux/gfp.h
+--- linux-2.6.6/include/linux/gfp.h 2004-04-04 04:36:52.000000000 +0100
++++ linux-2.6.6-gentoo/include/linux/gfp.h 2004-05-11 19:51:06.412779200 +0100
+@@ -48,6 +48,7 @@
+
+ #define GFP_DMA __GFP_DMA
+
++#ifdef __KERNEL__
+
+ /*
+ * There is only one page-allocator function, and two main namespaces to
+@@ -96,4 +97,5 @@
+
+ void page_alloc_init(void);
+
++#endif /* __KERNEL__ */
+ #endif /* __LINUX_GFP_H */
+diff -ur linux-2.6.6/include/linux/percpu.h linux-2.6.6-gentoo/include/linux/percpu.h
+--- linux-2.6.6/include/linux/percpu.h 2004-04-04 04:38:14.000000000 +0100
++++ linux-2.6.6-gentoo/include/linux/percpu.h 2004-05-11 19:33:00.987788880 +0100
+@@ -1,5 +1,6 @@
+ #ifndef __LINUX_PERCPU_H
+ #define __LINUX_PERCPU_H
++#include <linux/gfp.h>
+ #include <linux/spinlock.h> /* For preempt_disable() */
+ #include <linux/slab.h> /* For kmalloc() */
+ #include <linux/smp.h>
+diff -ur linux-2.6.6/include/linux/percpu_counter.h linux-2.6.6-gentoo/include/linux/percpu_counter.h
+--- linux-2.6.6/include/linux/percpu_counter.h 2004-04-04 04:37:23.000000000 +0100
++++ linux-2.6.6-gentoo/include/linux/percpu_counter.h 2004-05-11 19:46:31.423583912 +0100
+@@ -4,6 +4,7 @@
+ * WARNING: these things are HUGE. 4 kbytes per counter on 32-way P4.
+ */
+
++#include <linux/preempt.h>
+ #include <linux/config.h>
+ #include <linux/spinlock.h>
+ #include <linux/smp.h>
+