summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-10-10 11:04:22 +0000
committerBryon Roche <kain@gentoo.org>2002-10-10 11:04:22 +0000
commit5e0f54a4509fb59aaef42ecd8c4f7e0dba231d31 (patch)
tree61f9570687a27d41b37f7a6d1e97530b4056fcb5 /sys-kernel
parentfixed typo (diff)
downloadgentoo-2-5e0f54a4509fb59aaef42ecd8c4f7e0dba231d31.tar.gz
gentoo-2-5e0f54a4509fb59aaef42ecd8c4f7e0dba231d31.tar.bz2
gentoo-2-5e0f54a4509fb59aaef42ecd8c4f7e0dba231d31.zip
new ppc kernel
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ppc-sources/ChangeLog8
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r12
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.20-r1.ebuild110
3 files changed, 119 insertions, 1 deletions
diff --git a/sys-kernel/ppc-sources/ChangeLog b/sys-kernel/ppc-sources/ChangeLog
index 49b596af8c1d..f9fdd10e186b 100644
--- a/sys-kernel/ppc-sources/ChangeLog
+++ b/sys-kernel/ppc-sources/ChangeLog
@@ -1,6 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Id: ChangeLog,v 1.6 2002/07/16 04:39:54 gerk Exp $
+# $Id: ChangeLog,v 1.7 2002/10/10 11:04:22 kain Exp $
+
+*ppc-sources-2.4.20-r1 (10 Oct 2002)
+
+ 10 Oct 2002; Kain <kain@kain.org> ppc-sources-2.4.20-r1 :
+
+ New PPC benh kernel + XFS. Please remember that turning on XFS is optional.
*ppc-sources-2.4.19-r6 (12 Jun 2002)
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r1 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r1
new file mode 100644
index 000000000000..cecc52a22980
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r1
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 0527cb579ab1263b34ad3bfa86c227eb linux-gentoo-ppc-2.4.20-r1.patch.bz2 4554142
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.20-r1.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.20-r1.ebuild
new file mode 100644
index 000000000000..84f13c2259f2
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.20-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Id: ppc-sources-2.4.20-r1.ebuild,v 1.1 2002/10/10 11:04:22 kain Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.20-pre9-benh
+# from http://oss.sgi.com/projects/xfs:
+# SGI XFS 2.4.19 (Official release code -- the most thoroughly tested)
+
+DESCRIPTION="Full sources for the Gentoo Linux PPC kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 mirror://gentoo/linux-gentoo-ppc-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc -x86 -sparc -sparc64"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+GENTOOPATCH=${DISTDIR}/linux-gentoo-ppc-${KV}.patch.bz2
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ pwd
+ bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}