summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-13 19:46:05 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-13 19:46:05 +0000
commit4e00cac3781bf3d01329976d2a4ba1798969b78c (patch)
treea9d9a4e9286d226e5a0d7987c08fe95817f99978 /sys-kernel
parentVersion bump for the 3.4 / 3.9 / 3.10 series, remove old. (diff)
downloadgentoo-2-4e00cac3781bf3d01329976d2a4ba1798969b78c.tar.gz
gentoo-2-4e00cac3781bf3d01329976d2a4ba1798969b78c.tar.bz2
gentoo-2-4e00cac3781bf3d01329976d2a4ba1798969b78c.zip
Linux patches 3.4.53, 3.9.10 and 3.10.1.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog10
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.10.1.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.4.53.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.9.10.ebuild29
4 files changed, 96 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index a6b2f550d671..9498fd17a67d 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1153 2013/07/13 18:31:41 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1154 2013/07/13 19:46:05 tomwij Exp $
+
+*gentoo-sources-3.10.1 (13 Jul 2013)
+*gentoo-sources-3.9.10 (13 Jul 2013)
+*gentoo-sources-3.4.53 (13 Jul 2013)
+
+ 13 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +gentoo-sources-3.10.1.ebuild,
+ +gentoo-sources-3.4.53.ebuild, +gentoo-sources-3.9.10.ebuild:
+ Linux patches 3.4.53, 3.9.10 and 3.10.1.
*gentoo-sources-3.0.86 (13 Jul 2013)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.10.1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.10.1.ebuild
new file mode 100644
index 000000000000..82f7d14e733b
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.10.1.ebuild,v 1.1 2013/07/13 19:46:05 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="4"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.4.53.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.4.53.ebuild
new file mode 100644
index 000000000000..6dd201818bd0
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.4.53.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.4.53.ebuild,v 1.1 2013/07/13 19:46:05 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="35"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.9.10.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.9.10.ebuild
new file mode 100644
index 000000000000..cb6da9e117b7
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.9.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.9.10.ebuild,v 1.1 2013/07/13 19:46:05 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="15"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}