summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-11-07 21:55:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-11-07 21:55:09 +0000
commit1c704638085c291286c783175ebb57ab6f754cec (patch)
tree9387279b184d49cf30a0e530de6a9b7cef055fd3 /sys-kernel
parenthardened-sources-2.6.32-r25 based on 2.6.32.25 + genpatches + grsecurity-2.2.... (diff)
downloadgentoo-2-1c704638085c291286c783175ebb57ab6f754cec.tar.gz
gentoo-2-1c704638085c291286c783175ebb57ab6f754cec.tar.bz2
gentoo-2-1c704638085c291286c783175ebb57ab6f754cec.zip
hardened-sources-2.6.35-r7 based on 2.6.35.8 + genpatches + grsecurity-2.2.0-2.6.35.8-201011062054
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.35-r7.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 153da019c652..a0b28a0096c4 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.353 2010/11/07 21:52:34 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.354 2010/11/07 21:55:09 blueness Exp $
+
+*hardened-sources-2.6.35-r7 (07 Nov 2010)
+
+ 07 Nov 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.35-r7.ebuild:
+ hardened-sources-2.6.35-r7 based on 2.6.35.8 + genpatches +
+ grsecurity-2.2.0-2.6.35.8-201011062054
*hardened-sources-2.6.32-r25 (07 Nov 2010)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.35-r7.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.35-r7.ebuild
new file mode 100644
index 000000000000..3e7021c1f941
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.35-r7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.35-r7.ebuild,v 1.1 2010/11/07 21:55:09 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-8"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}