summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-10-21 18:33:36 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-10-21 18:33:36 +0000
commit78169f1c8750566c43fb5eb0843b19484d559b2a (patch)
tree264aa0d78f13792aa0103bdb7ca0a56c7b409e87 /sys-kernel/win4lin-sources
parents390/ppc64 stable to finish off the love (Manifest recommit) (diff)
downloadgentoo-2-78169f1c8750566c43fb5eb0843b19484d559b2a.tar.gz
gentoo-2-78169f1c8750566c43fb5eb0843b19484d559b2a.tar.bz2
gentoo-2-78169f1c8750566c43fb5eb0843b19484d559b2a.zip
Version bumped to address CAN-2004-0816; bug #68375.
Diffstat (limited to 'sys-kernel/win4lin-sources')
-rw-r--r--sys-kernel/win4lin-sources/ChangeLog9
-rw-r--r--sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.6.7-r6 (renamed from sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.6.7-r5)0
-rw-r--r--sys-kernel/win4lin-sources/files/win4lin-sources-2.6.CAN-2004-0816.patch43
-rw-r--r--sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r6.ebuild (renamed from sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r5.ebuild)5
4 files changed, 54 insertions, 3 deletions
diff --git a/sys-kernel/win4lin-sources/ChangeLog b/sys-kernel/win4lin-sources/ChangeLog
index 98d70f57bbaa..cb6a6c716bf8 100644
--- a/sys-kernel/win4lin-sources/ChangeLog
+++ b/sys-kernel/win4lin-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/win4lin-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/ChangeLog,v 1.36 2004/08/26 01:14:37 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/ChangeLog,v 1.37 2004/10/21 18:33:36 plasmaroo Exp $
+
+*win4lin-sources-2.6.7-r6 (21 Oct 2004)
+
+ 21 Oct 2004; <plasmaroo@gentoo.org> -win4lin-sources-2.6.7-r5.ebuild,
+ +win4lin-sources-2.6.7-r6.ebuild,
+ +files/win4lin-sources-2.6.CAN-2004-0816.patch:
+ Version bumped to address CAN-2004-0816; bug #68375.
26 Aug 2004; <plasmaroo@gentoo.org> win4lin-sources-2.6.7-r5.ebuild:
Marking the 2.6 version as "~x86"; bug #55587.
diff --git a/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.6.7-r5 b/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.6.7-r6
index bb24ec457f28..bb24ec457f28 100644
--- a/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.6.7-r5
+++ b/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.6.7-r6
diff --git a/sys-kernel/win4lin-sources/files/win4lin-sources-2.6.CAN-2004-0816.patch b/sys-kernel/win4lin-sources/files/win4lin-sources-2.6.CAN-2004-0816.patch
new file mode 100644
index 000000000000..13a9ea2f5aa4
--- /dev/null
+++ b/sys-kernel/win4lin-sources/files/win4lin-sources-2.6.CAN-2004-0816.patch
@@ -0,0 +1,43 @@
+Subject: Prevent ICMP crash in netfilter logging
+From: Olaf Kirch <okir@suse.de>
+References: 46016
+
+This patch fixes a remotely triggerable crash in the netfilter code
+when looking at ICMP unreachables. It dies when trying to copy
+BIGNUM bytes...
+
+Index: linux-2.6.5/net/ipv4/netfilter/ipt_LOG.c
+===================================================================
+--- linux-2.6.5.orig/net/ipv4/netfilter/ipt_LOG.c 2004-02-19 11:36:37.000000000 +0100
++++ linux-2.6.5/net/ipv4/netfilter/ipt_LOG.c 2004-09-24 15:48:54.000000000 +0200
+@@ -71,7 +71,7 @@
+ printk("FRAG:%u ", ntohs(iph.frag_off) & IP_OFFSET);
+
+ if ((info->logflags & IPT_LOG_IPOPT)
+- && iph.ihl * 4 != sizeof(struct iphdr)) {
++ && iph.ihl * 4 > sizeof(struct iphdr)) {
+ unsigned char opt[4 * 15 - sizeof(struct iphdr)];
+ unsigned int i, optsize;
+
+@@ -138,7 +138,7 @@
+ printk("URGP=%u ", ntohs(tcph.urg_ptr));
+
+ if ((info->logflags & IPT_LOG_TCPOPT)
+- && tcph.doff * 4 != sizeof(struct tcphdr)) {
++ && tcph.doff * 4 > sizeof(struct tcphdr)) {
+ unsigned char opt[4 * 15 - sizeof(struct tcphdr)];
+ unsigned int i, optsize;
+
+Index: linux-2.6.5/net/ipv6/netfilter/ip6t_LOG.c
+===================================================================
+--- linux-2.6.5.orig/net/ipv6/netfilter/ip6t_LOG.c 2004-09-24 15:47:00.000000000 +0200
++++ linux-2.6.5/net/ipv6/netfilter/ip6t_LOG.c 2004-09-24 15:48:35.000000000 +0200
+@@ -188,7 +188,7 @@
+ printk("URGP=%u ", ntohs(tcph->urg_ptr));
+
+ if ((info->logflags & IP6T_LOG_TCPOPT)
+- && tcph->doff * 4 != sizeof(struct tcphdr)) {
++ && tcph->doff * 4 > sizeof(struct tcphdr)) {
+ unsigned int i;
+
+ /* Max length: 127 "OPT (" 15*4*2chars ") " */
diff --git a/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r5.ebuild b/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r6.ebuild
index b108b0cdb907..79ea80a46e11 100644
--- a/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r5.ebuild
+++ b/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r5.ebuild,v 1.3 2004/08/26 01:14:37 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r6.ebuild,v 1.1 2004/10/21 18:33:36 plasmaroo Exp $
ETYPE="sources"
inherit kernel-2
@@ -15,7 +15,8 @@ UNIPATCH_LIST="
${FILESDIR}/${PN}-2.6.CAN-2004-0596.patch
${FILESDIR}/${PN}-2.6.IPTables-RDoS.patch
${FILESDIR}/${PN}-2.6.ProcPerms.patch
- ${FILESDIR}/${PN}-2.6.cmdlineLeak.patch"
+ ${FILESDIR}/${PN}-2.6.cmdlineLeak.patch
+ ${FILESDIR}/${PN}-2.6.CAN-2004-0816.patch"
S=${WORKDIR}/linux-${KV}