summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2002-11-30 18:15:57 +0000
committerSeth Chandler <sethbc@gentoo.org>2002-11-30 18:15:57 +0000
commitaca264eaaec518762bc3a1eaffe9a9dbd295b4a3 (patch)
treeba2cc0dd8da22a4da02dea6883a2162841b3413a /sys-kernel/mjc-sources
parentversion bump on mjc-sources as per convo with mjc (diff)
downloadgentoo-2-aca264eaaec518762bc3a1eaffe9a9dbd295b4a3.tar.gz
gentoo-2-aca264eaaec518762bc3a1eaffe9a9dbd295b4a3.tar.bz2
gentoo-2-aca264eaaec518762bc3a1eaffe9a9dbd295b4a3.zip
bump
Diffstat (limited to 'sys-kernel/mjc-sources')
-rw-r--r--sys-kernel/mjc-sources/mjc-sources-2.4.20-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/mjc-sources/mjc-sources-2.4.20-r1.ebuild b/sys-kernel/mjc-sources/mjc-sources-2.4.20-r1.ebuild
new file mode 100644
index 000000000000..de1e8e07aa9a
--- /dev/null
+++ b/sys-kernel/mjc-sources/mjc-sources-2.4.20-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mjc-sources/mjc-sources-2.4.20-r1.ebuild,v 1.1 2002/11/30 18:15:57 sethbc Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV=2.4.20
+KV=2.4.20-mjc1
+EXTRAVERSION=-mjc2
+S=${WORKDIR}/linux-${KV}
+DESCRIPTION="Full sources for MJC's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://www.kernel.org/pub/linux/kernel/people/mjc/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ unpack patches-${KV}.tar.bz2
+ cd ${KV}
+
+ kernel_src_unpack
+
+ cd ${WORKDIR}/linux-${KV}
+ patch -p1 < ${FILESDIR}/linux-${KV}-gentoo.diff || die "Quickfixes failed"
+
+}