summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-07 07:27:43 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-07 07:27:43 +0000
commit7e9f3f22287741b4030825e9c1b77b027c25b0e0 (patch)
treedc2b759f90e790cef6a1819301ed7fc291be518f /sys-kernel/linux-headers/linux-headers-2.4.16.ebuild
parentuse sed -i; sed in unpack; error message for emake; Readme.txt, not Readme (diff)
downloadgentoo-2-7e9f3f22287741b4030825e9c1b77b027c25b0e0.tar.gz
gentoo-2-7e9f3f22287741b4030825e9c1b77b027c25b0e0.tar.bz2
gentoo-2-7e9f3f22287741b4030825e9c1b77b027c25b0e0.zip
repoman: trim trailing whitespace
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.16.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.16.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.16.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.16.ebuild
index c17fb6fdb495..28247bfa3319 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.16.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.16.ebuild,v 1.13 2003/03/24 23:34:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.16.ebuild,v 1.14 2003/09/07 07:26:01 msterret Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
@@ -31,9 +31,9 @@ SRC_URI="http://www.de.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2"
[ "$ACPIV" ] && { SRC_URI="$SRC_URI http://developer.intel.com/technology/iapc/acpi/downloads/acpi-${ACPIV}.diff.gz"; PATCHES="$PATCHES ${DISTDIR}/acpi-${ACPIV}.diff.gz"; }
[ "$LOWLV" ] && { SRC_URI="$SRC_URI http://www.zip.com.au/~akpm/linux/${LOWLV}-low-latency.patch.gz"; PATCHES="$PATCHES ${DISTDIR}/${LOWLV}-low-latency.patch.gz"; }
[ "$PREEV" ] && { SRC_URI="$SRC_URI http://www.kernel.org/pub/linux/kernel/people/rml/preempt-kernel/v2.4/preempt-kernel-rml-${PREEV}.patch" PATCHES="$PATCHES ${DISTDIR}/preempt-kernel-rml-${PREEV}.patch"; }
-
+
PROVIDE="virtual/kernel virtual/os-headers"
-HOMEPAGE="http://www.kernel.org/ http://www.namesys.com http://www.sistina.com/lvm/ http://developer.intel.com/technology/iapc/acpi/"
+HOMEPAGE="http://www.kernel.org/ http://www.namesys.com http://www.sistina.com/lvm/ http://developer.intel.com/technology/iapc/acpi/"
if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
then
@@ -46,7 +46,7 @@ fi
patchorama() {
local x
- for x in ${*}
+ for x in ${*}
do
[ -d "$x" ] && continue
echo ">>> Applying ${x}..."
@@ -77,7 +77,7 @@ src_unpack() {
cd ${S}
patchorama $PATCHES
echo "Preparing for compilation..."
-
+
#sometimes we have icky kernel symbols; this seems to get rid of them
make mrproper || die
@@ -85,7 +85,7 @@ src_unpack() {
cp ${S}/arch/i386/defconfig .config || die
yes "" | make oldconfig
echo "Ignore any errors from the yes command above."
-
+
#fix silly permissions in tarball
cd ${WORKDIR}
chown -R 0.0 *
@@ -98,7 +98,7 @@ src_unpack() {
Makefile.orig >Makefile || die # test, remove me if Makefile ok
rm Makefile.orig
}
-
+
src_compile() {
if [ "${PN}" = "linux-headers" ]
then