summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2008-04-30 11:32:44 +0000
committerChristian Heim <phreak@gentoo.org>2008-04-30 11:32:44 +0000
commit4bbea62448c1c0ed89c35664f84e6263406e7360 (patch)
treee936203ab1464eab0612b344d99cd57fcf3e5c42 /sys-kernel/hardened-sources
parentVersion bump (diff)
downloadgentoo-2-4bbea62448c1c0ed89c35664f84e6263406e7360.tar.gz
gentoo-2-4bbea62448c1c0ed89c35664f84e6263406e7360.tar.bz2
gentoo-2-4bbea62448c1c0ed89c35664f84e6263406e7360.zip
Revision bump (thanks to Kerin and Gordon, again), solving #213811, #219089. Additional contains "various other fixes".
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.23-r10.ebuild35
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 852edc07fc8f..9cccad8d4c2a 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.217 2008/04/09 08:30:07 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.218 2008/04/30 11:32:44 phreak Exp $
+
+*hardened-sources-2.6.23-r10 (30 Apr 2008)
+
+ 30 Apr 2008; Christian Heim <phreak@gentoo.org>
+ +hardened-sources-2.6.23-r10.ebuild:
+ Revision bump (thanks to Kerin and Gordon, again), solving #213811, #219089.
+ Additional contains "various other fixes".
09 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Update the longdescription in metadata, thanks to Gordon Malm.
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.23-r10.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r10.ebuild
new file mode 100644
index 000000000000..24209b8b6a77
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.23-r10.ebuild,v 1.1 2008/04/30 11:32:44 phreak Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-8
+HGPV_URI="http://confucius.dh.bytemark.co.uk/~kerin.millar/distfiles/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4-2.6.23-rc7.patch 4205_uvesafb-0.1-rc3-2.6.23-rc3.patch 4405_alpha-sysctl-uac.patch"
+DESCRIPTION="Hardened kernel sources ${OKV}"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "The options selected by the \"Hardened [Gentoo]\" security level"
+ ewarn "(GRKERNSEC_HARDENED) have been revised for this release. If you intend"
+ ewarn "to import a previous kernel configuration which uses this level then"
+ ewarn "please remember to review these changes before you build the kernel. In"
+ ewarn "particular, x86 users should note that PAX_MEMORY_UDEREF is now enabled"
+ ewarn "which is known not to work well in some virtualised environments. If this"
+ ewarn "affects you then you should switch to the \"Custom\" security level and"
+ ewarn "disable the option."
+ ewarn
+}