summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-05-01 22:16:54 +0000
committerNed Ludd <solar@gentoo.org>2008-05-01 22:16:54 +0000
commit1e92f240fe3a02c8cbf61788a9e9419fc6024bce (patch)
treeec354451effa0cbfe3389a3ebbb48c681ddf660a /sys-kernel/hardened-sources
parentversion bump (diff)
downloadgentoo-2-1e92f240fe3a02c8cbf61788a9e9419fc6024bce.tar.gz
gentoo-2-1e92f240fe3a02c8cbf61788a9e9419fc6024bce.tar.bz2
gentoo-2-1e92f240fe3a02c8cbf61788a9e9419fc6024bce.zip
- version bump to fix ulgy linux bugs
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog7
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.23-r11.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 75ac41aa8ba1..5d685798fcb6 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.219 2008/04/30 11:45:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.220 2008/05/01 22:16:54 solar Exp $
+
+*hardened-sources-2.6.23-r11 (01 May 2008)
+
+ 01 May 2008; <solar@gentoo.org> +hardened-sources-2.6.23-r11.ebuild:
+ - version bump to fix ulgy linux bugs
*hardened-sources-2.6.24-r1 (30 Apr 2008)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.23-r11.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r11.ebuild
new file mode 100644
index 000000000000..db22917dd55c
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.23-r11.ebuild,v 1.1 2008/05/01 22:16:54 solar Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-9
+HGPV_URI="http://confucius.dh.bytemark.co.uk/~kerin.millar/distfiles/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4-2.6.23-rc7.patch 4205_uvesafb-0.1-rc3-2.6.23-rc3.patch 4405_alpha-sysctl-uac.patch"
+DESCRIPTION="Hardened kernel sources ${OKV}"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "The options selected by the \"Hardened [Gentoo]\" security level"
+ ewarn "(GRKERNSEC_HARDENED) have been revised for this release. If you intend"
+ ewarn "to import a previous kernel configuration which uses this level then"
+ ewarn "please remember to review these changes before you build the kernel. In"
+ ewarn "particular, x86 users should note that PAX_MEMORY_UDEREF is now enabled"
+ ewarn "which is known not to work well in some virtualised environments. If this"
+ ewarn "affects you then you should switch to the \"Custom\" security level and"
+ ewarn "disable the option."
+ ewarn
+}