summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2009-01-20 23:29:52 +0000
committerGordon Malm <gengor@gentoo.org>2009-01-20 23:29:52 +0000
commit0fc8bdc7226189258478aa84e92b3e79cb44f59c (patch)
tree17cb8dfee4bc52f2f4c28b6415811c3b08f8f960 /sys-kernel/hardened-sources
parentold (diff)
downloadgentoo-2-0fc8bdc7226189258478aa84e92b3e79cb44f59c.tar.gz
gentoo-2-0fc8bdc7226189258478aa84e92b3e79cb44f59c.tar.bz2
gentoo-2-0fc8bdc7226189258478aa84e92b3e79cb44f59c.zip
Add hardened-sources-2.6.25-r13 release
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-hardened-r4-rc1-2009011401 i686)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.25-r13.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index e47839f59729..edf488b3b1f4 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.271 2009/01/20 18:05:47 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.272 2009/01/20 23:29:52 gengor Exp $
+
+*hardened-sources-2.6.25-r13 (20 Jan 2009)
+
+ 20 Jan 2009; Gordon Malm <gengor@gentoo.org>
+ +hardened-sources-2.6.25-r13.ebuild:
+ Revert RLIMIT_STACK false-positives-avoidance patch. Bugs 253773, 254843
20 Jan 2009; nixnut <nixnut@gentoo.org>
hardened-sources-2.6.25-r12.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.25-r13.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.25-r13.ebuild
new file mode 100644
index 000000000000..2202f7a2d381
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.25-r13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.25-r13.ebuild,v 1.1 2009/01/20 23:29:52 gengor Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="11"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-14"
+HGPV_URI="http://dev.gentoo.org/~gengor/distfiles/${CATEGORY}/${PN}/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.1.12*"
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined"
+ ewarn "\"Hardened [Gentoo]\" grsecurity level has been removed."
+ ewarn "Two improved predefined security levels replace it:"
+ ewarn "\"Hardened Gentoo [server]\" and \"Hardened Gentoo [workstation]\""
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.24,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with kernel series ${OKV}."
+ ewarn "Therefore, it is strongly recommended that the following command is"
+ ewarn "issued prior to booting a ${P} series kernel for"
+ ewarn "the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}