summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-08-09 23:38:45 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-08-09 23:38:45 +0000
commit84131495cb2e085038942343db13be3145851e46 (patch)
tree0909c0860c543e5d0f42d00d6dfaa20950628fa9 /sys-kernel/gs-sources
parentAdded security fixes (see #57826, #59378 and #59905). Fix firmware.c. (Manife... (diff)
downloadgentoo-2-84131495cb2e085038942343db13be3145851e46.tar.gz
gentoo-2-84131495cb2e085038942343db13be3145851e46.tar.bz2
gentoo-2-84131495cb2e085038942343db13be3145851e46.zip
Version bump for the /proc/cmdline leak vulnerability; bug #59905.
Diffstat (limited to 'sys-kernel/gs-sources')
-rw-r--r--sys-kernel/gs-sources/ChangeLog8
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r11 (renamed from sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r10)0
-rw-r--r--sys-kernel/gs-sources/files/gs-sources.cmdlineLeak.patch11
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r11.ebuild (renamed from sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r10.ebuild)7
4 files changed, 22 insertions, 4 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index d782e3103d4d..6f3cb28f34d1 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.49 2004/08/08 18:47:27 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.50 2004/08/09 23:38:45 plasmaroo Exp $
+
+*gs-sources-2.4.25_pre7-r11 (10 Aug 2004)
+
+ 10 Aug 2004; <plasmaroo@gentoo.org> -gs-sources-2.4.25_pre7-r10.ebuild,
+ +gs-sources-2.4.25_pre7-r11.ebuild, +files/gs-sources.cmdlineLeak.patch:
+ Version bump for the /proc/cmdline leak vulnerability; bug #59905.
*gs-sources-2.4.25_pre7-r10 (08 Aug 2004)
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r10 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r11
index 6e0a8e42bbb2..6e0a8e42bbb2 100644
--- a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r10
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r11
diff --git a/sys-kernel/gs-sources/files/gs-sources.cmdlineLeak.patch b/sys-kernel/gs-sources/files/gs-sources.cmdlineLeak.patch
new file mode 100644
index 000000000000..5f26f7f388f6
--- /dev/null
+++ b/sys-kernel/gs-sources/files/gs-sources.cmdlineLeak.patch
@@ -0,0 +1,11 @@
+--- linux-2.4/fs/proc/base.c 2004-04-15 07:09:32.000000000 +0100
++++ linux-2.4/fs/proc/base.c.plasmaroo 2004-08-09 23:30:43.869195800 +0100
+@@ -187,7 +187,7 @@ static int proc_pid_cmdline(struct task_
+ if (mm)
+ atomic_inc(&mm->mm_users);
+ task_unlock(task);
+- if (mm) {
++ if (mm && mm->arg_end) {
+ int len = mm->arg_end - mm->arg_start;
+ if (len > PAGE_SIZE)
+ len = PAGE_SIZE;
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r10.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r11.ebuild
index 514970868063..e0e7e55a175c 100644
--- a/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r10.ebuild
+++ b/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r10.ebuild,v 1.1 2004/08/08 18:47:27 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r11.ebuild,v 1.1 2004/08/09 23:38:45 plasmaroo Exp $
IUSE="crypt"
@@ -30,7 +30,7 @@ S=${WORKDIR}/linux-${KV}
DESCRIPTION="This kernel stays up to date with current kernel -pre's, with recent ACPI,
EVMS, Win4Lin, aic79xx, Super FreeS/WAN, preempt, and various hardware fixes."
SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patches-${KV/r10/r1}.tar.bz2
+ mirror://gentoo/patches-${KV/r11/r1}.tar.bz2
http://dev.gentoo.org/~plasmaroo/patches/kernel/misc/security/linux-2.4.26-CAN-2004-0415.patch"
KEYWORDS="x86 -ppc -sparc"
SLOT="${KV}"
@@ -38,7 +38,7 @@ SLOT="${KV}"
src_unpack() {
unpack ${A}
mv linux-${OKV} linux-${KV} || die
- cd ${KV/r10/r1} || die
+ cd ${KV/r11/r1} || die
# Kill patches we aren't suppposed to use, don't worry about
# failures, if they aren't there that is a good thing!
# This is the ratified crypt USE flag, enables IPSEC and patch-int
@@ -68,4 +68,5 @@ src_unpack() {
epatch ${FILESDIR}/${PN}.CAN-2004-0685.patch || die "Failed to add the CAN-2004-0685 patch!"
epatch ${FILESDIR}/${PN}.FPULockup-53804.patch || die "Failed to apply FPU-lockup patch!"
epatch ${FILESDIR}/${PN}.MKI.CompileFix.patch || die "Failed to apply MKI compilefix patch!"
+ epatch ${FILESDIR}/${PN}.cmdlineLeak.patch || die "Failed to apply the /proc/cmdline patch!"
}