summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-03-09 20:06:40 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-03-09 20:06:40 +0000
commit2ddd3ddd10121485cf2699e79a49fa60727fcd08 (patch)
tree3e3ec36aebf0fd4b743312f2012c81095e0bb460 /sys-kernel/dracut
parentFix leechcraft.eclass to support new category, bug #460958. (diff)
downloadgentoo-2-2ddd3ddd10121485cf2699e79a49fa60727fcd08.tar.gz
gentoo-2-2ddd3ddd10121485cf2699e79a49fa60727fcd08.tar.bz2
gentoo-2-2ddd3ddd10121485cf2699e79a49fa60727fcd08.zip
Version bump.
NEWS ~~~~ - do not strip signed kernel modules - add sosreport script and generate /run/initramfs/sosreport.txt - make short uuid specification for allow-discards work - turn off RateLimit for the systemd journal - fixed MAC address assignment - add systemd checkisomd5 service - splitout drm kernel modules from plymouth module - add 'swapoff' to initramfs to fix shutdown/reboot - add team device support - add pre-shutdown hook - kill all processes in shutdown and report remaining ones - "--device" changed to "--add-device" and "add_device=" added for conf files - add memory usage trace to different hook points - cope with optional field #7 in /proc/self/mountinfo - lots of small bugfixes (Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/ChangeLog32
-rw-r--r--sys-kernel/dracut/dracut-025.ebuild290
-rw-r--r--sys-kernel/dracut/files/025-0001-dracut-functions.sh-support-for-altern.patch37
-rw-r--r--sys-kernel/dracut/files/025-0002-gentoo.conf-let-udevdir-be-handled-by-.patch30
-rw-r--r--sys-kernel/dracut/files/025-0003-rootfs-block-mount-root.sh-fixup-for-8.patch29
-rw-r--r--sys-kernel/dracut/files/025-0004-dracut.sh-reverting-return-value-chang.patch41
-rw-r--r--sys-kernel/dracut/files/025-0005-Mount-proc-before-including-dracut-lib.patch44
7 files changed, 502 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index ef4c1a1cb696..40aa01a8eba2 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,36 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.109 2013/02/02 23:12:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.110 2013/03/09 20:06:40 aidecoe Exp $
+
+*dracut-025 (09 Mar 2013)
+
+ 09 Mar 2013; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +files/025-0001-dracut-functions.sh-support-for-altern.patch,
+ +files/025-0002-gentoo.conf-let-udevdir-be-handled-by-.patch,
+ +files/025-0003-rootfs-block-mount-root.sh-fixup-for-8.patch,
+ +files/025-0004-dracut.sh-reverting-return-value-chang.patch,
+ +files/025-0005-Mount-proc-before-including-dracut-lib.patch,
+ +dracut-025.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+
+ - do not strip signed kernel modules
+ - add sosreport script and generate /run/initramfs/sosreport.txt
+ - make short uuid specification for allow-discards work
+ - turn off RateLimit for the systemd journal
+ - fixed MAC address assignment
+ - add systemd checkisomd5 service
+ - splitout drm kernel modules from plymouth module
+ - add 'swapoff' to initramfs to fix shutdown/reboot
+ - add team device support
+ - add pre-shutdown hook
+ - kill all processes in shutdown and report remaining ones
+ - "--device" changed to "--add-device" and "add_device=" added for conf files
+ - add memory usage trace to different hook points
+ - cope with optional field #7 in /proc/self/mountinfo
+ - lots of small bugfixes
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> dracut-024-r4.ebuild:
Add ~arm, wrt bug #449220
diff --git a/sys-kernel/dracut/dracut-025.ebuild b/sys-kernel/dracut/dracut-025.ebuild
new file mode 100644
index 000000000000..65c6b38420af
--- /dev/null
+++ b/sys-kernel/dracut/dracut-025.ebuild
@@ -0,0 +1,290 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-025.ebuild,v 1.1 2013/03/09 20:06:40 aidecoe Exp $
+
+EAPI=4
+
+inherit eutils linux-info
+
+add_req_use_for() {
+ local dep="$1"; shift
+ local f
+
+ for f in "$@"; do
+ REQUIRED_USE+="${f}? ( ${dep} )
+"
+ done
+}
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ dracut_modules_crypt-loop? ( dracut_modules_crypt )
+ dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_bootchart
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_crypt-loop
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ dracut_modules_systemd
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+NETWORK_MODULES="
+ dracut_modules_cifs
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ dracut_modules_ssh-client
+ "
+add_req_use_for device-mapper ${DM_MODULES}
+add_req_use_for net ${NETWORK_MODULES}
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug device-mapper optimization net selinux ${IUSE_DRACUT_MODULES}"
+
+RESTRICT="test"
+
+CDEPEND=">sys-fs/udev-166
+ dracut_modules_systemd? ( sys-apps/systemd )
+ "
+RDEPEND="${CDEPEND}
+ app-arch/cpio
+ >=app-shells/bash-4.0
+ >=app-shells/dash-0.5.4.11
+ >=sys-apps/baselayout-1.12.14-r1
+ || ( >=sys-apps/module-init-tools-3.8 >sys-apps/kmod-5[tools] )
+ >=sys-apps/sysvinit-2.87-r3
+ >=sys-apps/util-linux-2.21
+ virtual/pkgconfig
+
+ debug? ( dev-util/strace )
+ device-mapper? ( || ( sys-fs/device-mapper >=sys-fs/lvm2-2.02.33 ) )
+ net? ( net-misc/curl >=net-misc/dhcp-4.2.4_p2-r1[client] sys-apps/iproute2 )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_bootchart? ( app-benchmarks/bootchart2 sys-apps/usleep
+ sys-process/acct )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_cifs? ( net-fs/cifs-utils )
+ dracut_modules_crypt? ( sys-fs/cryptsetup )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( sys-fs/mdadm )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_ssh-client? ( dev-libs/openssl )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ "
+
+DRACUT_LIBDIR="/usr/lib"
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-dracut-functions.sh-support-for-altern.patch"
+ epatch "${FILESDIR}/${PV}-0002-gentoo.conf-let-udevdir-be-handled-by-.patch"
+ epatch "${FILESDIR}/${PV}-0003-rootfs-block-mount-root.sh-fixup-for-8.patch"
+ epatch "${FILESDIR}/${PV}-0004-dracut.sh-reverting-return-value-chang.patch"
+ epatch "${FILESDIR}/${PV}-0005-Mount-proc-before-including-dracut-lib.patch"
+ chmod +x "${S}/modules.d/95udev-rules/udev-rules-prepare.sh"
+
+ if use dracut_modules_systemd; then
+ local systemdutildir="$($(tc-getPKG_CONFIG) systemd \
+ --variable=systemdutildir)"
+ local systemdsystemunitdir="$($(tc-getPKG_CONFIG) systemd \
+ --variable=systemdsystemunitdir)"
+ [[ ${systemdutildir} ]] || die "Couldn't detect systemdutildir"
+ [[ ${systemdsystemunitdir} ]] \
+ || die "Couldn't detect systemdsystemunitdir"
+ einfo "Setting systemdutildir to ${systemdutildir} and ..."
+ sed -e "4asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir}..."
+ sed -e "5asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ fi
+}
+
+src_configure() {
+ econf --libdir="${DRACUT_LIBDIR}"
+}
+
+src_compile() {
+ emake doc
+
+ if use optimization; then
+ ewarn "Enabling experimental optimization!"
+ tc-export CC
+ emake install/dracut-install
+ fi
+}
+
+src_install() {
+ local libdir="${DRACUT_LIBDIR}"
+
+ emake DESTDIR="${D}" install
+
+ dodir /var/lib/dracut/overlay
+ dodoc HACKING TODO AUTHORS NEWS README*
+
+ insinto /etc/dracut.conf.d
+ newins dracut.conf.d/gentoo.conf.example gentoo.conf
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ dohtml dracut.html
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D%/}/${libdir#/}/dracut/modules.d"
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module -f ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ # Following flags define set of helper modules which are base dependencies
+ # for others and as so have no practical use, so remove these modules.
+ use device-mapper || rm_module 90dm
+ use net || rm_module 40network 45ifcfg 45url-lib
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 80cms 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS ~MODULES"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+ local desc_MODULES="Enable loadable module support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn " CONFIG_MODULES"
+ ewarn ""
+ fi
+
+ if use dracut_modules_crypt || use dracut_modules_dmraid || use \
+ dracut_modules_mdraid || use dracut_modules_lvm; then
+
+ if ! [[ $(</proc/cmdline) =~ rd.auto[\ =] ]]; then
+ ewarn "Autoassembly of special devices like cryptoLUKS, dmraid, "
+ ewarn "mdraid or lvm is off for default as of >=dracut-024."
+ ewarn "Use rd.auto option to turn it on."
+ fi
+ fi
+}
diff --git a/sys-kernel/dracut/files/025-0001-dracut-functions.sh-support-for-altern.patch b/sys-kernel/dracut/files/025-0001-dracut-functions.sh-support-for-altern.patch
new file mode 100644
index 000000000000..e23318cb0990
--- /dev/null
+++ b/sys-kernel/dracut/files/025-0001-dracut-functions.sh-support-for-altern.patch
@@ -0,0 +1,37 @@
+From fcb28882b1eaaa20ad9d831857ecf176dd0e3006 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Sun, 6 Jan 2013 13:35:01 +0100
+Subject: [PATCH 1/5] dracut-functions.sh: support for alternative udev dirs -
+ udevaltdirs
+
+It is required for Gentoo which moves udev from / to /usr and supports
+both /lib/udev and /usr/lib/udev for compatibility with other packages.
+
+Credits go to Alexander Tsoy <alexander@tsoy.me>.
+---
+ dracut-functions.sh | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/dracut-functions.sh b/dracut-functions.sh
+index e23db76..812ea2b 100755
+--- a/dracut-functions.sh
++++ b/dracut-functions.sh
+@@ -941,6 +941,15 @@ inst_rules() {
+ inst_dir "$_target"
+ for _rule in "$@"; do
+ if [ "${_rule#/}" = "$_rule" ]; then
++ for r in ${udevaltdirs}; do
++ [[ "$r" = "${udevdir}" ]] && continue
++ if [[ -f $r/rules.d/$_rule ]]; then
++ _found="$r/rules.d/$_rule"
++ inst_rule_programs "$_found"
++ inst_rule_group_owner "$_found"
++ inst_simple "$_found" "${udevdir}/rules.d/${_found##*/}"
++ fi
++ done
+ for r in ${udevdir}/rules.d /etc/udev/rules.d; do
+ if [[ -f $r/$_rule ]]; then
+ _found="$r/$_rule"
+--
+1.8.1.4
+
diff --git a/sys-kernel/dracut/files/025-0002-gentoo.conf-let-udevdir-be-handled-by-.patch b/sys-kernel/dracut/files/025-0002-gentoo.conf-let-udevdir-be-handled-by-.patch
new file mode 100644
index 000000000000..3a1c8d1adb39
--- /dev/null
+++ b/sys-kernel/dracut/files/025-0002-gentoo.conf-let-udevdir-be-handled-by-.patch
@@ -0,0 +1,30 @@
+From 1f8ab99eca988b15e9573155dd6207cc82842aff Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Sun, 16 Dec 2012 20:02:48 +0100
+Subject: [PATCH 2/5] gentoo.conf: let udevdir= be handled by pkg-config and
+ use udevaltdirs
+
+To avoid need of rebuild after udev update/downgrade let udevdir= be set
+dynamically with pkg-config. Use udevaltdirs to search for rules both
+in old and new locations.
+---
+ dracut.conf.d/gentoo.conf.example | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/dracut.conf.d/gentoo.conf.example b/dracut.conf.d/gentoo.conf.example
+index 1361a30..b78e5c6 100644
+--- a/dracut.conf.d/gentoo.conf.example
++++ b/dracut.conf.d/gentoo.conf.example
+@@ -1,7 +1,8 @@
+ # /etc/dracut.conf.d/gentoo.conf
+ # dracut config file customized for Gentoo Base System release 2
+
+-udevdir=/lib/udev
++udevdir=
++udevaltdirs="/lib/udev /usr/lib/udev"
+ ro_mnt=yes
+
+ #
+--
+1.8.1.4
+
diff --git a/sys-kernel/dracut/files/025-0003-rootfs-block-mount-root.sh-fixup-for-8.patch b/sys-kernel/dracut/files/025-0003-rootfs-block-mount-root.sh-fixup-for-8.patch
new file mode 100644
index 000000000000..ed265b09d6f8
--- /dev/null
+++ b/sys-kernel/dracut/files/025-0003-rootfs-block-mount-root.sh-fixup-for-8.patch
@@ -0,0 +1,29 @@
+From 6cf23a82629409c25d5d36ca71a02171075705ab Mon Sep 17 00:00:00 2001
+From: Harald Hoyer <harald@redhat.com>
+Date: Wed, 23 Jan 2013 16:23:07 +0100
+Subject: [PATCH 3/5] rootfs-block/mount-root.sh: fixup for 8b6bf0ef5
+
+not only fix the warning message, but the real mount arguments, too
+---
+ modules.d/95rootfs-block/mount-root.sh | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/modules.d/95rootfs-block/mount-root.sh b/modules.d/95rootfs-block/mount-root.sh
+index 54d5012..c7626c3 100755
+--- a/modules.d/95rootfs-block/mount-root.sh
++++ b/modules.d/95rootfs-block/mount-root.sh
+@@ -26,9 +26,10 @@ mount_root() {
+ fi
+
+ _rflags_ro="$rflags,ro"
++ _rflags_ro="${_rflags_ro##,}"
+
+ while ! mount -t ${rootfs} -o "$_rflags_ro" "${root#block:}" "$NEWROOT"; do
+- warn "Failed to mount -t ${rootfs} -o ${_rflags_ro##,} ${root#block:} $NEWROOT"
++ warn "Failed to mount -t ${rootfs} -o $_rflags_ro ${root#block:} $NEWROOT"
+ fsck_ask_err
+ done
+
+--
+1.8.1.4
+
diff --git a/sys-kernel/dracut/files/025-0004-dracut.sh-reverting-return-value-chang.patch b/sys-kernel/dracut/files/025-0004-dracut.sh-reverting-return-value-chang.patch
new file mode 100644
index 000000000000..9816ef811d14
--- /dev/null
+++ b/sys-kernel/dracut/files/025-0004-dracut.sh-reverting-return-value-chang.patch
@@ -0,0 +1,41 @@
+From 826b11e8adea942a7fb63fa54374d5571aab0930 Mon Sep 17 00:00:00 2001
+From: Harald Hoyer <harald@redhat.com>
+Date: Tue, 5 Feb 2013 16:45:42 +0100
+Subject: [PATCH 4/5] dracut.sh: reverting return value change
+
+reverting _get_fs_type() return values of patch
+c8d685c9d3860e49f39a9c85ffebbb4c4fec341f
+---
+ dracut.sh | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/dracut.sh b/dracut.sh
+index cfd10a1..23ffaa4 100755
+--- a/dracut.sh
++++ b/dracut.sh
+@@ -766,18 +766,18 @@ if [[ $hostonly ]]; then
+ fi
+
+ _get_fs_type() (
+- [[ $1 ]] || return 1
++ [[ $1 ]] || return
+ if [[ -b $1 ]] && get_fs_env $1; then
+ echo "$(readlink -f $1)|$ID_FS_TYPE"
+- return 0
++ return 1
+ fi
+ if [[ -b /dev/block/$1 ]] && get_fs_env /dev/block/$1; then
+ echo "$(readlink -f /dev/block/$1)|$ID_FS_TYPE"
+- return 0
++ return 1
+ fi
+ if fstype=$(find_dev_fstype $1); then
+ echo "$1|$fstype"
+- return 0
++ return 1
+ fi
+ return 1
+ )
+--
+1.8.1.4
+
diff --git a/sys-kernel/dracut/files/025-0005-Mount-proc-before-including-dracut-lib.patch b/sys-kernel/dracut/files/025-0005-Mount-proc-before-including-dracut-lib.patch
new file mode 100644
index 000000000000..6457b6cc1ecc
--- /dev/null
+++ b/sys-kernel/dracut/files/025-0005-Mount-proc-before-including-dracut-lib.patch
@@ -0,0 +1,44 @@
+From 8ad40b5d5f3f036f38eb328cb35e8d0f8a1b3df2 Mon Sep 17 00:00:00 2001
+From: Colin Guthrie <colin@mageia.org>
+Date: Sat, 26 Jan 2013 18:13:28 +0000
+Subject: [PATCH 5/5] Mount /proc before including dracut-lib.sh.
+
+When dracut-lib.sh is sourced it checks the command line (when not using systemd)
+as part of the check_quiet() call.
+
+Therefore mount /proc earlier in init.
+
+Avoids the error:
+
+init: 77: /lib/dracut-lib.sh: /proc/cmdline: No such file or directory
+---
+ modules.d/99base/init.sh | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/modules.d/99base/init.sh b/modules.d/99base/init.sh
+index 0259053..37b5996 100755
+--- a/modules.d/99base/init.sh
++++ b/modules.d/99base/init.sh
+@@ -17,9 +17,6 @@ OLDPATH=$PATH
+ PATH=/usr/sbin:/usr/bin:/sbin:/bin
+ export PATH
+
+-RD_DEBUG=""
+-. /lib/dracut-lib.sh
+-
+ # mount some important things
+ [ ! -d /proc/self ] && \
+ mount -t proc -o nosuid,noexec,nodev proc /proc >/dev/null
+@@ -37,6 +34,9 @@ if [ "$?" != "0" ]; then
+ exit 1
+ fi
+
++RD_DEBUG=""
++. /lib/dracut-lib.sh
++
+ if [ -x /lib/systemd/systemd-timestamp ]; then
+ RD_TIMESTAMP=$(/lib/systemd/systemd-timestamp)
+ else
+--
+1.8.1.4
+