summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-11-30 19:09:09 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-11-30 19:09:09 +0000
commit699629c788661ed13a955346f67cda3844fde11c (patch)
tree2aae58831d078d4f4a0a966877c6fb18bf51cefd /sys-kernel/ck-sources
parent[bump] dev-perl/PAR-1.3.0 (diff)
downloadgentoo-2-699629c788661ed13a955346f67cda3844fde11c.tar.gz
gentoo-2-699629c788661ed13a955346f67cda3844fde11c.tar.bz2
gentoo-2-699629c788661ed13a955346f67cda3844fde11c.zip
Version bump.
(Portage version: 2.1.10.38/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog7
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.1.4.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 41dc3ed90365..31bde46ded9a 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.199 2011/09/01 18:52:45 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.200 2011/11/30 19:09:09 nelchael Exp $
+
+*ck-sources-3.1.4 (30 Nov 2011)
+
+ 30 Nov 2011; Krzysztof Pawlik <nelchael@gentoo.org> +ck-sources-3.1.4.ebuild:
+ Version bump.
*ck-sources-3.0.4 (01 Sep 2011)
diff --git a/sys-kernel/ck-sources/ck-sources-3.1.4.ebuild b/sys-kernel/ck-sources/ck-sources-3.1.4.ebuild
new file mode 100644
index 000000000000..f0918c087b95
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.1.4.ebuild,v 1.1 2011/11/30 19:09:09 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="7"
+K_SECURITY_UNSUPPORTED="1"
+
+inherit kernel-2 versionator
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+BASE_VERSION="$(get_version_component_range 1-2)"
+CK_VERSION="2"
+
+CK_URI="http://ck.kolivas.org/patches/3.0/${BASE_VERSION}/${BASE_VERSION}.0-ck${CK_VERSION}/patch-${BASE_VERSION}.0-ck${CK_VERSION}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${BASE_VERSION}.0-ck${CK_VERSION}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}