summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-10-12 13:19:36 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-10-12 13:19:36 +0000
commit5122c51ed2be0ccf1a2eddd59d8ee8c099ccf6b5 (patch)
treed90b3e692aaa9b751ca7a4a63a633e7af26c1411 /sys-infiniband/opensm
parentFix QA issues: add missing die statements, escape variables (diff)
downloadgentoo-2-5122c51ed2be0ccf1a2eddd59d8ee8c099ccf6b5.tar.gz
gentoo-2-5122c51ed2be0ccf1a2eddd59d8ee8c099ccf6b5.tar.bz2
gentoo-2-5122c51ed2be0ccf1a2eddd59d8ee8c099ccf6b5.zip
[sys-infiniband] OFED 3.5 rc2 update
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'sys-infiniband/opensm')
-rw-r--r--sys-infiniband/opensm/ChangeLog8
-rw-r--r--sys-infiniband/opensm/opensm-3.3.15.ebuild44
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-infiniband/opensm/ChangeLog b/sys-infiniband/opensm/ChangeLog
index ad7b0bdeea63..be56e40a02fe 100644
--- a/sys-infiniband/opensm/ChangeLog
+++ b/sys-infiniband/opensm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-infiniband/opensm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-infiniband/opensm/ChangeLog,v 1.3 2012/04/18 16:45:30 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-infiniband/opensm/ChangeLog,v 1.4 2012/10/12 13:19:36 alexxy Exp $
+
+*opensm-3.3.15 (12 Oct 2012)
+
+ 12 Oct 2012; Alexey Shvetsov <alexxy@gentoo.org> +opensm-3.3.15.ebuild:
+ [sys-infiniband] OFED 3.5 rc2 update
*opensm-3.3.13 (18 Apr 2012)
@@ -16,4 +21,3 @@
30 Jun 2011; Alexey Shvetsov <alexxy@gentoo.org> +opensm-3.3.9.ebuild,
+files/opensm.init.d, +metadata.xml:
Initial import to tree
-
diff --git a/sys-infiniband/opensm/opensm-3.3.15.ebuild b/sys-infiniband/opensm/opensm-3.3.15.ebuild
new file mode 100644
index 000000000000..183275ff5880
--- /dev/null
+++ b/sys-infiniband/opensm/opensm-3.3.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-infiniband/opensm/opensm-3.3.15.ebuild,v 1.1 2012/10/12 13:19:36 alexxy Exp $
+
+EAPI="4"
+
+OFED_VER="3.5-rc2"
+OFED_SUFFIX="1"
+
+inherit openib
+
+DESCRIPTION="OpenSM - InfiniBand Subnet Manager and Administration for OpenIB"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ sys-infiniband/libibmad:${SLOT}
+ sys-infiniband/libibumad:${SLOT}"
+RDEPEND="$DEPEND
+ net-misc/iputils"
+block_other_ofed_versions
+
+src_configure() {
+ econf \
+ --enable-perf-mgr \
+ --enable-default-event-plugin \
+ --with-osmv="openib"
+}
+
+src_install() {
+ default
+ newconfd "${S}/scripts/opensm.sysconfig" opensm
+ newinitd "${FILESDIR}/opensm.init.d" opensm
+ insinto /etc/logrotate.d
+ newins "${S}/scripts/opensm.logrotate" opensm
+ # we dont nee this int script
+ rm "${ED}/etc/init.d/opensmd" || die "Dropping of upstream initscript failed"
+}
+
+pkg_postinst() {
+ einfo "To automatically configure the infiniband subnet manager on boot,"
+ einfo "edit /etc/opensm.conf and add opensm to your start-up scripts:"
+ einfo "\`rc-update add opensm default\`"
+}