summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-02-05 08:07:41 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-02-05 08:07:41 +0000
commitfb4f9395c067e10248d0731697a8f9543df102f8 (patch)
tree0f2932bfc114ecda246abd21596b528ab4aaf5cc /sys-fs
parentstable x86; bug #165352 (diff)
downloadgentoo-2-fb4f9395c067e10248d0731697a8f9543df102f8.tar.gz
gentoo-2-fb4f9395c067e10248d0731697a8f9543df102f8.tar.bz2
gentoo-2-fb4f9395c067e10248d0731697a8f9543df102f8.zip
Add 2.6.20 patch, bug 159573
(Portage version: 2.1.2-r7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/files/fuse-2.6.20.patch35
-rw-r--r--sys-fs/fuse/fuse-2.6.1.ebuild9
3 files changed, 47 insertions, 3 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 010e2caa8d78..8c72706aa510 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.71 2007/01/24 07:31:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.72 2007/02/05 08:07:41 genstef Exp $
+
+ 05 Feb 2007; <genstef@gentoo.org> +files/fuse-2.6.20.patch,
+ fuse-2.6.1.ebuild:
+ Add 2.6.20 patch, bug 159573
24 Jan 2007; <genstef@gentoo.org> +files/fuse.init, fuse-2.6.1.ebuild:
Gentooify init script thanks to David B. Ferguson <david@microtask.ca>
diff --git a/sys-fs/fuse/files/fuse-2.6.20.patch b/sys-fs/fuse/files/fuse-2.6.20.patch
new file mode 100644
index 000000000000..66b7df4dba9c
--- /dev/null
+++ b/sys-fs/fuse/files/fuse-2.6.20.patch
@@ -0,0 +1,35 @@
+diff -Naud fuse-2.6.1/work/fuse-2.6.1/kernel/dev.c fuse-2.6.1-fixed/work/fuse-2.6.1/kernel/dev.c
+--- fuse-2.6.1/work/fuse-2.6.1/kernel/dev.c 2006-11-19 17:02:34.000000000 +0100
++++ fuse-2.6.1-fixed/work/fuse-2.6.1/kernel/dev.c 2006-12-30 18:52:07.000000000 +0100
+@@ -43,7 +43,7 @@
+
+ struct fuse_req *fuse_request_alloc(void)
+ {
+- struct fuse_req *req = kmem_cache_alloc(fuse_req_cachep, SLAB_KERNEL);
++ struct fuse_req *req = kmem_cache_alloc(fuse_req_cachep, GFP_KERNEL);
+ if (req)
+ fuse_request_init(req);
+ return req;
+diff -Naud fuse-2.6.1/work/fuse-2.6.1/kernel/file.c fuse-2.6.1-fixed/work/fuse-2.6.1/kernel/file.c
+--- fuse-2.6.1/work/fuse-2.6.1/kernel/file.c 2006-10-20 19:33:56.000000000 +0200
++++ fuse-2.6.1-fixed/work/fuse-2.6.1/kernel/file.c 2006-12-30 19:00:13.000000000 +0100
+@@ -501,7 +501,6 @@
+ spin_unlock(&fc->lock);
+
+ if (offset == 0 && to == PAGE_CACHE_SIZE) {
+- clear_page_dirty(page);
+ SetPageUptodate(page);
+ }
+ }
+diff -Naud fuse-2.6.1/work/fuse-2.6.1/kernel/inode.c fuse-2.6.1-fixed/work/fuse-2.6.1/kernel/inode.c
+--- fuse-2.6.1/work/fuse-2.6.1/kernel/inode.c 2006-11-28 15:04:45.000000000 +0100
++++ fuse-2.6.1-fixed/work/fuse-2.6.1/kernel/inode.c 2006-12-30 18:52:26.000000000 +0100
+@@ -52,7 +52,7 @@
+ struct inode *inode;
+ struct fuse_inode *fi;
+
+- inode = kmem_cache_alloc(fuse_inode_cachep, SLAB_KERNEL);
++ inode = kmem_cache_alloc(fuse_inode_cachep, GFP_KERNEL);
+ if (!inode)
+ return NULL;
+
diff --git a/sys-fs/fuse/fuse-2.6.1.ebuild b/sys-fs/fuse/fuse-2.6.1.ebuild
index 2dbd237c6fb6..01ea0cc8dae1 100644
--- a/sys-fs/fuse/fuse-2.6.1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.1.ebuild,v 1.4 2007/01/24 07:31:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.1.ebuild,v 1.5 2007/02/05 08:07:41 genstef Exp $
inherit linux-mod eutils libtool
@@ -24,13 +24,18 @@ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
We will continue, but we wont build the module this time."
pkg_setup() {
- use kernel_linux && linux-mod_pkg_setup
+ if use kernel_linux ; then
+ linux-mod_pkg_setup
+ kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
+ older version from viewcvs"
+ fi
}
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
+ epatch "${FILESDIR}"/fuse-2.6.20.patch
elibtoolize
}