summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-11-04 02:19:51 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-11-04 02:19:51 +0000
commitfa4527ad89a6c89a986a9f3f1faf8ae738162978 (patch)
treefc03a32227328d408843846638303de1fcbbe0be /sys-fs
parentVersion bump. Add support for firewalld as well. (diff)
downloadgentoo-2-fa4527ad89a6c89a986a9f3f1faf8ae738162978.tar.gz
gentoo-2-fa4527ad89a6c89a986a9f3f1faf8ae738162978.tar.bz2
gentoo-2-fa4527ad89a6c89a986a9f3f1faf8ae738162978.zip
remove old; bump rc16 to EAPI=5, add epatch_user and make elog messages contextual to reduce elog spam
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dmraid/ChangeLog7
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild87
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild59
3 files changed, 38 insertions, 115 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
index 69d4bc1ec369..1b2df92756e6 100644
--- a/sys-fs/dmraid/ChangeLog
+++ b/sys-fs/dmraid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dmraid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.27 2012/05/24 02:51:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.28 2012/11/04 02:19:51 axs Exp $
+
+ 04 Nov 2012; Ian Stakenvicius <axs@gentoo.org> -dmraid-1.0.0_rc16-r2.ebuild,
+ dmraid-1.0.0_rc16-r3.ebuild:
+ remove old; bump rc16 to EAPI=5, add epatch_user and make elog messages
+ contextual to reduce elog spam
24 May 2012; Mike Frysinger <vapier@gentoo.org> dmraid-1.0.0_rc14.ebuild,
dmraid-1.0.0_rc15.ebuild, dmraid-1.0.0_rc16-r2.ebuild,
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild
deleted file mode 100644
index a9211c2e741d..000000000000
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild,v 1.3 2012/05/24 02:51:41 vapier Exp $
-
-EAPI="2"
-
-inherit linux-info flag-o-matic eutils
-
-MY_PV=${PV/_/.}
-
-DESCRIPTION="Device-mapper RAID tool and library"
-HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
-SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static selinux"
-
-RDEPEND="|| ( >=sys-fs/lvm2-2.02.45
- sys-fs/device-mapper )
- selinux? ( sys-libs/libselinux
- sys-libs/libsepol )"
-DEPEND="${RDEPEND}
- static? ( virtual/pkgconfig )"
-
-S=${WORKDIR}/${PN}/${MY_PV}
-
-pkg_setup() {
- if kernel_is lt 2 6 ; then
- ewarn "You are using a kernel < 2.6"
- ewarn "DMraid uses recently introduced Device-Mapper features."
- ewarn "These might be unavailable in the kernel you are running now."
- fi
- if use static && use selinux ; then
- eerror "ERROR - cannot compile static with libselinux / libsepol"
- die "USE flag conflicts."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-undo-p-rename.patch \
- "${FILESDIR}"/${P}-return-all-sets.patch \
- "${FILESDIR}"/${PN}-destdir-fix.patch \
- "${FILESDIR}"/${P}-as-needed2.patch
-
- if use static; then
- local myflags
- myflags=`/usr/bin/pkg-config --libs --static devmapper`
- sed -i -e "s#^LIBS += -ldl#LIBS += -ldl $myflags#" \
- tools/Makefile.in || die "sed failed"
- fi
-
- # archive the patched source for use with genkernel
- cd "${WORKDIR}"
- tar -jcf ${PN}-${MY_PV}-prepatched.tar.bz2 ${PN} || die
-}
-
-src_configure() {
- econf \
- $(use_enable static static_link) \
- $(use_enable selinux libselinux) \
- $(use_enable selinux libsepol)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGELOG README TODO KNOWN_BUGS doc/* || die "dodoc failed"
- insinto /usr/share/${PN}
- doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2 || die
-}
-
-pkg_postinst() {
- elog "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
- elog " "
- elog "Genkernel will generate the kernel and the initrd with a statically "
- elog "linked dmraid binary (its own version which may not be the same as this version):"
- elog "\t emerge -av sys-kernel/genkernel"
- elog "\t genkernel --dmraid all"
- elog " "
- elog "If you would rather use this version of DMRAID with Genkernel, update the following"
- elog "in /etc/genkernel.conf:"
- elog "\t DMRAID_VER=\"${MY_PV}\""
- elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
- elog " "
- ewarn "DMRAID should be safe to use, but no warranties can be given"
-}
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild
index 4c499a2d6a78..9eec5c4be653 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild,v 1.3 2012/05/24 02:51:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild,v 1.4 2012/11/04 02:19:51 axs Exp $
-EAPI="2"
+EAPI=5
inherit autotools linux-info flag-o-matic eutils
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="dietlibc intel_led klibc led mini static"
+REQUIRED_USE="klibc? ( !dietlibc )"
RDEPEND="|| ( >=sys-fs/lvm2-2.02.45
sys-fs/device-mapper )
@@ -39,56 +40,60 @@ src_prepare() {
"${FILESDIR}"/${P}-return-all-sets.patch \
"${FILESDIR}"/${P}-static-build-fixes.patch
# pkg_check_modules is not in aclocal.m4 by default, and eautoreconf doesnt add it
- elog "Appending pkg.m4 from system to aclocal.m4"
+ einfo "Appending pkg.m4 from system to aclocal.m4"
cat "${ROOT}"/usr/share/aclocal/pkg.m4 >>"${S}"/aclocal.m4 || die "Could not append pkg.m4"
+ epatch_user
eautoreconf
- elog "Creating prepatched source archive for use with Genkernel"
+ einfo "Creating prepatched source archive for use with Genkernel"
# archive the patched source for use with genkernel
- cd "${WORKDIR}"
- mkdir -p "tmp/${PN}"
- cp -a "${PN}/${MY_PV}/${PN}" "tmp/${PN}"
- mv "tmp/${PN}/${PN}" "tmp/${PN}/${MY_PV}"
- cd tmp
+ cd "${WORKDIR}" || die
+ mkdir -p "tmp/${PN}" || die
+ cp -a "${PN}/${MY_PV}/${PN}" "tmp/${PN}" || die
+ mv "tmp/${PN}/${PN}" "tmp/${PN}/${MY_PV}" || die
+ cd tmp || die
tar -jcf ${PN}-${MY_PV}-prepatched.tar.bz2 ${PN} || die
- mv ${PN}-${MY_PV}-prepatched.tar.bz2 ..
+ mv ${PN}-${MY_PV}-prepatched.tar.bz2 .. || die
}
src_configure() {
- local mylibc
- if use klibc && use dietlibc; then
- ewarn "Cannot compile against both klibc and dietlibc -- choosing klibc."
- mylibc="--enable-klibc --disable-dietlibc"
- else
- mylibc="$(use_enable klibc) $(use_enable dietlibc)"
- fi
econf --with-usrlibdir='${prefix}'/$(get_libdir) \
$(use_enable static static_link) \
$(use_enable mini) \
$(use_enable led) \
$(use_enable intel_led) \
- ${mylibc}
+ $(use_enable klibc) \
+ $(use_enable dietlibc)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGELOG README TODO KNOWN_BUGS doc/* || die "dodoc failed"
+ emake DESTDIR="${D}" install
+ dodoc CHANGELOG README TODO KNOWN_BUGS doc/*
insinto /usr/share/${PN}
- doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2 || die
+ doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2
}
pkg_postinst() {
- elog "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
- elog " "
- elog "Genkernel will generate the kernel and the initrd with a statically "
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "For booting Gentoo from Device-Mapper RAID you can use a Genkernel initramfs."
+ elog
+ elog "Genkernel will generate the kernel and the initramfs with a statically "
elog "linked dmraid binary (its own version which may not be the same as this version):"
elog "\t emerge -av sys-kernel/genkernel"
elog "\t genkernel --dmraid all"
- elog " "
+ fi
+ if [[ ${REPLACING_VERSIONS} != ${PVR} ]]; then
+ elog
+ elog "A pre-patched distfile of this version of DMRAID has been installed at"
+ elog "/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2 , to support using it within a"
+ elog "Genkernel initramfs."
+ elog
+ fi
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "If you would rather use this version of DMRAID with Genkernel, update the following"
elog "in /etc/genkernel.conf:"
elog "\t DMRAID_VER=\"${MY_PV}\""
elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
- elog " "
- ewarn "DMRAID should be safe to use, but no warranties can be given"
+ elog
+ fi
}