summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2005-06-01 23:39:59 +0000
committerBenjamin Smee <strerror@gentoo.org>2005-06-01 23:39:59 +0000
commitec7ebb7f11f9730042c60bbb64853f63b7d7bb35 (patch)
tree82079c74530fd363df100eb29576c655abe41515 /sys-fs
parentInitial import. Based on ebuild by Fruhwirth Clemens (diff)
downloadgentoo-2-ec7ebb7f11f9730042c60bbb64853f63b7d7bb35.tar.gz
gentoo-2-ec7ebb7f11f9730042c60bbb64853f63b7d7bb35.tar.bz2
gentoo-2-ec7ebb7f11f9730042c60bbb64853f63b7d7bb35.zip
Changed to include cryptfs
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog6
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild1
-rw-r--r--sys-fs/cryptsetup-luks/files/cryptfs.confd35
3 files changed, 41 insertions, 1 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index 23e1ace8954d..3f257e4c6c5c 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.1 2005/06/01 23:10:17 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.2 2005/06/01 23:39:59 strerror Exp $
+
+ 02 Jun 2005; Benjamin Smee <strerror@gentoo.org> +files/cryptfs.confd,
+ cryptsetup-luks-1.0.ebuild:
+ Changed to include cryptfs
*cryptsetup-luks-1.0 (02 Jun 2005)
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild
index 14bfb125f5a6..1f7a8531a3fc 100644
--- a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild
@@ -69,5 +69,6 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "install failed"
insinto /lib/rcscripts/addons
+ newconfd ${FILESDIR}/cryptfs.confd cryptfs
doins "${FILESDIR}"/dm-crypt-{start,stop}.sh
}
diff --git a/sys-fs/cryptsetup-luks/files/cryptfs.confd b/sys-fs/cryptsetup-luks/files/cryptfs.confd
new file mode 100644
index 000000000000..ca2399ce40f7
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/files/cryptfs.confd
@@ -0,0 +1,35 @@
+# /etc/conf.d/cryptfs
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/files/cryptfs.confd,v 1.1 2005/06/01 23:39:59 strerror Exp $
+
+# Note regarding the syntax of this file. This file is *almost* bash,
+# but each line is evaluated separately. Separate swaps/mounts can be
+# specified. The init-script which reads this file assumes that a
+# swap= or mount= line starts a new section, similar to lilo or grub
+# configuration.
+
+# Note when using gpg keys and /usr on a separate partition, you will
+# have to copy /usr/bin/gpg to /bin/gpg so that it will work properly.
+# See http://bugs.gentoo.org/90482 for more information.
+
+# Swap partitions. These should come first so that no keys make their
+# way into unencrypted swap.
+# If no options are given, they will default to: -c aes -h sha1 -d /dev/urandom
+# If no makefs is given then mkswap will be assumed
+#swap=crypt-swap
+#source='/dev/main/swap'
+
+# Mounts
+# If no options are given, they will default to: -c aes -h sha1
+# No mkfs is run unless you specify a makefs option
+#mount=crypt-tmp
+#source='/dev/main/tmp'
+#options='-d /dev/urandom'
+#pre_mount='/sbin/mkreiserfs -f -f ${dev}'
+#post_mount='chown root:root ${mount_point}; chmod 1777 ${mount_point}'
+
+# Loopback file example
+
+#mount='home-crypt'
+#source='/dev/loop0'
+#options='-c serpent -s 256'
+#loop_file='/mnt/crypt/home'