summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-06 02:54:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-06 02:54:21 +0000
commite017e56df8569bba16ba0cba9c6764aaa6d33ee7 (patch)
tree0df75afb3916a7111c58d4aec1abf5e179305ac8 /sys-fs
parentEnchanced 50po-mode-gentoo.el to support the detection of coding system via P... (diff)
downloadgentoo-2-e017e56df8569bba16ba0cba9c6764aaa6d33ee7.tar.gz
gentoo-2-e017e56df8569bba16ba0cba9c6764aaa6d33ee7.tar.bz2
gentoo-2-e017e56df8569bba16ba0cba9c6764aaa6d33ee7.zip
Fix fuse detection when gnome support is disabled #124919 by Konstantin Sobolev. Also add support for USE=crypt.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfsprogs/ChangeLog7
-rw-r--r--sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch119
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild16
3 files changed, 138 insertions, 4 deletions
diff --git a/sys-fs/ntfsprogs/ChangeLog b/sys-fs/ntfsprogs/ChangeLog
index 5966dee9304c..0d216c587829 100644
--- a/sys-fs/ntfsprogs/ChangeLog
+++ b/sys-fs/ntfsprogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfsprogs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.29 2006/03/03 01:55:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.30 2006/03/06 02:54:21 vapier Exp $
+
+ 06 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/ntfsprogs-1.13.0-pkg-config.patch, ntfsprogs-1.13.0.ebuild:
+ Fix fuse detection when gnome support is disabled #124919 by Konstantin
+ Sobolev. Also add support for USE=crypt.
*ntfsprogs-1.13.0 (03 Mar 2006)
diff --git a/sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch b/sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch
new file mode 100644
index 000000000000..6a3ca40a3bd4
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch
@@ -0,0 +1,119 @@
+configure fails when using --disable-gnome-vfs --enable-fuse-module because
+the configure.ac script doesn't explicitly call PKG_PROG_PKG_CONFIG.
+
+http://bugs.gentoo.org/124919
+
+--- configure
++++ configure
+@@ -2184,6 +2184,111 @@
+ fi;
+
+
++
++if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
++ if test -n "$ac_tool_prefix"; then
++ # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
++set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
++echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
++if test "${ac_cv_path_PKG_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $PKG_CONFIG in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++
++ ;;
++esac
++fi
++PKG_CONFIG=$ac_cv_path_PKG_CONFIG
++
++if test -n "$PKG_CONFIG"; then
++ echo "$as_me:$LINENO: result: $PKG_CONFIG" >&5
++echo "${ECHO_T}$PKG_CONFIG" >&6
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++
++fi
++if test -z "$ac_cv_path_PKG_CONFIG"; then
++ ac_pt_PKG_CONFIG=$PKG_CONFIG
++ # Extract the first word of "pkg-config", so it can be a program name with args.
++set dummy pkg-config; ac_word=$2
++echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
++if test "${ac_cv_path_ac_pt_PKG_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $ac_pt_PKG_CONFIG in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++
++ ;;
++esac
++fi
++ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
++
++if test -n "$ac_pt_PKG_CONFIG"; then
++ echo "$as_me:$LINENO: result: $ac_pt_PKG_CONFIG" >&5
++echo "${ECHO_T}$ac_pt_PKG_CONFIG" >&6
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++
++ PKG_CONFIG=$ac_pt_PKG_CONFIG
++else
++ PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
++fi
++
++fi
++if test -n "$PKG_CONFIG"; then
++ _pkg_min_version=0.9.0
++ echo "$as_me:$LINENO: checking pkg-config is at least version $_pkg_min_version" >&5
++echo $ECHO_N "checking pkg-config is at least version $_pkg_min_version... $ECHO_C" >&6
++ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ PKG_CONFIG=""
++ fi
++
++fi
++
+ # This is required to get past a stupid configure bug when making the rpm.
+ # Basically it is broken to specify the host as a command line argument to
+ # configure on its own, i.e. without giving --host=. It is supposed to work
diff --git a/sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild b/sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild
index 6351d6f9643d..1c471cde53e3 100644
--- a/sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild
+++ b/sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild,v 1.2 2006/03/05 03:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.13.0.ebuild,v 1.3 2006/03/06 02:54:21 vapier Exp $
+
+inherit eutils
DESCRIPTION="User tools for NTFS filesystems"
HOMEPAGE="http://www.linux-ntfs.org/"
@@ -9,9 +11,10 @@ SRC_URI="mirror://sourceforge/linux-ntfs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="gnome fuse debug"
+IUSE="crypt debug fuse gnome"
RDEPEND="fuse? ( >=sys-fs/fuse-2.3.0 )
+ crypt? ( >=dev-libs/libgcrypt-1.2.0 >=net-libs/gnutls-1.2.8 )
gnome? (
>=dev-libs/glib-2.0
>=gnome-base/gnome-vfs-2.0
@@ -19,12 +22,19 @@ RDEPEND="fuse? ( >=sys-fs/fuse-2.3.0 )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-pkg-config.patch
+}
+
src_compile() {
sed -i -e 's:-ggdb3::' configure
econf \
- $(use_enable gnome gnome-vfs) \
+ $(use_enable crypt) \
$(use_enable debug) \
$(use_enable fuse fuse-module) \
+ $(use_enable gnome gnome-vfs) \
|| die "Configure failed"
emake || die "Make failed"
}