summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-01 13:13:08 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-01 13:13:08 +0000
commit7edcc5e69d6d382f9385b84eaa0d987474d76625 (patch)
tree2a581ade740c51175ec52736cdfb1ead1f22bc49 /sys-fs
parentold (diff)
downloadgentoo-2-7edcc5e69d6d382f9385b84eaa0d987474d76625.tar.gz
gentoo-2-7edcc5e69d6d382f9385b84eaa0d987474d76625.tar.bz2
gentoo-2-7edcc5e69d6d382f9385b84eaa0d987474d76625.zip
Version bump.
(Portage version: 2.1.4_rc12)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog11
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.40.4.ebuild127
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.43
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.40-fbsd.patch10
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.40.4-prototypes.patch27
5 files changed, 166 insertions, 12 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 8b97647bad62..f5d4e779a2b0 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/e2fsprogs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.126 2007/12/24 12:49:52 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.127 2008/01/01 13:13:07 vapier Exp $
+
+*e2fsprogs-1.40.4 (01 Jan 2008)
+
+ 01 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/e2fsprogs-1.40.4-prototypes.patch, files/e2fsprogs-1.40-fbsd.patch,
+ +e2fsprogs-1.40.4.ebuild:
+ Version bump.
*e2fsprogs-1.40.3-r1 (24 Dec 2007)
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.40.4.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.40.4.ebuild
new file mode 100644
index 000000000000..e258c0b37c2a
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.40.4.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.40.4.ebuild,v 1.1 2008/01/01 13:13:07 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static elibc_FreeBSD"
+
+RDEPEND="~sys-libs/com_err-${PV}
+ ~sys-libs/ss-${PV}
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.40.4-prototypes.patch
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
+ chmod u+w po/*.po # Userpriv fix #27348
+ # Clean up makefile to suck less
+ epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.40-libintl.patch #122368
+ epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
+
+ # kernel headers use the same defines as e2fsprogs and can cause issues #48829
+ sed -i \
+ -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
+ $(grep -rl CONFIG_JBD_DEBUG *) \
+ || die "sed jbd debug failed"
+
+ # fake out files we forked into sep packages
+ sed -i \
+ -e '/^LIB_SUBDIRS/s:lib/et::' \
+ -e '/^LIB_SUBDIRS/s:lib/ss::' \
+ Makefile.in || die "remove subdirs"
+
+ ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
+ ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
+ ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
+ ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
+ ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ # Keep the package from doing silly things
+ export LDCONFIG=:
+ export CC=$(tc-getCC)
+ export STRIP=:
+
+ econf \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --enable-elf-shlibs \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable !static dynamic-e2fsck) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ $(use_enable userland_GNU fsck) \
+ || die
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+ # Parallel make sometimes fails
+ emake -j1 COMPILE_ET=compile_et || die
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake fsck_ext2fs || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README RELEASE-NOTES
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
+ dolib.a lib/*.a || die "dolib.a"
+ rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
+ local x
+ cd "${D}"/$(get_libdir)
+ for x in *.so ; do
+ gen_usr_ldscript ${x} || die "gen ldscript ${x}"
+ done
+
+ # move 'useless' stuff to /usr/
+ dosbin "${D}"/sbin/mklost+found
+ rm -f "${D}"/sbin/mklost+found
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs || die
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # these manpages are already provided by FreeBSD libc
+ # and filefrag is linux only
+ rm -f \
+ "${D}"/sbin/filefrag \
+ "${D}"/usr/share/man/man8/filefrag.8 \
+ "${D}"/bin/uuidgen \
+ "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
+ "${D}"/usr/share/man/man1/uuidgen.1 || die
+ fi
+}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.4 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.4
new file mode 100644
index 000000000000..5ec37d7d3bb7
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.4
@@ -0,0 +1,3 @@
+MD5 124d744bdf9d443591eb8193c085944b e2fsprogs-1.40.4.tar.gz 4048867
+RMD160 053556aab3de6ffffe5ab5981f436d4cdf9d9dae e2fsprogs-1.40.4.tar.gz 4048867
+SHA256 2e1ece31b004ff1f4a26e5633e884eda11457b489bc854edaa0d7f024bc06564 e2fsprogs-1.40.4.tar.gz 4048867
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.40-fbsd.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.40-fbsd.patch
index 616a638ef32c..547befb3ec5a 100644
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.40-fbsd.patch
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.40-fbsd.patch
@@ -1,13 +1,3 @@
---- a/lib/ext2fs/tdb.c.orig Thu Apr 5 02:43:05 2007
-+++ b/lib/ext2fs/tdb.c Sat Jun 30 16:13:15 2007
-@@ -36,7 +36,6 @@
- #define HAVE_UTIME_H
- #define HAVE_UTIME
- #endif
--#define _XOPEN_SOURCE 500
-
- #include <unistd.h>
- #include <stdio.h>
--- a/lib/ext2fs/ext2_fs.h.orig Sat Jun 30 16:36:37 2007
+++ b/lib/ext2fs/ext2_fs.h Sat Jun 30 16:36:43 2007
@@ -414,7 +414,7 @@
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.40.4-prototypes.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.40.4-prototypes.patch
new file mode 100644
index 000000000000..9bb4cd926a81
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.40.4-prototypes.patch
@@ -0,0 +1,27 @@
+needed for strcasecmp() prototype
+http://sourceforge.net/tracker/index.php?func=detail&aid=1861659&group_id=2406&atid=302406
+
+--- debugfs/set_fields.c
++++ debugfs/set_fields.c
+@@ -16,6 +16,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
++#include <strings.h>
+ #include <time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=1861663&group_id=2406&atid=302406
+
+--- misc/uuidd.c
++++ misc/uuidd.c
+@@ -9,6 +9,8 @@
+ * %End-Header%
+ */
+
++#define _GNU_SOURCE /* for setres[ug]id() */
++
+ #include <stdio.h>
+ #ifdef HAVE_STDLIB_H
+ #include <stdlib.h>