summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-01 11:38:10 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-01 11:38:10 +0000
commit5d8306409b353e10d58f334d810607aca0b6ba76 (patch)
tree4abc753a588f70e35bb39dfe7a09d8dc83c2f709 /sys-fs
parentBackport the Python fixes from gnome overlay. (diff)
downloadgentoo-2-5d8306409b353e10d58f334d810607aca0b6ba76.tar.gz
gentoo-2-5d8306409b353e10d58f334d810607aca0b6ba76.tar.bz2
gentoo-2-5d8306409b353e10d58f334d810607aca0b6ba76.zip
Add a new snapshot fixing multiple bugs, including bug #506128 by Tim Mohlmann.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e4rat/ChangeLog10
-rw-r--r--sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/sys-fs/e4rat/ChangeLog b/sys-fs/e4rat/ChangeLog
index c1ef040bbaab..a12803043fb5 100644
--- a/sys-fs/e4rat/ChangeLog
+++ b/sys-fs/e4rat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/e4rat
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.17 2013/08/01 18:04:07 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.18 2014/12/01 11:38:10 pacho Exp $
+
+*e4rat-0.2.4_pre20141201 (01 Dec 2014)
+
+ 01 Dec 2014; Pacho Ramos <pacho@gentoo.org> +e4rat-0.2.4_pre20141201.ebuild:
+ Add a new snapshot fixing multiple bugs, including bug #506128 by Tim
+ Mohlmann.
01 Aug 2013; Pacho Ramos <pacho@gentoo.org> e4rat-0.2.3-r1.ebuild:
Update README.gentoo doc as referenced wiki page no longer exists (#479376 by
diff --git a/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild b/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild
new file mode 100644
index 000000000000..710a20faa865
--- /dev/null
+++ b/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild,v 1.1 2014/12/01 11:38:10 pacho Exp $
+
+EAPI=5
+
+inherit cmake-utils linux-info readme.gentoo
+
+DESCRIPTION="Toolset to accelerate the boot process and application startup"
+HOMEPAGE="http://e4rat.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
+SRC_URI="http://dev.gentoo.org/~pacho/${PN}/${PN}-0.2.4_pre20141201.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl:=
+ >=dev-libs/boost-1.42:=
+ sys-fs/e2fsprogs
+ sys-process/audit
+ sys-process/lsof
+"
+DEPEND="${DEPEND}
+ app-arch/xz-utils
+"
+
+CONFIG_CHECK="~AUDITSYSCALL"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.2-shared-build.patch
+ "${FILESDIR}"/${PN}-0.2.2-libdir.patch
+)
+
+pkg_setup() {
+ check_extra_config
+ DOC_CONTENTS="
+ To launch systemd from e4rat you simply need to edit /etc/e4rat.conf
+ and set:\n
+ ; path to init process binary (DEFAULT: /sbin/init)\n
+ init /usr/lib/systemd/systemd"
+}
+
+src_install() {
+ cmake-utils_src_install
+ # relocate binaries to /sbin. If someone knows of a better way to do it
+ # please do tell me
+ dodir sbin
+ find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
+ || die
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if has_version sys-apps/preload; then
+ elog "It appears you have sys-apps/preload installed. This may"
+ elog "has negative effects on ${PN}. You may want to disable preload"
+ elog "when using ${PN}."
+ fi
+}