summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-07-12 14:24:15 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-07-12 14:24:15 +0000
commit2ee73386e3e468b16b8f43ad8b532c2985fb0bd1 (patch)
tree43a4c01ed3267f66fb671dd67ed988d1da10d770 /sys-fs
parentStable on sparc (diff)
downloadgentoo-2-2ee73386e3e468b16b8f43ad8b532c2985fb0bd1.tar.gz
gentoo-2-2ee73386e3e468b16b8f43ad8b532c2985fb0bd1.tar.bz2
gentoo-2-2ee73386e3e468b16b8f43ad8b532c2985fb0bd1.zip
Corrected typo in file mode for new added usb rule, Bug #185069. Now automatically blacklist the modules in modules.autoload.d from coldplug, to let modules-init script load them and respect the order in which they are listed, relevant for multimedia devices like alsa, v4l and dvb, Bug #184833.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog13
-rw-r--r--sys-fs/udev/files/digest-udev-113-r23
-rwxr-xr-xsys-fs/udev/files/modprobe-113-r2.sh80
-rw-r--r--sys-fs/udev/files/udev-113-r2-rules.diff38
-rw-r--r--sys-fs/udev/files/udev-start-113-r2.sh247
-rw-r--r--sys-fs/udev/files/udev.conf.post_11328
-rw-r--r--sys-fs/udev/udev-113-r2.ebuild308
7 files changed, 716 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index e910e25e71f1..13390437d225 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.314 2007/07/10 21:16:20 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.315 2007/07/12 14:24:15 zzam Exp $
+
+*udev-113-r2 (12 Jul 2007)
+
+ 12 Jul 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/udev-113-r2-rules.diff, +files/modprobe-113-r2.sh,
+ +files/udev-start-113-r2.sh, +files/udev.conf.post_113,
+ +udev-113-r2.ebuild:
+ Corrected typo in file mode for new added usb rule, Bug #185069. Now
+ automatically blacklist the modules in modules.autoload.d from coldplug, to
+ let modules-init script load them and respect the order in which they are
+ listed, relevant for multimedia devices like alsa, v4l and dvb, Bug #184833.
*udev-113-r1 (10 Jul 2007)
diff --git a/sys-fs/udev/files/digest-udev-113-r2 b/sys-fs/udev/files/digest-udev-113-r2
new file mode 100644
index 000000000000..2f51cd4d0a51
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-113-r2
@@ -0,0 +1,3 @@
+MD5 cb9a227206b9d85ae8cfc88fc51c1710 udev-113.tar.bz2 195555
+RMD160 02175d9714027716b7a97f49e61625979fd0c43c udev-113.tar.bz2 195555
+SHA256 38da4049b76b58ddbc6ead6fa84cb241d94cc38ad4ee7aefd99ae2c57a73a2d4 udev-113.tar.bz2 195555
diff --git a/sys-fs/udev/files/modprobe-113-r2.sh b/sys-fs/udev/files/modprobe-113-r2.sh
new file mode 100755
index 000000000000..23e198d1f66d
--- /dev/null
+++ b/sys-fs/udev/files/modprobe-113-r2.sh
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Do not continue for non-modular kernel - Bug #168322
+[ ! -f /proc/modules ] && exit 0
+
+if [ -e /dev/.udev_populate ]; then
+ # Enable verbose while called from udev-addon-start
+ . /dev/.udev_populate
+
+ if [ -c "${CONSOLE}" ]; then
+ # redirect stdin/out/err
+ exec <${CONSOLE} >${CONSOLE} 2>/${CONSOLE}
+ fi
+fi
+
+# set default if not present in udev.conf
+implicitly_blacklist_modules_autoload="yes"
+MODPROBE=/sbin/modprobe
+
+. /etc/init.d/functions.sh
+[ -e /etc/udev/udev.conf ] && . /etc/udev/udev.conf
+
+
+# Create a lock file for the current module.
+lock_modprobe() {
+ [ -e /dev/.udev/ ] || return 0
+
+ MODPROBE_LOCK="/dev/.udev/.lock-modprobe-${MODNAME}"
+
+ retry=20
+ while ! mkdir "$MODPROBE_LOCK" 2> /dev/null; do
+ if [ $retry -eq 0 ]; then
+ ewarn "Could lock modprobe ${MODNAME}!"
+ return 1
+ fi
+ sleep 1
+ retry=$(($retry - 1))
+ done
+ return 0
+}
+
+unlock_modprobe() {
+ [ "$MODPROBE_LOCK" ] || return 0
+ rmdir "$MODPROBE_LOCK" || true
+}
+
+MODLIST=$("${MODPROBE}" -q -i --show-depends "${@}" 2>/dev/null \
+ | sed -e "s#^insmod /lib.*/\(.*\)\.ko.*#\1#g" -e 's|-|_|g')
+
+# exit if you have no modules to load
+[ -z "${MODLIST}" ] && exit 0
+for m in ${MODLIST}; do
+ MODNAME=$m
+done
+
+# check for blacklisting
+if [ -f /etc/modprobe.conf ]; then
+ if grep -q '^blacklist.*[[:space:]]'"${MODNAME}"'\([[:space:]]\|$\)' /etc/modprobe.conf; then
+ # module blacklisted
+ exit 0
+ fi
+fi
+
+if [ "$implicitly_blacklist_modules_autoload" = "yes" -a -f "${MODULES_AUTOLOAD_FILE}" ]; then
+ if grep -q "^${MODNAME}"'\([[:space:]]\|$\)' "${MODULES_AUTOLOAD_FILE}"; then
+ # module implictly blacklisted
+ # as present in modules.autoload, Bug 184833
+ exit 0
+ fi
+fi
+
+lock_modprobe
+# check if loaded
+if ! grep -q "^${MODNAME}[[:space:]]" /proc/modules; then
+ # now do real loading
+ einfo " udev loading module ${MODNAME}"
+ "${MODPROBE}" -q "${@}" >/dev/null 2>/dev/null
+fi
+unlock_modprobe
+
diff --git a/sys-fs/udev/files/udev-113-r2-rules.diff b/sys-fs/udev/files/udev-113-r2-rules.diff
new file mode 100644
index 000000000000..fca477116cf1
--- /dev/null
+++ b/sys-fs/udev/files/udev-113-r2-rules.diff
@@ -0,0 +1,38 @@
+diff --git a/etc/udev/gentoo/50-udev.rules b/etc/udev/gentoo/50-udev.rules
+index 57f2387..b2f69e2 100644
+--- a/etc/udev/gentoo/50-udev.rules
++++ b/etc/udev/gentoo/50-udev.rules
+@@ -129,7 +129,8 @@ KERNEL=="dnrtmsg", NAME="netlink/%k"
+ KERNEL=="tap*", NAME="netlink/%k"
+
+ # network devices
+-KERNEL=="tun", NAME="net/%k", MODE="0600"
++KERNEL=="tun", NAME="net/%k", MODE="0660", OPTIONS+="ignore_remove"
++KERNEL=="ppp", MODE="0600", OPTIONS+="ignore_remove"
+
+ # ramdisk devices
+ KERNEL=="ram[0-9]*", NAME="rd/%n", SYMLINK+="%k"
+@@ -240,15 +241,18 @@ KERNEL=="issm*", NAME="infiniband/%k"
+
+
+ # usbfs-like device nodes
++# the way to go up to kernel 2.6.21 (and above if setting USB_DEVICE_CLASS=y)
+ SUBSYSTEM=="usb_device", PROGRAM="/bin/sh -c 'K=%k; K=$${K#usbdev}; printf bus/usb/%%03i/%%03i $${K%%%%.*} $${K#*.}'", NAME="%c", GROUP="usb", MODE="0664"
++# starting from kernel 2.6.22 use this rule
++SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", \
++ NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}", GROUP="usb", MODE="0664"
+
+-
+-# Setting timeout for tape-devices to 900 seconds
++# Setting timeout for tape-devices (type 1) to 900 seconds
++# and 60 seconds for device types 0, 7 and 14
+ # if you need timeouts for other devices add a similar rule
+ # with correct type-value, or open a bug on bugs.gentoo.org.
+-ACTION=="add", SUBSYSTEM=="scsi" , ATTRS{type}=="1", \
+- RUN+="/bin/sh -c 'echo 900 > /sys$$DEVPATH/timeout'"
+-
++SUBSYSTEM=="scsi", KERNEL=="[0-9]*:[0-9]*", ACTION=="add", ATTR{type}=="0|7|14", ATTR{timeout}="60"
++SUBSYSTEM=="scsi", KERNEL=="[0-9]*:[0-9]*", ACTION=="add", ATTR{type}=="1", ATTR{timeout}="900"
+
+ # Module autoloading
+ ACTION!="add", GOTO="hotplug_no_add_event"
diff --git a/sys-fs/udev/files/udev-start-113-r2.sh b/sys-fs/udev/files/udev-start-113-r2.sh
new file mode 100644
index 000000000000..f8cd44839431
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-113-r2.sh
@@ -0,0 +1,247 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+tmpfs_size="10M"
+
+[ -e /etc/udev/udev.conf ] && . /etc/udev/udev.conf
+
+get_modules_autoload_file() {
+ # code copied from /etc/init.d/modules
+
+ # Should not fail if kernel do not have module
+ # support compiled in ...
+ [ ! -f /proc/modules -o "${RC_SYS}" = "VPS" ] && return 0
+
+ local KV=$(uname -r)
+ local KV_MAJOR=${KV%%.*}
+ local x=${KV#*.}
+ local KV_MINOR=${x%%.*}
+ x=${KV#*.*.}
+ local KV_MICRO=${x%%-*}
+
+ local auto=""
+ if [ -f /etc/modules.autoload -a ! -L /etc/modules.autoload ]; then
+ auto=/etc/modules.autoload
+ else
+ local x= f="/etc/modules.autoload.d/kernel"
+ for x in "${KV}" ${KV_MAJOR}.${KV_MINOR}.${KV_MICRO} ${KV_MAJOR}.${KV_MINOR} ; do
+ if [ -f "${f}-${x}.${RC_SOFTLEVEL}" ] ; then
+ auto="${f}-${x}.${RC_SOFTLEVEL}"
+ break
+ fi
+ if [ "${RC_SOFTLEVEL}" = "${RC_BOOTLEVEL}" -a -f "${f}-${x}.${RC_DEFAULTLEVEL}" ] ; then
+ auto="${f}-${x}.${RC_DEFAULTLEVEL}"
+ break
+ fi
+ if [ -f "${f}-${x}" ] ; then
+ auto="${f}-${x}"
+ break
+ fi
+ done
+ fi
+ echo "${auto}"
+}
+
+populate_udev() {
+ # populate /dev with devices already found by the kernel
+
+ # tell modprobe.sh to be verbose to $CONSOLE
+
+ echo "export CONSOLE=${CONSOLE}" > /dev/.udev_populate
+ echo "export TERM=${TERM}" >> /dev/.udev_populate
+ echo "export MODULES_AUTOLOAD_FILE=$(get_modules_autoload_file)" >> /dev/.udev_populate
+
+ if get_bootparam "nocoldplug" ; then
+ RC_COLDPLUG="no"
+ ewarn "Skipping udev coldplug as requested in kernel cmdline"
+ fi
+
+ if [ "$(get_KV)" -gt "$(KV_to_int '2.6.14')" ] ; then
+ ebegin "Populating /dev with existing devices through uevents"
+ local opts=
+ [ "${RC_COLDPLUG}" != "yes" ] && opts="--attr-match=dev"
+ /sbin/udevtrigger ${opts}
+ eend $?
+ else
+ ebegin "Populating /dev with existing devices with udevstart"
+ /sbin/udevstart
+ eend $?
+ fi
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ /sbin/udevsettle --timeout=60
+ eend $?
+
+ rm -f /dev/.udev_populate
+ return 0
+}
+
+seed_dev() {
+ # Seed /dev with some things that we know we need
+ ebegin "Seeding /dev with needed nodes"
+
+ # creating /dev/console and /dev/tty1 to be able to write
+ # to $CONSOLE with/without bootsplash before udevd creates it
+ [ ! -c /dev/console ] && mknod /dev/console c 5 1
+ [ ! -c /dev/tty1 ] && mknod /dev/tty1 c 4 1
+
+ # udevd will dup its stdin/stdout/stderr to /dev/null
+ # and we do not want a file which gets buffered in ram
+ [ ! -c /dev/null ] && mknod /dev/null c 1 3
+
+ # copy over any persistant things
+ if [ -d /lib/udev/devices ] ; then
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev 2>/dev/null
+ fi
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [ -e /proc/kcore ] && ln -snf /proc/kcore /dev/core
+
+ # Create problematic directories
+ mkdir -p /dev/pts /dev/shm
+ eend 0
+}
+
+unpack_device_tarball() {
+ # Actually get udev rolling
+ if [ "${RC_DEVICE_TARBALL}" = "yes" ] && \
+ [ -s /lib/udev/state/devices.tar.bz2 ] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev/state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+}
+
+make_dev_root() {
+ local DEV="$(/lib/udev/get_dir_major_minor "/")"
+ if [ $? = 0 -a -n "${DEV}" ]; then
+ mknod -m 600 /dev/root b ${DEV}
+ fi
+}
+
+check_persistent_net() {
+ # check if there are problems with persistent-net
+ local syspath=
+ local devs=
+ local problem_found=0
+ for syspath in /sys/class/net/*_rename*; do
+ if [ -d "${syspath}" ]; then
+ devs="${devs} ${syspath##*/}"
+ problem_found=1
+ fi
+ done
+
+ [ "${problem_found}" = 0 ] && return 0
+
+ eerror "UDEV: Your system has a problem assigning persistent names"
+ eerror "to these network interfaces: ${devs}"
+
+ einfo "Checking persistent-net rules:"
+ # the sed-expression lists all duplicate lines
+ # from the input, like "uniq -d" does, but uniq
+ # is installed into /usr/bin and not available at boot.
+ dups=$(
+ RULES_FILE='/etc/udev/rules.d/70-persistent-net.rules'
+ . /lib/udev/rule_generator.functions
+ find_all_rules 'NAME=' '.*'|tr ' ' '\n'|sort|sed '$!N; s/^\(.*\)\n\1$/\1/; t; D'
+ )
+ if [ -n "${dups}" ]; then
+ ewarn "The rules create multiple entries assigning these names:"
+ eindent
+ ewarn "${dups}"
+ eoutdent
+ else
+ ewarn "Found no duplicate names in persistent-net rules,"
+ ewarn "there must be some other problem!"
+ fi
+ return 1
+}
+
+main() {
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [ "${RC_USE_FSTAB}" = "yes" ] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [ -n "${mntcmd}" ] ; then
+ try mount -n ${mntcmd}
+ else
+ mntopts="exec,nosuid,mode=0755,size=${tmpfs_size}"
+ if grep -Eq "[[:space:]]+tmpfs$" /proc/filesystems ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ # many video drivers require exec access in /dev #92921
+ try mount -n -t "${mntcmd}" -o "${mntopts}" udev /dev
+ fi
+ eend $?
+
+ # Create a file so that our rc system knows it's still in sysinit.
+ # Existance means init scripts will not directly run.
+ # rc will remove the file when done with sysinit.
+ touch /dev/.rcsysinit
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [ -x /sbin/restorecon -a -c /selinux/null ] ; then
+ restorecon /dev > /selinux/null
+ fi
+
+ unpack_device_tarball
+ seed_dev
+
+ # Setup hotplugging (if possible)
+ if [ -e /proc/sys/kernel/hotplug ] ; then
+ ebegin "Setting up proper hotplug agent"
+ eindent
+ if [ $(get_KV) -gt $(KV_to_int '2.6.14') ] ; then
+ einfo "Using netlink for hotplug events..."
+ echo "" > /proc/sys/kernel/hotplug
+ else
+ einfo "Setting /sbin/udevsend as hotplug agent ..."
+ echo "/sbin/udevsend" > /proc/sys/kernel/hotplug
+ fi
+ eoutdent
+ eend 0
+ fi
+
+ ebegin "Starting udevd"
+ /sbin/udevd --daemon
+ eend $?
+
+ populate_udev
+ make_dev_root
+
+ # Only do this for baselayout-1*
+ if [ ! -e /lib/librc.so ]; then
+
+ # Create nodes that udev can't
+ ebegin "Finalizing udev configuration"
+ [ -x /sbin/lvm ] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ # Running evms_activate on a LiveCD causes lots of headaches
+ [ -z "${CDBOOT}" -a -x /sbin/evms_activate ] && \
+ /sbin/evms_activate -q &>/dev/null
+ eend 0
+ fi
+
+ check_persistent_net
+
+ # trigger executing initscript when /etc is writable
+ IN_HOTPLUG=1 /etc/init.d/udev-postmount start >/dev/null 2>/dev/null
+
+ # udev started successfully
+ return 0
+}
+
+main
+
+# vim:ts=4
diff --git a/sys-fs/udev/files/udev.conf.post_113 b/sys-fs/udev/files/udev.conf.post_113
new file mode 100644
index 000000000000..b9f6e14bf121
--- /dev/null
+++ b/sys-fs/udev/files/udev.conf.post_113
@@ -0,0 +1,28 @@
+# /etc/udev/udev.conf: main config file for udev
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/files/udev.conf.post_113,v 1.1 2007/07/12 14:24:15 zzam Exp $
+#
+# This file can be used to override some of udev's default values.
+# See the udev man page for more details about these values.
+
+# udev_root - where in the filesystem to place the device nodes
+udev_root="/dev/"
+
+# udev_rules - The name and location of the udev rules file
+udev_rules="/etc/udev/rules.d/"
+
+# The initial syslog(3) priority: "err", "info", "debug" or its
+# numerical equivalent. For runtime debugging, the daemons internal
+# state can be changed with: "udevcontrol log_priority=<value>".
+udev_log="err"
+
+# The maximum size reserved for the tmpfs mounted on /dev
+tmpfs_size="10M"
+
+# Implictly blacklist the modules listed in modules.autoload
+# so that udev (with coldplugging) does not load them
+# but /etc/init.d/modules will do later.
+# This can guarantee correct load order needed for
+# some subsystems (like alsa, v4l, dvb, ...).
+# It should be generally safe.
+implicitly_blacklist_modules_autoload="yes"
+
diff --git a/sys-fs/udev/udev-113-r2.ebuild b/sys-fs/udev/udev-113-r2.ebuild
new file mode 100644
index 000000000000..ec81872a9bf7
--- /dev/null
+++ b/sys-fs/udev/udev-113-r2.ebuild
@@ -0,0 +1,308 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-113-r2.ebuild,v 1.1 2007/07/12 14:24:15 zzam Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="!sys-apps/coldplug"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.12.5"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+pkg_setup() {
+ udev_helper_dir="/$(get_libdir)/udev"
+
+ myconf=
+ extras="extras/ata_id \
+ extras/cdrom_id \
+ extras/edd_id \
+ extras/firmware \
+ extras/floppy \
+ extras/path_id \
+ extras/scsi_id \
+ extras/usb_id \
+ extras/volume_id \
+ extras/rule_generator \
+ extras/root_link"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+}
+
+sed_helper_dir() {
+ sed -e "s#/lib/udev#${udev_helper_dir}#" -i "$@"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ epatch ${FILESDIR}/${PN}-104-peristent-net-disable-xen.patch
+ EPATCH_OPTS="-p1" epatch ${FILESDIR}/${PN}-110-root-link-1.diff
+ epatch ${FILESDIR}/${PN}-113-r2-rules.diff
+
+ # this is now installed by sys-fs/device-mapper
+ rm etc/udev/gentoo/64-device-mapper.rules
+
+ # We already have that rule in 50-udev.rules
+ sed -i extras/cdrom_id/Makefile -e '/60-cdrom_id.rules/d'
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/50-udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "933bc5d61ac2d49ab75bdf94cde454e1" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+
+ sed_helper_dir \
+ etc/udev/gentoo/50-udev.rules \
+ extras/rule_generator/write_*_rules \
+ udev_rules_parse.c \
+ udev_utils_run.c
+
+ # Use correct multilib dir
+ sed -i extras/volume_id/lib/Makefile \
+ -e "/ =/s-/lib-/$(get_libdir)-"
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ emake \
+ EXTRAS="${extras}" \
+ libudevdir=${udev_helper_dir} \
+ CROSS_COMPILE=${mycross} \
+ OPTFLAGS="" \
+ ${myconf} || die
+}
+
+src_install() {
+ into /
+ emake \
+ DESTDIR="${D}" \
+ libudevdir=${udev_helper_dir} \
+ EXTRAS="${extras}" \
+ ${myconf} \
+ install || die
+
+ # make install does not install this
+ dosbin udevstart || die "Required binary not installed properly"
+ doman udevstart.8
+
+ exeinto "${udev_helper_dir}"
+ newexe "${FILESDIR}"/net-104-r10.sh net.sh || die "Required binary not installed properly"
+ newexe "${FILESDIR}"/modprobe-113-r2.sh modprobe.sh || die "Required binary not installed properly"
+ newexe "${FILESDIR}"/move_tmp_persistent_rules-112-r1.sh move_tmp_persistent_rules.sh \
+ || die "Required binary not installed properly"
+
+ keepdir "${udev_helper_dir}"/state
+ keepdir "${udev_helper_dir}"/devices
+
+ # create symlinks for these utilities to /sbin
+ # where multipath-tools expect them to be (Bug #168588)
+ dosym "..${udev_helper_dir}/vol_id" /sbin/vol_id
+ dosym "..${udev_helper_dir}/scsi_id" /sbin/scsi_id
+
+ # vol_id library (needed by mount and HAL)
+ into /
+ dolib extras/volume_id/lib/*.so*
+ into /usr
+ dolib extras/volume_id/lib/*.a
+
+ # handle static linking bug #4411
+ rm -f "${D}/usr/$(get_libdir)/libvolume_id.so"
+ gen_usr_ldscript libvolume_id.so
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_113 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ doins etc/udev/gentoo/??-*.rules
+ # Use upstream's persistent rules for devices
+ doins etc/udev/rules.d/60-*.rules
+
+ # our udev hooks into the rc system
+ insinto /$(get_libdir)/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-113-r2.sh udev-start.sh
+ newins "${FILESDIR}"/udev-stop-111-r2.sh udev-stop.sh
+
+ # The udev-post init-script
+ newinitd "${FILESDIR}"/udev-postmount-initd-111-r2 udev-postmount
+
+ insinto /etc/modprobe.d
+ newins ${FILESDIR}/blacklist-110 blacklist
+ doins ${FILESDIR}/pnp-aliases
+
+ # convert /lib/udev to real used dir
+ sed_helper_dir \
+ "${D}/$(get_libdir)"/rcscripts/addons/*.sh \
+ "${D}"/etc/init.d/udev* \
+ "${D}"/etc/modprobe.d/*
+
+ if use s390; then
+ # s390 does not has persistent mac addresses
+ # and we only have persistence rules for mac.
+ # For now just remove the rules file.
+ rm ${D}/etc/udev/rules.d/75-persistent-net-generator.rules
+ fi
+
+ # documentation
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+
+}
+
+pkg_preinst() {
+ if [[ -d "${ROOT}"/lib/udev-state ]] ; then
+ mv -f "${ROOT}"/lib/udev-state/* "${D}"/lib/udev/state/
+ rm -r "${ROOT}"/lib/udev-state
+ fi
+
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f "${ROOT}"/etc/udev/udev.config "${ROOT}"/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f "${ROOT}"/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f "${ROOT}"/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/10-udev.hotplug" ]
+ then
+ rm -f "${ROOT}"/etc/hotplug.d/default/10-udev.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [ -f "${ROOT}/etc/init.d/coldplug" ]
+ then
+ coldplug_stale="1"
+ fi
+
+ if has_version "<sys-fs/udev-113" &&
+ [[ -f "${ROOT}"/etc/udev/rules.d/64-device-mapper.rules ]] &&
+ has_version sys-fs/device-mapper
+ then
+ # change mtime to definitely keep the file
+ touch "${ROOT}"/etc/udev/rules.d/64-device-mapper.rules
+ fi
+}
+
+pkg_postinst() {
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+
+ if [[ ${coldplug_stale} == "1" ]] ; then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ # delete 40-scsi-hotplug.rules - all integrated in 50-udev.rules
+ if has_version "=sys-fs/udev-103-r3"; then
+ if [[ -e "${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules" ]]
+ then
+ ewarn "Deleting stray 40-scsi-hotplug.rules"
+ ewarn "installed by sys-fs/udev-103-r3"
+ rm -f "${ROOT}"/etc/udev/rules.d/40-scsi-hotplug.rules
+ fi
+ fi
+
+ # Removing some device-nodes we thought we need some time ago
+ if [[ -d "${ROOT}"/lib/udev/devices ]]; then
+ rm -f "${ROOT}"/lib/udev/devices/{null,zero,console,urandom}
+ fi
+
+ # Removing some old file
+ if has_version "<sys-fs/udev-104-r5"; then
+ rm -f "${ROOT}"/etc/dev.d/net/hotplug.dev
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net
+ fi
+
+ if has_version "<sys-fs/udev-106-r5"; then
+ if [[ -e "${ROOT}"/etc/udev/rules.d/95-net.rules ]]; then
+ rm -f "${ROOT}"/etc/udev/rules.d/95-net.rules
+ fi
+ fi
+
+ # Try to remove /etc/dev.d as that is obsolete
+ if [[ -d "${ROOT}"/etc/dev.d ]]; then
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/default "${ROOT}"/etc/dev.d
+ if [[ -d "${ROOT}"/etc/dev.d ]]; then
+ ewarn "You still have the directory /etc/dev.d on your system."
+ ewarn "This is no longer used by udev and can be removed."
+ fi
+ fi
+
+ # 64-device-mapper.rules now gets installed by sys-fs/device-mapper
+ # remove it if user don't has sys-fs/device-mapper installed
+ if has_version "<sys-fs/udev-113" &&
+ [[ -f "${ROOT}"/etc/udev/rules.d/64-device-mapper.rules ]] &&
+ ! has_version sys-fs/device-mapper
+ then
+ rm -f "${ROOT}"/etc/udev/rules.d/64-device-mapper.rules
+ einfo "Removed unneeded file 64-device-mapper.rules"
+ fi
+
+
+ if [[ "${ROOT}" == "/" ]] ; then
+ # check if root of init-process is identical to ours
+ if [ -r /proc/1/root -a /proc/1/root/ -ef /proc/self/root/ ]; then
+ einfo "restarting udevd now."
+ if [[ -n $(pidof udevd) ]] ; then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+ fi
+ fi
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}