summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-02 21:36:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-02 21:36:51 +0000
commit0f9f8a9bd4a494b3ef2ae618fd7306aab652b0fc (patch)
treede260ddfdedf2b5c62a6e29c4543b8e5f9dd0d06 /sys-fs
parentAdd support to not build with ocamlopt (diff)
downloadgentoo-2-0f9f8a9bd4a494b3ef2ae618fd7306aab652b0fc.tar.gz
gentoo-2-0f9f8a9bd4a494b3ef2ae618fd7306aab652b0fc.tar.bz2
gentoo-2-0f9f8a9bd4a494b3ef2ae618fd7306aab652b0fc.zip
Version bump using a snapshot from the actual Git repo now. Also update the live ebuild to use the Git repo directly. attr/acl are totally optional now.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtd-utils/ChangeLog9
-rw-r--r--sys-fs/mtd-utils/files/digest-mtd-utils-200801023
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20080102.ebuild51
-rw-r--r--sys-fs/mtd-utils/mtd-utils-9999.ebuild36
4 files changed, 82 insertions, 17 deletions
diff --git a/sys-fs/mtd-utils/ChangeLog b/sys-fs/mtd-utils/ChangeLog
index c1971d4a9f60..394da26a2872 100644
--- a/sys-fs/mtd-utils/ChangeLog
+++ b/sys-fs/mtd-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/mtd-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.7 2008/01/01 16:24:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.8 2008/01/02 21:36:51 robbat2 Exp $
+
+*mtd-utils-20080102 (02 Jan 2008)
+
+ 02 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> mtd-utils-9999.ebuild,
+ +mtd-utils-20080102.ebuild:
+ Version bump using a snapshot from the actual Git repo now. Also update the
+ live ebuild to use the Git repo directly. attr/acl are totally optional now.
01 Jan 2008; Markus Meier <maekke@gentoo.org> mtd-utils-20060907.ebuild:
x86 stable, bug #203855
diff --git a/sys-fs/mtd-utils/files/digest-mtd-utils-20080102 b/sys-fs/mtd-utils/files/digest-mtd-utils-20080102
new file mode 100644
index 000000000000..bf9dd60f7502
--- /dev/null
+++ b/sys-fs/mtd-utils/files/digest-mtd-utils-20080102
@@ -0,0 +1,3 @@
+MD5 757a7d7962661a887932d894a03edc67 mtd-utils-snapshot-20080102-9ba41c4dc891e38c92126bfcc4c366d765841da0.tar.gz 300364
+RMD160 8b998bd23be16a389ddef7a5562547647d10aff8 mtd-utils-snapshot-20080102-9ba41c4dc891e38c92126bfcc4c366d765841da0.tar.gz 300364
+SHA256 01947ddd2acfbb38dc14c1a12a5c4b1727378c1aa80045295fceb51438da793d mtd-utils-snapshot-20080102-9ba41c4dc891e38c92126bfcc4c366d765841da0.tar.gz 300364
diff --git a/sys-fs/mtd-utils/mtd-utils-20080102.ebuild b/sys-fs/mtd-utils/mtd-utils-20080102.ebuild
new file mode 100644
index 000000000000..7d1a7dd6890c
--- /dev/null
+++ b/sys-fs/mtd-utils/mtd-utils-20080102.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20080102.ebuild,v 1.1 2008/01/02 21:36:51 robbat2 Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="MTD userspace tools, based on GIT snapshot from upstream"
+HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
+
+# Git ID for the snapshot
+MY_PV="${PV}-9ba41c4dc891e38c92126bfcc4c366d765841da0"
+SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="xattr"
+
+S=${WORKDIR}/${PN}.git
+
+RDEPEND="!sys-fs/mtd
+ sys-libs/zlib"
+# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
+# And ACL brings in Attr as well.
+DEPEND="xattr? ( sys-apps/acl )
+ ${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i.orig \
+ -e 's!^MANDIR.*!MANDIR = /usr/share/man!g' \
+ -e 's!-include.*!!g' \
+ -e '/make -C/s,make,$(MAKE),g' \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local myflags=""
+ use xattr || myflags="WITHOUT_XATTR=1"
+ emake DESTDIR="${D}" \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ ${myflags} || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc *.txt
+ # TODO: check ubi-utils for docs+scripts
+}
diff --git a/sys-fs/mtd-utils/mtd-utils-9999.ebuild b/sys-fs/mtd-utils/mtd-utils-9999.ebuild
index 8e26b30cfde6..a5e81af7acaf 100644
--- a/sys-fs/mtd-utils/mtd-utils-9999.ebuild
+++ b/sys-fs/mtd-utils/mtd-utils-9999.ebuild
@@ -1,46 +1,50 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-9999.ebuild,v 1.1 2007/12/27 21:13:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-9999.ebuild,v 1.2 2008/01/02 21:36:51 robbat2 Exp $
ECVS_USER="anoncvs"
ECVS_PASS="anoncvs"
-ECVS_SERVER="cvs.infradead.org:/home/cvs"
-ECVS_MODULE="mtd"
-inherit toolchain-funcs flag-o-matic cvs
+EGIT_REPO_URI="git://git.infradead.org/mtd-utils.git"
+inherit toolchain-funcs flag-o-matic git
DESCRIPTION="MTD userspace tools"
-HOMEPAGE="http://sources.redhat.com/jffs2/"
+HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="xattr"
-S=${WORKDIR}/mtd/util
-
-DEPEND="!sys-fs/mtd
- sys-libs/zlib"
+RDEPEND="!sys-fs/mtd
+ sys-libs/zlib"
+# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
+# And ACL brings in Attr as well.
+DEPEND="xattr? ( sys-apps/acl )
+ ${DEPEND}"
src_unpack() {
- cvs_src_unpack
+ git_src_unpack
sed -i \
-e 's!^MANDIR.*!MANDIR = /usr/share/man!g' \
-e 's!-include.*!!g' \
+ -e '/make -C/s,make,$(MAKE),g' \
"${S}"/Makefile
}
src_compile() {
- emake \
- CFLAGS="${CFLAGS} -I../include -Wall" \
+ local myflags=""
+ use xattr || myflags="WITHOUT_XATTR=1"
+ emake DESTDIR="${D}" \
+ OPTFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)" \
- DESTDIR="${D}" \
- || die
+ ${myflags} || die
}
src_install() {
emake install DESTDIR="${D}" || die
rm -r "${D}"/usr/include || die
dodoc *.txt
+ # TODO: check ubi-utils for docs+scripts
}