summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-03 07:26:27 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-03 07:26:27 +0000
commit00820b8e4feb9203ee57f3bdb2213e8d19a6ee85 (patch)
treee54a6d67804f53a1bfae19f15099665e3c0d5160 /sys-fs
parentUpdated with pdf use flag and png-1.5 support (closes bug 355817). (diff)
downloadgentoo-2-00820b8e4feb9203ee57f3bdb2213e8d19a6ee85.tar.gz
gentoo-2-00820b8e4feb9203ee57f3bdb2213e8d19a6ee85.tar.bz2
gentoo-2-00820b8e4feb9203ee57f3bdb2213e8d19a6ee85.zip
Add check() to initscript, #357089
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/ChangeLog8
-rw-r--r--sys-fs/quota/files/quota.rc738
-rw-r--r--sys-fs/quota/quota-3.17-r1.ebuild79
3 files changed, 124 insertions, 1 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index ea5363295ba8..a60a461df082 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/quota
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.49 2011/02/26 16:49:17 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.50 2011/03/03 07:26:27 jlec Exp $
+
+*quota-3.17-r1 (03 Mar 2011)
+
+ 03 Mar 2011; Justin Lecher <jlec@gentoo.org> +quota-3.17-r1.ebuild,
+ +files/quota.rc7:
+ Add check() to initscript, #357089
26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> quota-3.17.ebuild:
Marked ~ppc64 wrt #340455
diff --git a/sys-fs/quota/files/quota.rc7 b/sys-fs/quota/files/quota.rc7
new file mode 100644
index 000000000000..9fd2d900cd2e
--- /dev/null
+++ b/sys-fs/quota/files/quota.rc7
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/files/quota.rc7,v 1.1 2011/03/03 07:26:27 jlec Exp $
+
+extra_started_commands="check"
+description_check="Running quotacheck with quota being offline"
+
+depend() {
+ need localmount
+ use portmap
+}
+
+start() {
+ if [[ ${RUN_QUOTACHECK} == "yes" ]] ; then
+ ebegin "Checking quotas (may take a while)"
+ quotacheck ${QUOTACHECK_OPTS}
+ eend $?
+ fi
+
+ ebegin "Starting quota"
+ quotaon ${QUOTAON_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping quota"
+ quotaoff ${QUOTAOFF_OPTS}
+ eend $?
+}
+
+check() {
+ ebegin "Checking quota"
+ quotaoff ${QUOTAOFF_OPTS} && \
+ quotacheck ${QUOTACHECK_OPTS} && \
+ quotaon ${QUOTAON_OPTS}
+ eend $?
+}
diff --git a/sys-fs/quota/quota-3.17-r1.ebuild b/sys-fs/quota/quota-3.17-r1.ebuild
new file mode 100644
index 000000000000..0f41a756e0c9
--- /dev/null
+++ b/sys-fs/quota/quota-3.17-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.17-r1.ebuild,v 1.1 2011/03/03 07:26:27 jlec Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls tcpd ldap rpc"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ rpc? ( || ( net-nds/portmap net-nds/rpcbind ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
+
+ # This was for openldap-2.2 support before,
+ # Now we only support >=2.3
+ append-cppflags -DLDAP_DEPRECATED=0
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake STRIP="" ROOTDIR="${D}" install || die
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ dodoc doc/*
+ dodoc README.*
+ dodoc Changelog
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}