summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-06-25 23:56:43 +0000
committerMike Frysinger <vapier@gentoo.org>2009-06-25 23:56:43 +0000
commit48d93ce890b7bb7841629e82b7dab3fd7391d548 (patch)
tree90da3fe110078f6d8d9b780d2fef22e3b416cd80 /sys-fs/xfsprogs
parentVersion bump #275405 by Lars Wendler. (diff)
downloadgentoo-2-48d93ce890b7bb7841629e82b7dab3fd7391d548.tar.gz
gentoo-2-48d93ce890b7bb7841629e82b7dab3fd7391d548.tar.bz2
gentoo-2-48d93ce890b7bb7841629e82b7dab3fd7391d548.zip
Version bump #275405 by Lars Wendler and USE=static support #273219 by Wolfram Schlich.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog12
-rw-r--r--sys-fs/xfsprogs/files/xfsprogs-3.0.1-sharedlibs.patch84
-rw-r--r--sys-fs/xfsprogs/xfsprogs-3.0.1.ebuild53
3 files changed, 148 insertions, 1 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index 5ccd6644de34..3af45948bd76 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.115 2009/02/24 05:11:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.116 2009/06/25 23:56:43 vapier Exp $
+
+ 25 Jun 2009; Mike Frysinger <vapier@gentoo.org> +xfsprogs-3.0.1.ebuild,
+ +files/xfsprogs-3.0.1-sharedlibs.patch:
+ Version bump #275405 by Lars Wendler and USE=static support #273219 by
+ Wolfram Schlich.
+
+*xfsprogs-3.0.1 (25 Jun 2009)
+
+ 25 Jun 2009; Mike Frysinger <vapier@gentoo.org> +xfsprogs-3.0.1.ebuild:
+ Version bump #275405 by Lars Wendler.
24 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+files/xfsprogs-3.0.0-parallel-build.patch, xfsprogs-3.0.0.ebuild:
diff --git a/sys-fs/xfsprogs/files/xfsprogs-3.0.1-sharedlibs.patch b/sys-fs/xfsprogs/files/xfsprogs-3.0.1-sharedlibs.patch
new file mode 100644
index 000000000000..aa6b008a327d
--- /dev/null
+++ b/sys-fs/xfsprogs/files/xfsprogs-3.0.1-sharedlibs.patch
@@ -0,0 +1,84 @@
+ripped from PLD Linux
+
+--- xfsprogs-3.0.0/libdisk/Makefile
++++ xfsprogs-3.0.0/libdisk/Makefile
+@@ -25,8 +25,9 @@
+ include $(BUILDRULES)
+
+ install: default
++ $(INSTALL_LTLIB)
+
+ install-dev: default
+- $(INSTALL_LTLIB_STATIC)
++ $(INSTALL_LTLIB_DEV)
+
+ install-qa: install-dev
+--- xfsprogs-3.0.0/libxfs/Makefile
++++ xfsprogs-3.0.0/libxfs/Makefile
+@@ -41,7 +41,9 @@
+ include $(BUILDRULES)
+
+ install: default
++ $(INSTALL_LTLIB)
+
+ install-dev: default
++ $(INSTALL_LTLIB_DEV)
+
+ install-qa: default
+--- xfsprogs-3.0.0/libxlog/Makefile
++++ xfsprogs-3.0.0/libxlog/Makefile
+@@ -12,6 +12,8 @@
+
+ CFILES = xfs_log_recover.c util.c
+
++LTLIBS = $(LIBUUID) $(LIBXFS)
++
+ # don't want to link xfs_repair with a debug libxlog.
+ DEBUG = -DNDEBUG
+
+@@ -19,4 +21,10 @@
+
+ include $(BUILDRULES)
+
+-install install-dev install-qa: default
++install: default
++ $(INSTALL_LTLIB)
++
++install-dev: default
++ $(INSTALL_LTLIB_DEV)
++
++install-qa: default
+
+--- xfsprogs-3.0.0/Makefile
++++ xfsprogs-3.0.0/Makefile
+@@ -41,6 +41,7 @@
+ mkfs: libxfs libdisk
+ quota: libxcmd
+ repair: libxfs libxlog
++libxlog: libxfs
+
+ ifeq ($(HAVE_BUILDDEFS), yes)
+ include $(BUILDRULES)
+--- xfsprogs-3.0.0/include/buildmacros
++++ xfsprogs-3.0.0/include/buildmacros
+@@ -69,17 +69,9 @@
+ # /usr/lib.
+ ifeq ($(ENABLE_SHARED),yes)
+ INSTALL_LTLIB_DEV = \
+- cd $(TOPDIR)/$(LIBNAME)/.libs; \
+- ../$(INSTALL) -m 755 -d $(PKG_DEVLIB_DIR); \
+- ../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai $(PKG_DEVLIB_DIR); \
+- ../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
+- ../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
+- ../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_LIB_DIR); \
+- if test "x$(PKG_DEVLIB_DIR)" != "x$(PKG_LIB_DIR)" ; then \
+- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(PKG_LIB_DIR)/$(LIBNAME).a; \
+- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(PKG_LIB_DIR)/$(LIBNAME).la; \
+- ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so; \
+- fi
++ cd $(TOPDIR)/$(LIBNAME); \
++ $(INSTALL) -m 755 -d $(PKG_DEVLIB_DIR); \
++ env -uDIST_ROOT $(LTINSTALL) $(TOPDIR)/$(LIBNAME)/$(LIBNAME).la $(DIST_ROOT)$(PKG_DEVLIB_DIR)/$(LIBNAME).la
+ else
+ INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
+ endif
diff --git a/sys-fs/xfsprogs/xfsprogs-3.0.1.ebuild b/sys-fs/xfsprogs/xfsprogs-3.0.1.ebuild
new file mode 100644
index 000000000000..ad22095bd0d3
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-3.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.0.1.ebuild,v 1.1 2009/06/25 23:56:43 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+RDEPEND="sys-fs/e2fsprogs
+ !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-sharedlibs.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "sed include/builddefs.in failed"
+ sed -i '1iLLDFLAGS = -static' {estimate,fsr}/Makefile
+ sed -i \
+ -e "/LLDFLAGS/s:-static:$(use static && echo -all-static):" \
+ $(find -name Makefile)
+}
+
+src_compile() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+ econf \
+ --bindir=/usr/bin \
+ --sbindir=/sbin \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable nls gettext) \
+ || die "config failed"
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev || die "make install failed"
+ gen_usr_ldscript -a disk handle xfs xlog
+ prepalldocs
+}