summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-27 14:03:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-27 14:03:12 +0000
commit6385a85b98dea53649422585607c9c8e37552253 (patch)
tree4ac69ec3b679e2200748f1494254778d9852fe34 /sys-fs/udisks
parentppc/ppc64 stable wrt #364973 (diff)
downloadgentoo-2-6385a85b98dea53649422585607c9c8e37552253.tar.gz
gentoo-2-6385a85b98dea53649422585607c9c8e37552253.tar.bz2
gentoo-2-6385a85b98dea53649422585607c9c8e37552253.zip
Insert ntfs-3g to the list of well known filesystems.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/udisks')
-rw-r--r--sys-fs/udisks/ChangeLog8
-rw-r--r--sys-fs/udisks/files/udisks-1.0.2-ntfs-3g.patch14
-rw-r--r--sys-fs/udisks/udisks-1.0.2-r2.ebuild77
3 files changed, 98 insertions, 1 deletions
diff --git a/sys-fs/udisks/ChangeLog b/sys-fs/udisks/ChangeLog
index 095044cacce6..913e293f3ec2 100644
--- a/sys-fs/udisks/ChangeLog
+++ b/sys-fs/udisks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/udisks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/ChangeLog,v 1.39 2011/04/26 10:51:37 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/ChangeLog,v 1.40 2011/04/27 14:03:12 ssuominen Exp $
+
+*udisks-1.0.2-r2 (27 Apr 2011)
+
+ 27 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> +udisks-1.0.2-r2.ebuild,
+ +files/udisks-1.0.2-ntfs-3g.patch:
+ Insert ntfs-3g to the list of well known filesystems.
26 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> udisks-1.0.2-r1.ebuild:
ppc/ppc64 stable wrt #353343
diff --git a/sys-fs/udisks/files/udisks-1.0.2-ntfs-3g.patch b/sys-fs/udisks/files/udisks-1.0.2-ntfs-3g.patch
new file mode 100644
index 000000000000..0f600d7be35f
--- /dev/null
+++ b/sys-fs/udisks/files/udisks-1.0.2-ntfs-3g.patch
@@ -0,0 +1,14 @@
+Unsure if this patch should go here, or baselayout's /etc/filesystems.
+
+Waiting for upstream reply: http://bugs.freedesktop.org/show_bug.cgi?id=36361
+
+--- src/device.c
++++ src/device.c
+@@ -5909,6 +5909,7 @@
+ "vfat",
+ "exfat"
+ "ntfs",
++ "ntfs-3g",
+ NULL,
+ };
+
diff --git a/sys-fs/udisks/udisks-1.0.2-r2.ebuild b/sys-fs/udisks/udisks-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..7dd238780780
--- /dev/null
+++ b/sys-fs/udisks/udisks-1.0.2-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/udisks-1.0.2-r2.ebuild,v 1.1 2011/04/27 14:03:12 ssuominen Exp $
+
+EAPI=4
+inherit eutils bash-completion linux-info
+
+DESCRIPTION="Daemon providing interfaces to work with storage devices"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/udisks"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug doc nls remote-access"
+
+COMMON_DEPEND=">=sys-fs/udev-147[extras]
+ >=dev-libs/glib-2.16.1:2
+ >=sys-apps/dbus-1.4.0
+ >=dev-libs/dbus-glib-0.92
+ >=sys-auth/polkit-0.97
+ >=sys-block/parted-1.8.8[device-mapper]
+ >=sys-fs/lvm2-2.02.66
+ >=dev-libs/libatasmart-0.14
+ >=sys-apps/sg3_utils-1.27.20090411
+ !sys-apps/devicekit-disks"
+RDEPEND="${COMMON_DEPEND}
+ virtual/eject
+ remote-access? ( net-dns/avahi )"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )"
+
+RESTRICT="test" # this would need running dbus and sudo available
+
+pkg_setup() {
+ DOCS="AUTHORS HACKING NEWS README"
+
+ if use amd64 || use x86; then
+ CONFIG_CHECK="~USB_SUSPEND ~!IDE"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-CVE-2010-4661.patch \
+ "${FILESDIR}"/${P}-ntfs-3g.patch
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable debug verbose-mode) \
+ --enable-man-pages \
+ $(use_enable doc gtk-doc) \
+ $(use_enable remote-access) \
+ $(use_enable nls) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/etc/profile.d/udisks-bash-completion.sh
+ dobashcompletion tools/udisks-bash-completion.sh ${PN}
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ keepdir /media
+}