summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-28 06:47:00 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-28 06:47:00 +0000
commit30397a5fd8692c8933df32e878749ddbfa1c3701 (patch)
tree694d0f46b661232f6f98ebd53b08dca17dde5af4 /sys-fs/sshfs-fuse
parentslang dependency fix as per bug #141947. remove old version (diff)
downloadgentoo-2-30397a5fd8692c8933df32e878749ddbfa1c3701.tar.gz
gentoo-2-30397a5fd8692c8933df32e878749ddbfa1c3701.tar.bz2
gentoo-2-30397a5fd8692c8933df32e878749ddbfa1c3701.zip
Add patch for fue 2.6.0_pre3 thanks to gardo <dbiscocho@skydsl.com.ph> and <candrews@compucrafters.com> in bug 141768
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'sys-fs/sshfs-fuse')
-rw-r--r--sys-fs/sshfs-fuse/ChangeLog7
-rw-r--r--sys-fs/sshfs-fuse/files/sshfs-fuse-2.6.0_pre3.patch29
-rw-r--r--sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild16
3 files changed, 48 insertions, 4 deletions
diff --git a/sys-fs/sshfs-fuse/ChangeLog b/sys-fs/sshfs-fuse/ChangeLog
index 3ec064941700..7a47c93adb6c 100644
--- a/sys-fs/sshfs-fuse/ChangeLog
+++ b/sys-fs/sshfs-fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/sshfs-fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/sshfs-fuse/ChangeLog,v 1.21 2006/06/05 10:17:08 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/sshfs-fuse/ChangeLog,v 1.22 2006/07/28 06:47:00 genstef Exp $
+
+ 28 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/sshfs-fuse-2.6.0_pre3.patch, sshfs-fuse-1.6.ebuild:
+ Add patch for fue 2.6.0_pre3 thanks to gardo <dbiscocho@skydsl.com.ph> and
+ <candrews@compucrafters.com> in bug 141768
05 Jun 2006; Stefan Schweizer <genstef@gentoo.org> -sshfs-fuse-1.2.ebuild,
-sshfs-fuse-1.3.ebuild, sshfs-fuse-1.6.ebuild:
diff --git a/sys-fs/sshfs-fuse/files/sshfs-fuse-2.6.0_pre3.patch b/sys-fs/sshfs-fuse/files/sshfs-fuse-2.6.0_pre3.patch
new file mode 100644
index 000000000000..4c2cf5296a00
--- /dev/null
+++ b/sys-fs/sshfs-fuse/files/sshfs-fuse-2.6.0_pre3.patch
@@ -0,0 +1,29 @@
+diff -ur sshfs-fuse-1.6.orig/sshfs.c sshfs-fuse-1.6/sshfs.c
+--- sshfs-fuse-1.6.orig/sshfs.c 2006-07-28 08:39:55.000000000 +0200
++++ sshfs-fuse-1.6/sshfs.c 2006-07-28 08:40:30.000000000 +0200
+@@ -2349,14 +2349,14 @@
+ case KEY_HELP:
+ usage(outargs->argv[0]);
+ fuse_opt_add_arg(outargs, "-ho");
+- fuse_main(outargs->argc, outargs->argv, &sshfs_oper.oper);
++ fuse_main(outargs->argc, outargs->argv, &sshfs_oper.oper, 0);
+ exit(1);
+
+ case KEY_VERSION:
+ fprintf(stderr, "SSHFS version %s\n", PACKAGE_VERSION);
+ #if FUSE_VERSION >= 25
+ fuse_opt_add_arg(outargs, "--version");
+- fuse_main(outargs->argc, outargs->argv, &sshfs_oper.oper);
++ fuse_main(outargs->argc, outargs->argv, &sshfs_oper.oper, 0);
+ #endif
+ exit(0);
+
+@@ -2511,7 +2511,7 @@
+ check_large_read(&args);
+ g_free(tmp);
+ g_free(fsname);
+- res = fuse_main(args.argc, args.argv, cache_init(&sshfs_oper));
++ res = fuse_main(args.argc, args.argv, cache_init(&sshfs_oper), 0);
+ fuse_opt_free_args(&args);
+ fuse_opt_free_args(&sshfs.ssh_args);
+ free(sshfs.directport);
diff --git a/sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild b/sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild
index 401398c50e9b..9951ea427cfa 100644
--- a/sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild
+++ b/sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild,v 1.9 2006/06/05 10:17:08 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/sshfs-fuse/sshfs-fuse-1.6.ebuild,v 1.10 2006/07/28 06:47:00 genstef Exp $
+
+inherit eutils
DESCRIPTION="Fuse-filesystem utilizing the sftp service."
SRC_URI="mirror://sourceforge/fuse/${P}.tar.gz"
@@ -12,7 +14,15 @@ KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
SLOT="0"
IUSE=""
-src_install () {
- make DESTDIR=${D} install || die "make install failed"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if has_version '>=sys-fs/fuse-2.6.0_pre3'; then
+ epatch ${FILESDIR}/sshfs-fuse-2.6.0_pre3.patch
+ fi
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
dodoc README NEWS ChangeLog AUTHORS
}