summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-06-21 15:42:30 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-06-21 15:42:30 +0000
commit7f1ac0e8f60f82ab7686aef6e3631ca131962810 (patch)
tree2592974a9d7f589172f660fd2ff76affc0121e65 /sys-fs/s3fs
parentAdd steps to conf.d and init.d scripts to determine which beam script needs t... (diff)
downloadgentoo-2-7f1ac0e8f60f82ab7686aef6e3631ca131962810.tar.gz
gentoo-2-7f1ac0e8f60f82ab7686aef6e3631ca131962810.tar.bz2
gentoo-2-7f1ac0e8f60f82ab7686aef6e3631ca131962810.zip
Add mime-types to RDEPEND, per #257777
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sys-fs/s3fs')
-rw-r--r--sys-fs/s3fs/ChangeLog7
-rw-r--r--sys-fs/s3fs/s3fs-177-r1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/sys-fs/s3fs/ChangeLog b/sys-fs/s3fs/ChangeLog
index b470771b568d..d1c9fc151476 100644
--- a/sys-fs/s3fs/ChangeLog
+++ b/sys-fs/s3fs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/s3fs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.2 2009/03/31 22:43:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.3 2009/06/21 15:42:30 caleb Exp $
+
+*s3fs-177-r1 (21 Jun 2009)
+
+ 21 Jun 2009; Caleb Tennis <caleb@gentoo.org> +s3fs-177-r1.ebuild:
+ Add mime-types to RDEPEND, per #257777
31 Mar 2009; Caleb Tennis <caleb@gentoo.org> s3fs-177.ebuild:
x86/amd64 stable
diff --git a/sys-fs/s3fs/s3fs-177-r1.ebuild b/sys-fs/s3fs/s3fs-177-r1.ebuild
new file mode 100644
index 000000000000..f0a5c1bf630c
--- /dev/null
+++ b/sys-fs/s3fs/s3fs-177-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/s3fs-177-r1.ebuild,v 1.1 2009/06/21 15:42:30 caleb Exp $
+
+MY_PV="r${PV}-source"
+
+DESCRIPTION="Amazon mounting S3 via fuse"
+HOMEPAGE="http://s3fs.googlecode.com/"
+SRC_URI="http://s3fs.googlecode.com/files/${PN}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+DEPEND=">=net-misc/curl-7.17.1
+ >=sys-fs/fuse-2.6.0
+ dev-libs/libxml2
+ dev-libs/openssl"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin s3fs
+}