summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-02-02 00:01:45 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-02-02 00:01:45 +0000
commit0b65ecdeb8e5441d8430453778e05fc05f697b0c (patch)
treee80d0d0f36859d3c5389e33eaaa58f48549ccad6 /sys-fs/ntfs3g
parentVersion bump. (diff)
downloadgentoo-2-0b65ecdeb8e5441d8430453778e05fc05f697b0c.tar.gz
gentoo-2-0b65ecdeb8e5441d8430453778e05fc05f697b0c.tar.bz2
gentoo-2-0b65ecdeb8e5441d8430453778e05fc05f697b0c.zip
Version bump (bug #352606)
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog7
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild4
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2011.1.15.ebuild70
3 files changed, 78 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 4e94985a85bc..3ed235d6c21f 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.111 2011/01/10 18:45:12 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.112 2011/02/02 00:01:45 chutzpah Exp $
+
+*ntfs3g-2011.1.15 (01 Feb 2011)
+
+ 01 Feb 2011; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-2011.1.15.ebuild:
+ Version bump (bug #352606)
10 Jan 2011; Brent Baude <ranger@gentoo.org> ntfs3g-2010.8.8.ebuild:
stable ppc, bug 346097
diff --git a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
index 91de2acf2ea8..e39d5acf8632 100644
--- a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.7 2010/12/19 01:08:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.8 2011/02/02 00:01:45 chutzpah Exp $
EAPI=2
inherit linux-info
diff --git a/sys-fs/ntfs3g/ntfs3g-2011.1.15.ebuild b/sys-fs/ntfs3g/ntfs3g-2011.1.15.ebuild
new file mode 100644
index 000000000000..76b12ea0d30e
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2011.1.15.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2011.1.15.ebuild,v 1.1 2011/02/02 00:01:45 chutzpah Exp $
+
+EAPI=2
+inherit linux-info
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug suid xattr +udev +external-fuse"
+
+RDEPEND="external-fuse? ( >=sys-fs/fuse-2.8.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/attr"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
+ --disable-ldconfig \
+ --with-fuse=$(use external-fuse && echo external || echo internal) \
+ $(use_enable acl posix-acls) \
+ $(use_enable xattr xattr-mappings) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog CREDITS README
+
+ use suid && fperms u+s "/bin/${MY_PN}"
+
+ if use udev; then
+ insinto /etc/udev/rules.d/
+ doins "${FILESDIR}/99-ntfs3g.rules"
+ fi
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}